aboutsummaryrefslogtreecommitdiff
path: root/mail/razor-agents/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-12 19:59:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-12 19:59:00 +0000
commit3c61e59373cfdcd00e2f645f88a91437f4b0522e (patch)
tree9ba606ca1ae270d3fb1a973d8ae015ebe726041c /mail/razor-agents/Makefile
parent2b75b207cdf816af1b67fcb248362667ce3815a7 (diff)
downloadports-3c61e59373cfdcd00e2f645f88a91437f4b0522e.tar.gz
ports-3c61e59373cfdcd00e2f645f88a91437f4b0522e.zip
add razor-agent
A distributed, collaborative, spam detection and filtering network PR: 32739 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com>
Notes
Notes: svn path=/head/; revision=51412
Diffstat (limited to 'mail/razor-agents/Makefile')
-rw-r--r--mail/razor-agents/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/mail/razor-agents/Makefile b/mail/razor-agents/Makefile
new file mode 100644
index 000000000000..9cb9068e6c19
--- /dev/null
+++ b/mail/razor-agents/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: razor-agents
+# Date created: 29 November 2001
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= razor-agents
+PORTVERSION= 1.17
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= razor
+
+MAINTAINER= leeym@leeym.com
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN1= razor-check.1 razor-discover.1 razor-report.1
+MAN3= Razor::Client.3 Razor::Errorhandler.3
+
+.include <bsd.port.mk>