aboutsummaryrefslogtreecommitdiff
path: root/mail/rubygem-actionmailer41
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-08-09 17:16:21 +0000
committerSteve Wills <swills@FreeBSD.org>2015-08-09 17:16:21 +0000
commitc28e531b8789cdc7ef4c001243da1b9bf8e586be (patch)
tree2e6e009c5aa329f0d5f61236c1ab8d7ab01366a4 /mail/rubygem-actionmailer41
parentb4d9bc604cbf28ec0ff2e8e58438b886e0b0181c (diff)
downloadports-c28e531b8789cdc7ef4c001243da1b9bf8e586be.tar.gz
ports-c28e531b8789cdc7ef4c001243da1b9bf8e586be.zip
mail/rubygem-actionmailer41: create port
Add rails 4.1 version of actionmailer PR: 201823 Submitted by: Torsten Zühlsdorff <ports@toco-domains.de>
Notes
Notes: svn path=/head/; revision=393811
Diffstat (limited to 'mail/rubygem-actionmailer41')
-rw-r--r--mail/rubygem-actionmailer41/Makefile25
-rw-r--r--mail/rubygem-actionmailer41/distinfo2
-rw-r--r--mail/rubygem-actionmailer41/pkg-descr10
3 files changed, 37 insertions, 0 deletions
diff --git a/mail/rubygem-actionmailer41/Makefile b/mail/rubygem-actionmailer41/Makefile
new file mode 100644
index 000000000000..8651b6a29b4b
--- /dev/null
+++ b/mail/rubygem-actionmailer41/Makefile
@@ -0,0 +1,25 @@
+# Created by: Torsten Zühlsdorff <ports@toco-domains.de>
+# $FreeBSD$
+
+PORTNAME= actionmailer
+PORTVERSION= 4.1.12
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 41
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Easy email delivery and testing for Ruby
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-actionpack41>=${PORTVERSION}:${PORTSDIR}/www/rubygem-actionpack41 \
+ rubygem-actionview41>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-actionview41 \
+ rubygem-mail>=2.5.4:${PORTSDIR}/mail/rubygem-mail
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PORTSCOUT= limit:^4\.1
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-actionmailer41/distinfo b/mail/rubygem-actionmailer41/distinfo
new file mode 100644
index 000000000000..3b7f6a301c53
--- /dev/null
+++ b/mail/rubygem-actionmailer41/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/actionmailer-4.1.12.gem) = 55c44ed99ce8c0e5d4daa2d1bab169033b3b1b3b3b09ed88b264ede264f3305c
+SIZE (rubygem/actionmailer-4.1.12.gem) = 25088
diff --git a/mail/rubygem-actionmailer41/pkg-descr b/mail/rubygem-actionmailer41/pkg-descr
new file mode 100644
index 000000000000..2af9adc06c58
--- /dev/null
+++ b/mail/rubygem-actionmailer41/pkg-descr
@@ -0,0 +1,10 @@
+Action Mailer is framework for designing email-service layers. These layers
+are used to consolidate code for sending out forgotten passwords, welcoming
+wishes on signup, invoices for billing, and any other use case that requires
+a written notification to either a person or another system.
+
+Additionally, an Action Mailer class can be used to process incoming email,
+such as allowing a weblog to accept new posts from an email (which could even
+have been sent from a phone)
+
+WWW: http://www.rubyonrails.org