aboutsummaryrefslogtreecommitdiff
path: root/mail/sendmail811
diff options
context:
space:
mode:
authorGregory Neil Shapiro <gshapiro@FreeBSD.org>2000-10-14 04:51:41 +0000
committerGregory Neil Shapiro <gshapiro@FreeBSD.org>2000-10-14 04:51:41 +0000
commitcef9c4b2b88a0af01b45d01d9666a06c517f9449 (patch)
tree7eea26a486c6f2ff331453f1b80f3983d9529a5f /mail/sendmail811
parent90d103f7cccf0eaaed04de7bed64f238f6520294 (diff)
downloadports-cef9c4b2b88a0af01b45d01d9666a06c517f9449.tar.gz
ports-cef9c4b2b88a0af01b45d01d9666a06c517f9449.zip
New port for the sendmail MTA.
PR: 18415 Submitted by: Dirk Meyer <dirk.meyer@dinoex.sub.org> Reviewed by: will
Notes
Notes: svn path=/head/; revision=33808
Diffstat (limited to 'mail/sendmail811')
-rw-r--r--mail/sendmail811/Makefile86
-rw-r--r--mail/sendmail811/distinfo1
-rw-r--r--mail/sendmail811/files/site.config.m47
-rw-r--r--mail/sendmail811/files/site.config.m4.pre41
-rw-r--r--mail/sendmail811/pkg-comment1
-rw-r--r--mail/sendmail811/pkg-descr11
-rw-r--r--mail/sendmail811/pkg-message29
-rw-r--r--mail/sendmail811/pkg-plist12
8 files changed, 148 insertions, 0 deletions
diff --git a/mail/sendmail811/Makefile b/mail/sendmail811/Makefile
new file mode 100644
index 000000000000..da47806b6372
--- /dev/null
+++ b/mail/sendmail811/Makefile
@@ -0,0 +1,86 @@
+# New ports collection makefile for: sendmail
+# Date created: 20 Apr 2000
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sendmail
+PORTVERSION= 8.11.1
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+
+NO_PACKAGE= "sendmail included in base system"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PLIST= ${WRKDIR}/.PLIST.more
+
+.if exists(/etc/mail/mailer.conf)
+pre-configure:
+ ${SED} -e "s=%%PREFIX%%=${PREFIX}=" \
+ ${FILESDIR}/site.config.m4 >${WRKSRC}/devtools/Site/site.config.m4
+.else
+pre-configure:
+ ${SED} -e "s=%%PREFIX%%=${PREFIX}=" \
+ ${FILESDIR}/site.config.m4.pre4 >${WRKSRC}/devtools/Site/site.config.m4
+
+PREFIX?= ${DESTDIR}/usr
+MANPREFIX?= ${DESTDIR}/usr/share
+.endif
+
+PLIST_SUB+= PREFIX=${PREFIX:S=${PREFIX}/==}
+SENDMAIL= ${PREFIX}/sbin/sendmail
+
+MAN1= mailq.1 newaliases.1 vacation.1
+MAN5= aliases.5
+MAN8= sendmail.8 mailstats.8 makemap.8 praliases.8 smrsh.8 \
+ mail.local.8 rmail.8
+
+pre-install:
+ ${CAT} ${PKGDIR}/pkg-plist >${PLIST}
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && find cf -type f | \
+ ${AWK} '{print "share/sendmail/" $$1}' >>${PLIST}
+ cd ${WRKSRC} && find -d cf -type d | \
+ ${AWK} '{print "@dirrm share/sendmail/" $$1}' >>${PLIST}
+.endif
+
+# We want mail.local and rmail for our system.
+# the build install catmans only, we have to fix this.
+post-install:
+ ( cd ${WRKSRC}/mail.local && ${MAKE} force-install )
+ ( cd ${WRKSRC}/rmail && ${MAKE} force-install )
+.for i in ${MAN8}
+ @${RM} -f ${MANPREFIX}/man/cat8/${i} ${MANPREFIX}/man/cat8/${i}.gz
+ ${INSTALL_MAN} ${WRKSRC}/*/${i} ${MANPREFIX}/man/man8
+.endfor
+.for i in ${MAN5}
+ @${RM} -f ${MANPREFIX}/man/cat5/${i} ${MANPREFIX}/man/cat5/${i}.gz
+ ${INSTALL_MAN} ${WRKSRC}/*/${i} ${MANPREFIX}/man/man5
+.endfor
+.for i in ${MAN1}
+ @${RM} -f ${MANPREFIX}/man/cat1/${i} ${MANPREFIX}/man/cat1/${i}.gz
+ ${INSTALL_MAN} ${WRKSRC}/*/${i} ${MANPREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/sendmail
+ @cd ${WRKSRC}; ${TAR} cf - cf |\
+ (cd ${PREFIX}/share/sendmail; ${TAR} xf -)
+.endif
+.if exists(${DESTDIR}/etc/mail/mailer.conf)
+ @${SED} s!%%PREFIX%%!${PREFIX}!g ${PKGDIR}/pkg-message
+
+mailer.conf:
+ ${SED} \
+ -e "s=^sendmail[ ]*/.*$$=sendmail ${SENDMAIL}=" \
+ -e "s=^send-mail[ ]*/.*$$=send-mail ${SENDMAIL}=" \
+ -e "s=^mailq[ ]*/.*$$=mailq ${SENDMAIL}=" \
+ -e "s=^newaliases[ ]*/.*$$=newaliases ${SENDMAIL}=" \
+ ${DESTDIR}/etc/mail/mailer.conf > ${DESTDIR}/etc/mail/mailer.conf.new
+ ${MV} ${DESTDIR}/etc/mail/mailer.conf.new ${DESTDIR}/etc/mail/mailer.conf
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/sendmail811/distinfo b/mail/sendmail811/distinfo
new file mode 100644
index 000000000000..0cf3cf85dbdb
--- /dev/null
+++ b/mail/sendmail811/distinfo
@@ -0,0 +1 @@
+MD5 (sendmail.8.11.1.tar.gz) = 9118a555141493fb574a588d50f57215
diff --git a/mail/sendmail811/files/site.config.m4 b/mail/sendmail811/files/site.config.m4
new file mode 100644
index 000000000000..6e8776bc7e70
--- /dev/null
+++ b/mail/sendmail811/files/site.config.m4
@@ -0,0 +1,7 @@
+define(`confEBINDIR',`%%PREFIX%%/libexec')
+define(`confMANROOT',`%%PREFIX%%/man/cat')
+define(`confMANROOTMAN',`%%PREFIX%%/man/man')
+define(`confMBINDIR',`%%PREFIX%%/sbin')
+define(`confSBINDIR',`%%PREFIX%%/sbin')
+define(`confUBINDIR',`%%PREFIX%%/bin')
+define(`confCCOPTS',`-DCMDDIR="\"%%PREFIX%%/libexec/sm.bin\"" -DPATH="\"/bin:/usr/bin\""')
diff --git a/mail/sendmail811/files/site.config.m4.pre4 b/mail/sendmail811/files/site.config.m4.pre4
new file mode 100644
index 000000000000..a1703e5f812f
--- /dev/null
+++ b/mail/sendmail811/files/site.config.m4.pre4
@@ -0,0 +1 @@
+define(`confCCOPTS',`-DCMDDIR="\"%%PREFIX%%/libexec/sm.bin\"" -DPATH="\"/bin:/usr/bin\""')
diff --git a/mail/sendmail811/pkg-comment b/mail/sendmail811/pkg-comment
new file mode 100644
index 000000000000..6815e8e88ecb
--- /dev/null
+++ b/mail/sendmail811/pkg-comment
@@ -0,0 +1 @@
+Reliable, highly configurable mail transfer agent with associated utilities
diff --git a/mail/sendmail811/pkg-descr b/mail/sendmail811/pkg-descr
new file mode 100644
index 000000000000..21e2ecf498f9
--- /dev/null
+++ b/mail/sendmail811/pkg-descr
@@ -0,0 +1,11 @@
+Sendmail implements a general purpose internetwork mail routing facility
+under the UNIX operating system. It is not tied to any one transport
+protocol - its function may be likened to a crossbar switch, relaying
+messages from one domain into another. In the process, it can do a limited
+amount of message header editing to put the message into a format that is
+appropriate for the receiving domain. All of this is done under the
+control of a configuration file.
+
+Sendmail is a trademark of Sendmail, Inc.
+
+WWW: http://www.sendmail.org/
diff --git a/mail/sendmail811/pkg-message b/mail/sendmail811/pkg-message
new file mode 100644
index 000000000000..3182ce372cfa
--- /dev/null
+++ b/mail/sendmail811/pkg-message
@@ -0,0 +1,29 @@
+
+---------------------------------------------------
+
+If you update your configuration from 8.9.x add the following to your
+'*.mc' file(s):
+
+MODIFY_MAILER_FLAGS(`LOCAL', `+S')dnl
+
+because mail.local is no longer installed set-user-id root. This is not
+needed if you are using FEATURE(`local_lmtp').
+
+To activate sendmail as your default mailer, call the target 'mailer.conf':
+
+$ make mailer.conf
+
+Your '/etc/mail/mailer.conf' should look like this:
+
+#
+# Execute the "real" sendmail program, named /usr/libexec/sendmail/sendmail
+#
+sendmail %%PREFIX%%/sbin/sendmail
+send-mail %%PREFIX%%/sbin/sendmail
+mailq %%PREFIX%%/sbin/sendmail
+newaliases %%PREFIX%%/sbin/sendmail
+
+You may also need to update /etc/rc.conf.
+
+---------------------------------------------------
+
diff --git a/mail/sendmail811/pkg-plist b/mail/sendmail811/pkg-plist
new file mode 100644
index 000000000000..9dad06e7a4bb
--- /dev/null
+++ b/mail/sendmail811/pkg-plist
@@ -0,0 +1,12 @@
+bin/hoststat
+bin/mailq
+bin/newaliases
+bin/purgestat
+bin/rmail
+bin/vacation
+libexec/mail.local
+libexec/smrsh
+sbin/mailstats
+sbin/makemap
+sbin/praliases
+sbin/sendmail