aboutsummaryrefslogtreecommitdiff
path: root/mail/smtpclient
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-26 17:57:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-26 17:57:10 +0000
commit7eaa211d56eb8671dbb393befd76cba6c2d8fe42 (patch)
treea99453b478fd2635f210ae887d15a605cbd2ceff /mail/smtpclient
parente784a335674ca207343828410fbc3910101fdac7 (diff)
downloadports-7eaa211d56eb8671dbb393befd76cba6c2d8fe42.tar.gz
ports-7eaa211d56eb8671dbb393befd76cba6c2d8fe42.zip
- Teach -c toggle to behave as described in man page
PR: ports/63324 Submitted by: Malcolm Kay <malcolm.kay@internode.on.net>
Notes
Notes: svn path=/head/; revision=110080
Diffstat (limited to 'mail/smtpclient')
-rw-r--r--mail/smtpclient/Makefile1
-rw-r--r--mail/smtpclient/files/patch-smtpclient_main_c27
2 files changed, 26 insertions, 2 deletions
diff --git a/mail/smtpclient/Makefile b/mail/smtpclient/Makefile
index 88a014066f87..55fc350981c9 100644
--- a/mail/smtpclient/Makefile
+++ b/mail/smtpclient/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smtpclient
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.engelschall.com/sw/smtpclient/distrib/
diff --git a/mail/smtpclient/files/patch-smtpclient_main_c b/mail/smtpclient/files/patch-smtpclient_main_c
index 4d2a7838895a..a79101e26486 100644
--- a/mail/smtpclient/files/patch-smtpclient_main_c
+++ b/mail/smtpclient/files/patch-smtpclient_main_c
@@ -1,5 +1,5 @@
---- smtpclient_main.c.orig Wed Aug 1 15:25:22 2001
-+++ smtpclient_main.c Wed Aug 1 15:33:07 2001
+--- smtpclient_main.c.orig Tue Feb 24 11:49:07 2004
++++ smtpclient_main.c Tue Feb 24 12:47:11 2004
@@ -86,7 +86,7 @@ void log(char *str, ...)
char buf[1024];
@@ -29,3 +29,26 @@
}
from_addr = strdup(buf);
}
+@@ -453,8 +453,20 @@ int main(int argc, char **argv)
+ chat("MAIL FROM: <%s>\r\n", from_addr);
+ for (i = optind; i < argc; i++)
+ chat("RCPT TO: <%s>\r\n", argv[i]);
+- if (cc_addr)
+- chat("RCPT TO: <%s>\r\n", cc_addr);
++ if (cc_addr) {
++ char *cc_tmp,*p;
++ if(!(cc_tmp=malloc(strlen(cc_addr+1)))) {
++ log("memory allocation failed.");
++ exit(1);
++ }
++ strcpy(cc_tmp,cc_addr);
++ p=strtok(cc_tmp,",");
++ while(p) {
++ chat("RCPT TO: <%s>\r\n", p);
++ p=strtok(NULL,",");
++ }
++ free(cc_tmp);
++ }
+ chat("DATA\r\n");
+
+ /*