aboutsummaryrefslogtreecommitdiff
path: root/mail/spamguard/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-11-18 21:56:41 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-11-18 21:56:41 +0000
commitbed0260f04b4294d358a21a0e933ad3e919389dc (patch)
tree7f3ca98f8439ecb67988da667db61d2af904ab81 /mail/spamguard/Makefile
parent97035073308ef555a8449baf93d19ce0a000e442 (diff)
downloadports-bed0260f04b4294d358a21a0e933ad3e919389dc.tar.gz
ports-bed0260f04b4294d358a21a0e933ad3e919389dc.zip
Add spamguard 1.6, MTA spam prevention program for qmail/postfix/sendmail.
Nearly all of today's mail system administrators face spam as their first threat. Because of this, EnderUNIX team has written this small application to automagically monitor malicious spammer activity in your mail server logs. spamGuard is written purely in C, to stop spammers hanging around. The program supports nearly all mostly used MTAs; qmail (both multilog and splogger), sendmail and Postfix. WWW: http://www.enderunix.org/spamguard PR: 58499 Submitted by: Omer Faruk Sen <ofsen@enderunix.org>
Notes
Notes: svn path=/head/; revision=94297
Diffstat (limited to 'mail/spamguard/Makefile')
-rw-r--r--mail/spamguard/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail/spamguard/Makefile b/mail/spamguard/Makefile
new file mode 100644
index 000000000000..40f5977b3b63
--- /dev/null
+++ b/mail/spamguard/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: spamguard
+# Date created: 21 Oct 2003
+# Whom: Omer Faruk Sen <ofsen@enderunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spamguard
+PORTVERSION= 1.6
+CATEGORIES= mail
+MASTER_SITES= http://www.enderunix.org/spamguard/
+
+MAINTAINER= ofsen@enderunix.org
+COMMENT= MTA spam prevention program for qmail/postfix/sendmail
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+DOCS= AUTHORS CHANGELOG COPYING INSTALL \
+ POST-INSTALL README THANKS
+DOCS_TR= BENIOKU COPYING DEGISIKLIKLER KURULUM \
+ KURULUM-SONRASI YAPILACAKLAR YAZARLAR
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/spamguard ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/*.sample ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/tr
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC}/tr && ${INSTALL_DATA} ${DOCS_TR} ${DOCSDIR}/tr
+.endif
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' pkg-message > ${PKGMESSAGE}
+
+.include <bsd.port.mk>