aboutsummaryrefslogtreecommitdiff
path: root/mail/spmfilter-spamassassin
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-05-17 23:51:50 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-05-17 23:51:50 +0000
commit9ca8fcc7dfd758ac56343527f25a7a94899108b7 (patch)
treefa0ea1ee40cf58c1868963eb94edc8fa0025c658 /mail/spmfilter-spamassassin
parent9ad145c15f6e4c13ec026b4602e6404f7af624cf (diff)
downloadports-9ca8fcc7dfd758ac56343527f25a7a94899108b7.tar.gz
ports-9ca8fcc7dfd758ac56343527f25a7a94899108b7.zip
spmfilter-spamassassin is a plugin for spmfilter that enables spmfilter to
spam-check emails with the help of the daemonized version of Spamassassin (spamd). The major goal of this plugin is to provide an easy way for spam-checking messages. WWW: http://www.spmfilter.org/ PR: ports/146161 Submitted by: Axel Steiner <ast at treibsand.com> Approved by: wxs@ (mentor)
Notes
Notes: svn path=/head/; revision=254512
Diffstat (limited to 'mail/spmfilter-spamassassin')
-rw-r--r--mail/spmfilter-spamassassin/Makefile47
-rw-r--r--mail/spmfilter-spamassassin/distinfo3
-rw-r--r--mail/spmfilter-spamassassin/pkg-descr6
-rw-r--r--mail/spmfilter-spamassassin/pkg-plist5
4 files changed, 61 insertions, 0 deletions
diff --git a/mail/spmfilter-spamassassin/Makefile b/mail/spmfilter-spamassassin/Makefile
new file mode 100644
index 000000000000..bf72169765e5
--- /dev/null
+++ b/mail/spmfilter-spamassassin/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: spmfilter-spamassassin
+# Date created: 2010-04-29
+# Whom: Axel Steiner <ast@treibsand.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spmfilter-spamassassin
+PORTVERSION= 0.1
+CATEGORIES= mail
+MASTER_SITES= http://www.spmfilter.org/attachments/download/58/
+
+MAINTAINER= ast@treibsand.com
+COMMENT= Spamassassin plugin for spmfilter
+
+BUILD_DEPENDS= spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
+RUN_DEPENDS= spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
+
+USE_CMAKE= yes
+CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
+ -DCMAKE_LIBRARY_PATH="${LOCALBASE}/lib"
+
+USE_LDCONFIG= ${PREFIX}/lib/spmfilter
+
+OPTIONS= DEBUG "Enable Debugging" off
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+CMAKE_USE_PTHREAD= yes
+.endif
+
+.if defined(WITH_DEBUG)
+CMAKE_ARGS+= -DENABLE_DEBUG=TRUE
+.endif
+
+MAN1= ${PORTNAME}.1 \
+ smf-spamq.1 \
+ smf-spamctl.1
+
+MANCOMPRESSED= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|' \
+ ${WRKSRC}/cmake/Modules/SMFMacros.cmake
+
+.include <bsd.port.post.mk>
diff --git a/mail/spmfilter-spamassassin/distinfo b/mail/spmfilter-spamassassin/distinfo
new file mode 100644
index 000000000000..eb371da9b111
--- /dev/null
+++ b/mail/spmfilter-spamassassin/distinfo
@@ -0,0 +1,3 @@
+MD5 (spmfilter-spamassassin-0.1.tar.gz) = 139e605703d9e6f7dfe767c8a17d81c6
+SHA256 (spmfilter-spamassassin-0.1.tar.gz) = 7e7053314e4b2efbad5a3f8493017769bfc6ed1ae727af5699ade677cd977e86
+SIZE (spmfilter-spamassassin-0.1.tar.gz) = 10384
diff --git a/mail/spmfilter-spamassassin/pkg-descr b/mail/spmfilter-spamassassin/pkg-descr
new file mode 100644
index 000000000000..9ad428041e5f
--- /dev/null
+++ b/mail/spmfilter-spamassassin/pkg-descr
@@ -0,0 +1,6 @@
+spmfilter-spamassassin is a plugin for spmfilter that enables spmfilter to
+spam-check emails with the help of the daemonized version of Spamassassin
+(spamd). The major goal of this plugin is to provide an easy way for
+spam-checking messages.
+
+WWW: http://www.spmfilter.org/
diff --git a/mail/spmfilter-spamassassin/pkg-plist b/mail/spmfilter-spamassassin/pkg-plist
new file mode 100644
index 000000000000..7b490b2a2279
--- /dev/null
+++ b/mail/spmfilter-spamassassin/pkg-plist
@@ -0,0 +1,5 @@
+bin/smf-spamq
+bin/smf-spamctl
+lib/spmfilter/libspamassassin.so
+lib/spmfilter/libspamassassin.so.0.1
+@dirrmtry lib/spmfilter