aboutsummaryrefslogtreecommitdiff
path: root/mail/spruce
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-06-11 08:29:17 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-06-11 08:29:17 +0000
commit7e169a4a79c6adef19b89370f18cd0e0cfd35541 (patch)
treed1d227367470fc2ed719528212def54a15e585f3 /mail/spruce
parentc1e2ca9143af3ecb249b586a161f1ce2f9149328 (diff)
downloadports-7e169a4a79c6adef19b89370f18cd0e0cfd35541.tar.gz
ports-7e169a4a79c6adef19b89370f18cd0e0cfd35541.zip
A simple GTK based email client.
PR: 12039 Submitted by: Chris Piazza <cpiazza@home.net>
Notes
Notes: svn path=/head/; revision=19418
Diffstat (limited to 'mail/spruce')
-rw-r--r--mail/spruce/Makefile26
-rw-r--r--mail/spruce/distinfo1
-rw-r--r--mail/spruce/files/patch-ab17
-rw-r--r--mail/spruce/files/patch-ad13
-rw-r--r--mail/spruce/files/patch-ae10
-rw-r--r--mail/spruce/pkg-comment1
-rw-r--r--mail/spruce/pkg-descr6
-rw-r--r--mail/spruce/pkg-plist18
8 files changed, 92 insertions, 0 deletions
diff --git a/mail/spruce/Makefile b/mail/spruce/Makefile
new file mode 100644
index 000000000000..1dc7736d5622
--- /dev/null
+++ b/mail/spruce/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: spruce
+# Version required: 0.4.5
+# Date created: 05 June 1999
+# Whom: Chris Piazza <cpiazza@home.net>
+#
+# $Id$
+#
+
+DISTNAME= spruce-0.4.5
+CATEGORIES= mail
+MASTER_SITES= http://www.xtorshun.org/spruce/
+
+MAINTAINER= cpiazza@home.net
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/spruce ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/spruce
+ ${INSTALL_DATA} ${WRKSRC}/xpm/* ${PREFIX}/share/spruce
+
+.include <bsd.port.mk>
diff --git a/mail/spruce/distinfo b/mail/spruce/distinfo
new file mode 100644
index 000000000000..9bc238d2c3b6
--- /dev/null
+++ b/mail/spruce/distinfo
@@ -0,0 +1 @@
+MD5 (spruce-0.4.5.tar.gz) = 3b47eac8450fd37aeab2d133c94bd01a
diff --git a/mail/spruce/files/patch-ab b/mail/spruce/files/patch-ab
new file mode 100644
index 000000000000..45bd62c49b89
--- /dev/null
+++ b/mail/spruce/files/patch-ab
@@ -0,0 +1,17 @@
+--- server.h.orig Fri May 21 18:34:59 1999
++++ server.h Sat Jun 5 14:55:46 1999
+@@ -19,12 +19,11 @@
+ #ifndef SERVER_H
+ #define SERVER_H
+
+-#include <sys/socket.h>
+ #include <sys/types.h>
+-#include <sys/param.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
+-#include <netinet/in.h>
+ #include <unistd.h>
+ #include <string.h>
+ #include <stdlib.h>
diff --git a/mail/spruce/files/patch-ad b/mail/spruce/files/patch-ad
new file mode 100644
index 000000000000..97794705a372
--- /dev/null
+++ b/mail/spruce/files/patch-ad
@@ -0,0 +1,13 @@
+--- sockio.h.orig Mon May 17 17:42:53 1999
++++ sockio.h Sat Jun 5 14:55:46 1999
+@@ -19,9 +19,8 @@
+ #ifndef SOCKIO_H
+ #define SOCKIO_H
+
+-#include <sys/socket.h>
+ #include <sys/types.h>
+-#include <sys/param.h>
++#include <sys/socket.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
+ #include <unistd.h>
diff --git a/mail/spruce/files/patch-ae b/mail/spruce/files/patch-ae
new file mode 100644
index 000000000000..f6049b114c34
--- /dev/null
+++ b/mail/spruce/files/patch-ae
@@ -0,0 +1,10 @@
+--- smtpio.c.orig Sat Jun 5 10:54:01 1999
++++ smtpio.c Sat Jun 5 14:55:46 1999
+@@ -17,6 +17,7 @@
+ */
+
+ #include "smtpio.h"
++#include <sys/param.h>
+
+ static char *smtp_errlist[] = {"",
+ ": Hostname failed to resolve",
diff --git a/mail/spruce/pkg-comment b/mail/spruce/pkg-comment
new file mode 100644
index 000000000000..df79b74f8d2a
--- /dev/null
+++ b/mail/spruce/pkg-comment
@@ -0,0 +1 @@
+A simple GTK based email client.
diff --git a/mail/spruce/pkg-descr b/mail/spruce/pkg-descr
new file mode 100644
index 000000000000..1d013cb1ea66
--- /dev/null
+++ b/mail/spruce/pkg-descr
@@ -0,0 +1,6 @@
+Spruce is a very simple email client that uses GTK+ for it's user interface.
+
+WWW: http://www.xtorshun.org/spruce/
+
+-Chris Piazza
+cpiazza@home.net
diff --git a/mail/spruce/pkg-plist b/mail/spruce/pkg-plist
new file mode 100644
index 000000000000..bf662c465da3
--- /dev/null
+++ b/mail/spruce/pkg-plist
@@ -0,0 +1,18 @@
+bin/spruce
+share/spruce/attach.xpm
+share/spruce/csave.xpm
+share/spruce/del.xpm
+share/spruce/fwd.xpm
+share/spruce/maddr.xpm
+share/spruce/msave.xpm
+share/spruce/new.xpm
+share/spruce/reply.xpm
+share/spruce/send.xpm
+share/spruce/splashscreen.xpm
+share/spruce/splashscreen2.xpm
+share/spruce/spruce-attach.xpm
+share/spruce/spruce-comp-save.xpm
+share/spruce/spruce-icon.xpm
+share/spruce/spruce-options.xpm
+share/spruce/spruce-send.xpm
+@dirrm share/spruce