aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-compatibility-plugin/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-07-20 09:17:51 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-07-20 09:17:51 +0000
commitc0273732af025218a6d378d991a688b7b64207cd (patch)
tree5a02f6083010b4759062967129bea0ed427f3bb5 /mail/squirrelmail-compatibility-plugin/Makefile
parent4a8c580001d30f83826756318e232e05a31bae9a (diff)
downloadports-c0273732af025218a6d378d991a688b7b64207cd.tar.gz
ports-c0273732af025218a6d378d991a688b7b64207cd.zip
- Update to 2.0.8
- Pass maintainership to submitter - Rework Makefile for easier readability - Reformat pkg-descr PR: ports/114480 Submitted by: Thomas Abthorpe <thomas@goodking.ca> Reviewed by: Neil Darlow <neil at darlow.co.uk> Approved by: Alexander Wittig <alexander@wittig.name> (maintainer)
Notes
Notes: svn path=/head/; revision=195936
Diffstat (limited to 'mail/squirrelmail-compatibility-plugin/Makefile')
-rw-r--r--mail/squirrelmail-compatibility-plugin/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/mail/squirrelmail-compatibility-plugin/Makefile b/mail/squirrelmail-compatibility-plugin/Makefile
index 7af909523510..0c30915ca3de 100644
--- a/mail/squirrelmail-compatibility-plugin/Makefile
+++ b/mail/squirrelmail-compatibility-plugin/Makefile
@@ -4,35 +4,39 @@
#
# $FreeBSD$
-PORTNAME= squirrelmail
-PORTVERSION= 2.0.6
-PORTREVISION= 1
+PORTNAME= compatibility
+PORTVERSION= 2.0.8
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMESUFFIX= -${SQUIRREL_PLUGIN_NAME}-plugin
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1.0
DIST_SUBDIR= squirrelmail
-MAINTAINER= alexander@wittig.name
+MAINTAINER= thomas@goodking.ca
COMMENT= Required by many plugins for compatibility with SquirrelMail
-RUN_DEPENDS= squirrelmail>=1.4.9:${PORTSDIR}/mail/squirrelmail
+RUN_DEPENDS= squirrelmail>=1.4.10:${PORTSDIR}/mail/squirrelmail
CONFLICTS= squirrelmail-compatibility-plugin-1.*
-SQUIRREL_PLUGIN_NAME= compatibility
+SQUIRREL_PLUGIN_NAME= ${PORTNAME}
.ifdef SQUIRRELDIR
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
.else
-. ifndef WITHOUT_WWWDIR
+.ifndef WITHOUT_WWWDIR
SQUIRRELDIR= ${PREFIX}/www/squirrelmail
PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-. else
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+.else
SQUIRRELDIR= ${PREFIX}/squirrelmail
PLIST_SUB+= SQUIRRELDIR=squirrelmail
-. endif
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+.endif
.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -56,11 +60,12 @@ pre-everything::
do-install:
${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
post-install:
@${ECHO} "Patching SquirrelMail for compatibility plugin"
@${ECHO} ""
- ${PATCH} -sN -p0 -d ${SQUIRRELDIR}/plugins/compatibility < ${SQUIRRELDIR}/plugins/compatibility/patches/compatibility_patch-1.4.9.diff
+ ${PATCH} -sN -p0 -d ${SQUIRRELDIR}/plugins/compatibility < ${SQUIRRELDIR}/plugins/compatibility/patches/compatibility_patch-1.4.10.diff
@${ECHO} ""
.ifndef WITHOUT_ACTIVATE