aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-compatibility-plugin1
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-07-20 09:26:39 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-07-20 09:26:39 +0000
commit60af9968e1a1bb24bb0f3c6f533f1679d1510532 (patch)
tree7fa42b91956dd676405416060da1b62968cfd16c /mail/squirrelmail-compatibility-plugin1
parentca4d6d103a75d30eee022c09b18ce1d0856e4461 (diff)
downloadports-60af9968e1a1bb24bb0f3c6f533f1679d1510532.tar.gz
ports-60af9968e1a1bb24bb0f3c6f533f1679d1510532.zip
- Pass maintainership to submitter
- Rework Makefile for easier readability - Reformat pkg-descr - Bump portrevision (file owner/group changed) PR: ports/114482 Submitted by: Thomas Abthorpe <thomas@goodking.ca> Approved by: Alexander Wittig <alexander@wittig.name> (maintainer)
Notes
Notes: svn path=/head/; revision=195939
Diffstat (limited to 'mail/squirrelmail-compatibility-plugin1')
-rw-r--r--mail/squirrelmail-compatibility-plugin1/Makefile22
-rw-r--r--mail/squirrelmail-compatibility-plugin1/pkg-descr11
-rw-r--r--mail/squirrelmail-compatibility-plugin1/pkg-plist4
3 files changed, 20 insertions, 17 deletions
diff --git a/mail/squirrelmail-compatibility-plugin1/Makefile b/mail/squirrelmail-compatibility-plugin1/Makefile
index 6ea2fdc81dcb..8b134127f4bf 100644
--- a/mail/squirrelmail-compatibility-plugin1/Makefile
+++ b/mail/squirrelmail-compatibility-plugin1/Makefile
@@ -4,34 +4,39 @@
#
# $FreeBSD$
-PORTNAME= squirrelmail
+PORTNAME= compatibility
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMESUFFIX= -${SQUIRREL_PLUGIN_NAME}-plugin
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
DIST_SUBDIR= squirrelmail
-MAINTAINER= alexander@wittig.name
+MAINTAINER= thomas@goodking.ca
COMMENT= Required by many plugins for compatibility with SquirrelMail
RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
CONFLICTS= squirrelmail-compatibility-plugin-2.*
-SQUIRREL_PLUGIN_NAME= compatibility
+SQUIRREL_PLUGIN_NAME= ${PORTNAME}
.ifdef SQUIRRELDIR
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
.else
-. ifndef WITHOUT_WWWDIR
+.ifndef WITHOUT_WWWDIR
SQUIRRELDIR= ${PREFIX}/www/squirrelmail
PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-. else
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+.else
SQUIRRELDIR= ${PREFIX}/squirrelmail
PLIST_SUB+= SQUIRRELDIR=squirrelmail
-. endif
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+.endif
.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -55,6 +60,7 @@ pre-everything::
do-install:
${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
post-install:
.ifndef WITHOUT_ACTIVATE
diff --git a/mail/squirrelmail-compatibility-plugin1/pkg-descr b/mail/squirrelmail-compatibility-plugin1/pkg-descr
index 729d8cec22ac..b148cf3b4d49 100644
--- a/mail/squirrelmail-compatibility-plugin1/pkg-descr
+++ b/mail/squirrelmail-compatibility-plugin1/pkg-descr
@@ -1,10 +1,7 @@
-SquirrelMail Plug-in that provides a standard API for plugin authors who need
-certain functionalities that may not be available in older versions of
-SquirrelMail. SquirrelMail administrators only need to download this plugin if
-any of the plugins they have require it.
+SquirrelMail Plug-in that provides a standard API for plugin authors
+who need certain functionalities that may not be available in older
+versions of SquirrelMail. SquirrelMail administrators only need to
+download this plugin if any of the plugins they have require it.
This plugin has no functionality in and of itself.
WWW: http://www.squirrelmail.org
-
-- Alexander Wittig
-alexander@wittig.name
diff --git a/mail/squirrelmail-compatibility-plugin1/pkg-plist b/mail/squirrelmail-compatibility-plugin1/pkg-plist
index ea26c627a6e7..48c7e62d0567 100644
--- a/mail/squirrelmail-compatibility-plugin1/pkg-plist
+++ b/mail/squirrelmail-compatibility-plugin1/pkg-plist
@@ -1,4 +1,4 @@
-@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin compatibility; fi
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin %%SQUIRREL_PLUGIN_NAME%%; fi
%%SQUIRRELDIR%%/plugins/compatibility/functions.php
%%SQUIRRELDIR%%/plugins/compatibility/index.php
%%SQUIRRELDIR%%/plugins/compatibility/INSTALL
@@ -6,4 +6,4 @@
%%SQUIRRELDIR%%/plugins/compatibility/setup.php
%%SQUIRRELDIR%%/plugins/compatibility/version
@dirrm %%SQUIRRELDIR%%/plugins/compatibility
-@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin compatibility; fi
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi