aboutsummaryrefslogtreecommitdiff
path: root/mail/sylpheed-claws
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-17 06:46:04 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-17 06:46:04 +0000
commit5c4032c435a7b1bd1b943bd41f22c2b936707fbf (patch)
tree21608fd9ec21487c17030696fb3f99c405dea700 /mail/sylpheed-claws
parent3b05a3924eb3af67ec51daef0895cdf491b2d34d (diff)
downloadports-5c4032c435a7b1bd1b943bd41f22c2b936707fbf.tar.gz
ports-5c4032c435a7b1bd1b943bd41f22c2b936707fbf.zip
Update to 0.7.0
PR: 33922 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=53229
Diffstat (limited to 'mail/sylpheed-claws')
-rw-r--r--mail/sylpheed-claws/Makefile78
-rw-r--r--mail/sylpheed-claws/distinfo2
-rw-r--r--mail/sylpheed-claws/files/patch-configure24
-rw-r--r--mail/sylpheed-claws/files/patch-tools-README.sylprint18
-rw-r--r--mail/sylpheed-claws/files/patch-tools-sylprint.pl14
-rw-r--r--mail/sylpheed-claws/pkg-descr4
-rw-r--r--mail/sylpheed-claws/pkg-plist95
7 files changed, 149 insertions, 86 deletions
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 2f35f62725b7..47c181bf4788 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -5,12 +5,11 @@
# $FreeBSD$
#
-PORTNAME= sylpheed
-PORTVERSION= 0.6.6
+PORTNAME= sylpheed-claws
+PORTVERSION= 0.7.0
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
-PKGNAMESUFFIX= -claws
DISTNAME= sylpheed-${PORTVERSION}claws
MAINTAINER= corecode@corecode.ath.cx
@@ -23,27 +22,31 @@ USE_GTK= yes
CONFIGURE_ARGS= --program-suffix="-claws" --with-included-gettext \
--enable-ipv6
-CONFIGURE_ENV= CFLAGS="${CFLAGS}"
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
-.if defined(WITH_PIXBUF)
+.if defined(WITH_PIXBUF) || defined(WITH_ALL)
LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
CONFIGURE_ARGS+= --disable-imlib
.else
USE_IMLIB= yes
CONFIGURE_ARGS+= --disable-gdk-pixbuf
.endif
-.if defined(WITH_GPGME)
+.if defined(WITH_GPGME) || defined(WITH_ALL)
LIB_DEPENDS+= gpgme.4:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+= --enable-gpgme
.endif
-.if defined(WITH_COMPFACE)
+.if defined(WITH_COMPFACE) || defined(WITH_ALL)
LIB_DEPENDS+= compface.1:${PORTSDIR}/mail/faces
-CONFIGURE_ENV+= LIBS="-L${X11BASE}/lib"
.else
CONFIGURE_ARGS+= --disable-compface
.endif
-.if defined(WITH_PSPELL)
+.if defined(WITH_JCONV) || defined(WITH_ALL)
+LIB_DEPENDS+= jconv.0:${PORTSDIR}/japanese/libjconv
+.else
+CONFIGURE_ARGS+= --disable-jconv
+.endif
+.if defined(WITH_PSPELL) || defined(WITH_ALL)
LIB_DEPENDS+= pspell.4:${PORTSDIR}/textproc/pspell
CONFIGURE_ARGS+= --enable-pspell
.endif
@@ -53,42 +56,43 @@ CONFIGURE_ARGS+= --enable-ssl
.endif
pre-everything::
-.if !defined(WITH_PIXBUF)
- @${ECHO_MSG}
- @${ECHO_MSG} "You can enable GDK Pixbuf support by defining WITH_PIXBUF."
-.endif
-.if defined(WITH_GPGME)
- @${ECHO_MSG}
- @${ECHO_MSG} "WARNING: GnuPG support using GPGME is still experimental."
-.else
- @${ECHO_MSG}
- @${ECHO_MSG} "You can enable GnuPG support using GPGME by defining WITH_GPGME."
- @${ECHO_MSG} "WARNING: GnuPG support is still experimental."
-.endif
-.if !defined(WITH_COMPFACE)
- @${ECHO_MSG}
- @${ECHO_MSG} "You can enable compface (X-Face) support by defining WITH_COMPFACE."
-.endif
-.if !defined(WITH_PSPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "You can enable pspell support by defining WITH_PSPELL."
-.endif
-.if !defined(WITHOUT_SSL)
- @${ECHO_MSG}
- @${ECHO_MSG} "You can disable OpenSSL support by defining WITHOUT_SSL."
+ @${ECHO} ""
+ @${ECHO} "You may define the following build options:"
+ @${ECHO} ""
+ @${ECHO} " WITH_ALL Enable all options below"
+ @${ECHO} " WITH_PIXBUF Enable GDK Pixbuf support"
+ @${ECHO} " WITH_GPGME Enable GnuPG support using GPGME"
+ @${ECHO} " WITH_COMPFACE Enable compface (X-Face) support"
+ @${ECHO} " WITH_JCONV Enable enhanced charset conversion"
+ @${ECHO} " WITH_PSPELL Enable spell-checking support"
+ @${ECHO} ""
+ @${ECHO} " WITHOUT_SSL Disable OpenSSL support"
+ @${ECHO} ""
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" \
+ ${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
+.if defined(NOPORTDOCS)
+ @${PERL} -pi -e 's|^(SUBDIRS = .*)manual (.*)|\1\2|' ${WRKSRC}/Makefile.in
.endif
- @${ECHO_MSG}
pre-build:
- ${LN} -sf ${LOCALBASE}/bin/${LIBTOOL} ${WRKSRC}/libtool
+ @${LN} -sf ${LOCALBASE}/bin/${LIBTOOL} ${WRKSRC}/libtool
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/sylpheed-claws
-.for i in NEWS README README.claws README.jp RELEASE_NOTES.claws TODO TODO.jp
- @${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/sylpheed-claws
+.for i in README README.jp README.claws RELEASE_NOTES.claws TODO TODO.jp tools/README.sylprint
+ @${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
+ @${INSTALL_MAN} ${WRKSRC}/tools/README ${DOCSDIR}/README.tools
.endif
+ @${MKDIR} ${DATADIR}
+.for i in eud2gc.py filter_conv.pl gif2xface.pl ldif-to-xml.py newscache_clean.pl
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/${i} ${DATADIR}
+.endfor
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/sylpheed-switcher ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/sylprint.pl ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/tools/sylprint.rc ${PREFIX}/etc/sylprint.rc.example
@${MKDIR} ${PREFIX}/share/pixmaps
@${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${PREFIX}/share/pixmaps/sylpheed-claws.png
diff --git a/mail/sylpheed-claws/distinfo b/mail/sylpheed-claws/distinfo
index 44ce38840938..c228936f27fb 100644
--- a/mail/sylpheed-claws/distinfo
+++ b/mail/sylpheed-claws/distinfo
@@ -1 +1 @@
-MD5 (sylpheed-0.6.6claws.tar.gz) = b7c62a120808fc87e3c3fc009bd63703
+MD5 (sylpheed-0.7.0claws.tar.gz) = ff76b9e3f0f43bdacf05f3a25addcd40
diff --git a/mail/sylpheed-claws/files/patch-configure b/mail/sylpheed-claws/files/patch-configure
index af0361f0024d..98fada214116 100644
--- a/mail/sylpheed-claws/files/patch-configure
+++ b/mail/sylpheed-claws/files/patch-configure
@@ -1,5 +1,5 @@
---- ./configure.orig Sat Dec 15 14:28:30 2001
-+++ ./configure Fri Dec 21 01:02:01 2001
+--- configure.orig Mon Jan 14 16:15:33 2002
++++ configure Tue Jan 15 15:53:11 2002
@@ -756,7 +756,7 @@
fi
@@ -8,4 +8,22 @@
+PACKAGE=sylpheed-claws
MAJOR_VERSION=0
- MINOR_VERSION=6
+ MINOR_VERSION=7
+@@ -1056,7 +1056,7 @@
+ fi
+
+
+-if test -d "$gnomedir"; then
++if false; then
+ SYLPHEED_GNOME_TRUE=
+ SYLPHEED_GNOME_FALSE='#'
+ else
+@@ -7419,7 +7419,7 @@
+ localedir='${prefix}/${DATADIRNAME}/locale'
+
+
+-manualdir='${prefix}/${DATADIRNAME}/${PACKAGE}/manual'
++manualdir='${prefix}/${DATADIRNAME}/doc/${PACKAGE}/manual'
+
+
+ # Check whether --with-glib-prefix or --without-glib-prefix was given.
diff --git a/mail/sylpheed-claws/files/patch-tools-README.sylprint b/mail/sylpheed-claws/files/patch-tools-README.sylprint
new file mode 100644
index 000000000000..22b5e00325d4
--- /dev/null
+++ b/mail/sylpheed-claws/files/patch-tools-README.sylprint
@@ -0,0 +1,18 @@
+--- tools/README.sylprint.orig Sun Jan 6 17:05:30 2002
++++ tools/README.sylprint Tue Jan 15 00:19:12 2002
+@@ -144,11 +144,12 @@
+ sylprint.pl
+ The script itself.
+
+- sylprint.rc
++ %%PREFIX%%/etc/sylprint.rc
++ ~/.sylpheed/sylprint.rc
+ Stores user default preferred configuration for the
+ script. Settings in this file may be overriden by
+- command line options. Must be stored in the same
+- directory of the script and/or in the ~/.sylpheed
++ command line options. Must be stored in the local
++ configuration directory and/or in the ~/.sylpheed
+ one (Sylpheed user's configuration directory).
+
+ /tmp/sylprint.username.number
diff --git a/mail/sylpheed-claws/files/patch-tools-sylprint.pl b/mail/sylpheed-claws/files/patch-tools-sylprint.pl
new file mode 100644
index 000000000000..fce5e4ec5bbe
--- /dev/null
+++ b/mail/sylpheed-claws/files/patch-tools-sylprint.pl
@@ -0,0 +1,14 @@
+--- tools/sylprint.pl.orig Tue Jan 8 20:34:37 2002
++++ tools/sylprint.pl Tue Jan 15 00:13:15 2002
+@@ -36,10 +36,7 @@
+ # get user config
+ if (defined($ARGV[1]) && $ARGV[1] eq '-r') { $a++; }
+ else {
+- @spp = split('/',$0);
+- $spp[$#spp] = '';
+- $spp = join('/',@spp);
+- $rcf="$spp$rc";
++ $rcf="%%PREFIX%%/etc/$rc";
+ if (-x $rcf) { do $rcf; }
+ $rcf="$ENV{'HOME'}/.sylpheed/$rc";
+ if (-x $rcf) { do $rcf; }
diff --git a/mail/sylpheed-claws/pkg-descr b/mail/sylpheed-claws/pkg-descr
index 481ba3918629..a77dfe2ecc44 100644
--- a/mail/sylpheed-claws/pkg-descr
+++ b/mail/sylpheed-claws/pkg-descr
@@ -9,11 +9,11 @@ In addition to the above, Sylpheed-claws has the following extra features:
* allow colour labeling of emails based on filtering rules
* automatic mailing list reply, allow ignoring of mail threads
* selectable fonts, compface support, spell checking, SMTP AUTH
-* Revision of the quotation format and forwarding format
* encryption/decryption of GPG/PGP ascii-armored messages is supported
-* dynamic signatures are enabled
* folder properties: associate certain options per folder,
'Request Return Receipt', 'Default To', and 'Default account'
+* subject simplification for changing the display of subject lines via RegExp
+* Undo/Redo
and more...
WWW: http://sylpheed-claws.sourceforge.net/
diff --git a/mail/sylpheed-claws/pkg-plist b/mail/sylpheed-claws/pkg-plist
index 746089f3f1dc..7927074465ed 100644
--- a/mail/sylpheed-claws/pkg-plist
+++ b/mail/sylpheed-claws/pkg-plist
@@ -1,12 +1,53 @@
bin/sylpheed-claws
+bin/sylpheed-switcher
+bin/sylprint.pl
+etc/sylprint.rc.example
lib/charset.alias
-%%PORTDOCS%%share/doc/sylpheed-claws/NEWS
%%PORTDOCS%%share/doc/sylpheed-claws/README
%%PORTDOCS%%share/doc/sylpheed-claws/README.claws
%%PORTDOCS%%share/doc/sylpheed-claws/README.jp
+%%PORTDOCS%%share/doc/sylpheed-claws/README.sylprint
+%%PORTDOCS%%share/doc/sylpheed-claws/README.tools
%%PORTDOCS%%share/doc/sylpheed-claws/RELEASE_NOTES.claws
%%PORTDOCS%%share/doc/sylpheed-claws/TODO
%%PORTDOCS%%share/doc/sylpheed-claws/TODO.jp
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-1.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-10.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-11.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-12.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-13.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-14.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-15.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-16.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-17.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-2.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-3.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-4.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-5.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-6.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-7.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-8.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed-9.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/en/sylpheed.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-1.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-10.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-11.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-12.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-13.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-14.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-15.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-16.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-17.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-2.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-3.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-4.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-5.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-6.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-7.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-8.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed-9.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed.html
+%%PORTDOCS%%share/doc/sylpheed-claws/manual/ja/sylpheed.sgml
share/locale/cs/LC_MESSAGES/sylpheed-claws.mo
share/locale/de/LC_MESSAGES/sylpheed-claws.mo
share/locale/el/LC_MESSAGES/sylpheed-claws.mo
@@ -23,46 +64,14 @@ share/locale/pt_BR/LC_MESSAGES/sylpheed-claws.mo
share/locale/ru/LC_MESSAGES/sylpheed-claws.mo
share/locale/sv/LC_MESSAGES/sylpheed-claws.mo
share/pixmaps/sylpheed-claws.png
-share/sylpheed-claws/manual/en/sylpheed-1.html
-share/sylpheed-claws/manual/en/sylpheed-10.html
-share/sylpheed-claws/manual/en/sylpheed-11.html
-share/sylpheed-claws/manual/en/sylpheed-12.html
-share/sylpheed-claws/manual/en/sylpheed-13.html
-share/sylpheed-claws/manual/en/sylpheed-14.html
-share/sylpheed-claws/manual/en/sylpheed-15.html
-share/sylpheed-claws/manual/en/sylpheed-16.html
-share/sylpheed-claws/manual/en/sylpheed-17.html
-share/sylpheed-claws/manual/en/sylpheed-2.html
-share/sylpheed-claws/manual/en/sylpheed-3.html
-share/sylpheed-claws/manual/en/sylpheed-4.html
-share/sylpheed-claws/manual/en/sylpheed-5.html
-share/sylpheed-claws/manual/en/sylpheed-6.html
-share/sylpheed-claws/manual/en/sylpheed-7.html
-share/sylpheed-claws/manual/en/sylpheed-8.html
-share/sylpheed-claws/manual/en/sylpheed-9.html
-share/sylpheed-claws/manual/en/sylpheed.html
-share/sylpheed-claws/manual/ja/sylpheed-1.html
-share/sylpheed-claws/manual/ja/sylpheed-10.html
-share/sylpheed-claws/manual/ja/sylpheed-11.html
-share/sylpheed-claws/manual/ja/sylpheed-12.html
-share/sylpheed-claws/manual/ja/sylpheed-13.html
-share/sylpheed-claws/manual/ja/sylpheed-14.html
-share/sylpheed-claws/manual/ja/sylpheed-15.html
-share/sylpheed-claws/manual/ja/sylpheed-16.html
-share/sylpheed-claws/manual/ja/sylpheed-17.html
-share/sylpheed-claws/manual/ja/sylpheed-2.html
-share/sylpheed-claws/manual/ja/sylpheed-3.html
-share/sylpheed-claws/manual/ja/sylpheed-4.html
-share/sylpheed-claws/manual/ja/sylpheed-5.html
-share/sylpheed-claws/manual/ja/sylpheed-6.html
-share/sylpheed-claws/manual/ja/sylpheed-7.html
-share/sylpheed-claws/manual/ja/sylpheed-8.html
-share/sylpheed-claws/manual/ja/sylpheed-9.html
-share/sylpheed-claws/manual/ja/sylpheed.html
-share/sylpheed-claws/manual/ja/sylpheed.sgml
-@dirrm share/sylpheed-claws/manual/ja
-@dirrm share/sylpheed-claws/manual/en
-@dirrm share/sylpheed-claws/manual
-@dirrm share/sylpheed-claws
-@unexec rmdir %D/share/pixmaps 2>/dev/null || true
+share/sylpheed-claws/eud2gc.py
+share/sylpheed-claws/filter_conv.pl
+share/sylpheed-claws/gif2xface.pl
+share/sylpheed-claws/ldif-to-xml.py
+share/sylpheed-claws/newscache_clean.pl
+%%PORTDOCS%%@dirrm share/doc/sylpheed-claws/manual/ja
+%%PORTDOCS%%@dirrm share/doc/sylpheed-claws/manual/en
+%%PORTDOCS%%@dirrm share/doc/sylpheed-claws/manual
%%PORTDOCS%%@dirrm share/doc/sylpheed-claws
+@unexec rmdir %D/share/pixmaps 2>/dev/null || true
+@dirrm share/sylpheed-claws