aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2012-04-25 04:51:59 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2012-04-25 04:51:59 +0000
commit5d1bdd789c20819a25ccb974a8619073098ddb7e (patch)
tree2c310cc49005dcb307974eddaad9cf5351680b0b /mail/thunderbird
parenta4a3a3c37ac07b0bd68369c163353bc038471c9a (diff)
downloadports-5d1bdd789c20819a25ccb974a8619073098ddb7e.tar.gz
ports-5d1bdd789c20819a25ccb974a8619073098ddb7e.zip
- Update to 12.0
Notes
Notes: svn path=/head/; revision=295450
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/distinfo4
-rw-r--r--mail/thunderbird/files/patch-mozilla-gfx-thebes-gfxPlatform.cpp34
-rw-r--r--mail/thunderbird/files/patch-mozilla-js-src-Makefile.in26
4 files changed, 50 insertions, 16 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 1a6e1021d5ca..c50979eeaa71 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= thunderbird
-DISTVERSION= 11.0.1
+DISTVERSION= 12.0
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index 3ec5b39e5085..bd7e7509d10a 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,2 +1,2 @@
-SHA256 (thunderbird-11.0.1.source.tar.bz2) = 5a5c35b76ecd38624a12b817909b3dcfe9c378c10cbfce60c9971e18251305a0
-SIZE (thunderbird-11.0.1.source.tar.bz2) = 101480528
+SHA256 (thunderbird-12.0.source.tar.bz2) = 08752a597e42638748e76c711f7875856dd15a545e5f56732ba45f5df2faf45d
+SIZE (thunderbird-12.0.source.tar.bz2) = 101278632
diff --git a/mail/thunderbird/files/patch-mozilla-gfx-thebes-gfxPlatform.cpp b/mail/thunderbird/files/patch-mozilla-gfx-thebes-gfxPlatform.cpp
new file mode 100644
index 000000000000..e7dc51335465
--- /dev/null
+++ b/mail/thunderbird/files/patch-mozilla-gfx-thebes-gfxPlatform.cpp
@@ -0,0 +1,34 @@
+--- mozilla/gfx/thebes/gfxPlatform.cpp~ 2012-02-07 11:59:39.717184907 +0000
++++ mozilla/gfx/thebes/gfxPlatform.cpp 2012-02-07 13:06:01.084668445 +0000
+@@ -446,6 +446,7 @@
+ static_cast<SourceSurface*>(srcBuffer)->Release();
+ }
+
++#ifdef MOZ_TREE_CAIRO
+ void SourceSnapshotDetached(cairo_surface_t *nullSurf)
+ {
+ gfxImageSurface* origSurf =
+@@ -453,6 +454,7 @@
+
+ origSurf->SetData(&kSourceSurface, NULL, NULL);
+ }
++#endif
+
+ RefPtr<SourceSurface>
+ gfxPlatform::GetSourceSurfaceForSurface(DrawTarget *aTarget, gfxASurface *aSurface)
+@@ -522,6 +524,7 @@
+ imgSurface->Stride(),
+ format);
+
++ #ifdef MOZ_TREE_CAIRO
+ cairo_surface_t *nullSurf =
+ cairo_null_surface_create(CAIRO_CONTENT_COLOR_ALPHA);
+ cairo_surface_set_user_data(nullSurf,
+@@ -530,6 +533,7 @@
+ NULL);
+ cairo_surface_attach_snapshot(imgSurface->CairoSurface(), nullSurf, SourceSnapshotDetached);
+ cairo_surface_destroy(nullSurf);
++ #endif
+ }
+
+ srcBuffer->AddRef();
diff --git a/mail/thunderbird/files/patch-mozilla-js-src-Makefile.in b/mail/thunderbird/files/patch-mozilla-js-src-Makefile.in
index f203d1dce232..e62d7b8202a2 100644
--- a/mail/thunderbird/files/patch-mozilla-js-src-Makefile.in
+++ b/mail/thunderbird/files/patch-mozilla-js-src-Makefile.in
@@ -1,15 +1,15 @@
---- mozilla/js/src/Makefile.in.orig 2011-07-06 05:09:22.000000000 +0200
-+++ mozilla/js/src/Makefile.in 2011-07-06 22:23:46.363233778 +0200
-@@ -416,7 +416,7 @@
- # END enclude sources for V8 dtoa
- #############################################
+--- mozilla/js/src/Makefile.in.orig 2012-03-15 20:40:13.000000000 +0100
++++ mozilla/js/src/Makefile.in 2012-03-16 10:03:18.000000000 +0100
+@@ -352,7 +352,7 @@
+ # For architectures without YARR JIT, PCRE is faster than the YARR
+ # interpreter (bug 684559).
--ifeq (,$(filter arm% sparc %86 x86_64,$(TARGET_CPU)))
-+ifeq (,$(filter arm% sparc %86 amd64 x86_64,$(TARGET_CPU)))
+-ifeq (,$(filter arm% sparc %86 x86_64 mips%,$(TARGET_CPU)))
++ifeq (,$(filter arm% sparc %86 amd64 x86_64 mips%,$(TARGET_CPU)))
- VPATH += $(srcdir)/assembler \
- $(srcdir)/assembler/wtf \
-@@ -469,6 +469,9 @@
+ VPATH += $(srcdir)/yarr/pcre \
+ $(NULL)
+@@ -418,6 +418,9 @@
else
#CPPSRCS += only_on_x86.cpp
endif
@@ -19,12 +19,12 @@
endif
ifeq (arm, $(TARGET_CPU))
#CPPSRCS += only_on_arm.cpp
-@@ -793,7 +796,7 @@
+@@ -737,7 +740,7 @@
endif # WINNT
ifeq ($(OS_ARCH),FreeBSD)
-EXTRA_LIBS += -pthread
+EXTRA_LIBS += -pthread -lc
endif
- ifeq ($(OS_ARCH),IRIX)
- ifdef USE_N32
+ ifeq ($(OS_ARCH),Linux)
+ EXTRA_LIBS += -ldl