aboutsummaryrefslogtreecommitdiff
path: root/mail/wmbiff/Makefile
diff options
context:
space:
mode:
authorSimon L. B. Nielsen <simon@FreeBSD.org>2004-01-08 11:55:30 +0000
committerSimon L. B. Nielsen <simon@FreeBSD.org>2004-01-08 11:55:30 +0000
commit2fcee47a69c73e559e6894177ce11b1853f59503 (patch)
tree1cc1c558bb949ce650d1e4ebb0a958838429501c /mail/wmbiff/Makefile
parentf326b15cd2528e946aa66c652c365b322997ebf2 (diff)
downloadports-2fcee47a69c73e559e6894177ce11b1853f59503.tar.gz
ports-2fcee47a69c73e559e6894177ce11b1853f59503.zip
- Update to version 0.4.20.
- Autodetect if gnutls is installed to get dependencies right. Approved by: edwin
Notes
Notes: svn path=/head/; revision=97670
Diffstat (limited to 'mail/wmbiff/Makefile')
-rw-r--r--mail/wmbiff/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/mail/wmbiff/Makefile b/mail/wmbiff/Makefile
index d04bbfb79d2a..7ade7f2478f3 100644
--- a/mail/wmbiff/Makefile
+++ b/mail/wmbiff/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wmbiff
-PORTVERSION= 0.4.19
+PORTVERSION= 0.4.20
CATEGORIES= mail windowmaker afterstep
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,12 +14,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= simon@FreeBSD.org
COMMENT= An xbiff-like Window Maker dock app
+USE_X_PREFIX= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libgnutls.so.7)
+WITH_GNUTLS= yes
+.endif
+
.ifdef WITH_GNUTLS
-LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
- gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gcrypt.6:${PORTSDIR}/security/libgcrypt \
+ gnutls.7:${PORTSDIR}/security/gnutls
.endif
-USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
@@ -32,4 +39,4 @@ post-install:
@${ECHO_MSG} "===> Modify it to suit your needs and copy to ~/.wmbiffrc"
@${INSTALL_DATA} -m 644 ${WRKSRC}/wmbiff/sample.wmbiffrc ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>