aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2011-08-18 10:02:33 +0000
committerAlex Dupre <ale@FreeBSD.org>2011-08-18 10:02:33 +0000
commit1628ff46a7cdf516519e6725bbd8a6a9e584bbda (patch)
tree9842a0872b22105c034c5281b4691db7adb8f98c /mail
parent87b5e43a927f564afb64630c9304ec658c9af7e8 (diff)
downloadports-1628ff46a7cdf516519e6725bbd8a6a9e584bbda.tar.gz
ports-1628ff46a7cdf516519e6725bbd8a6a9e584bbda.zip
Make it fully working and restrict to correct port.
Approved by: flo
Notes
Notes: svn path=/head/; revision=279960
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird-esr-i18n/Makefile9
-rw-r--r--mail/thunderbird-i18n/Makefile9
2 files changed, 12 insertions, 6 deletions
diff --git a/mail/thunderbird-esr-i18n/Makefile b/mail/thunderbird-esr-i18n/Makefile
index 620fdfe7a311..c5984ee0d10f 100644
--- a/mail/thunderbird-esr-i18n/Makefile
+++ b/mail/thunderbird-esr-i18n/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird-i18n
PORTVERSION= 6.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}/linux-i686/xpi
PKGNAMEPREFIX=
@@ -24,7 +25,7 @@ RUN_DEPENDS+= xpi-quick-locale-switcher>=0:${PORTSDIR}/www/xpi-quick-locale-swit
NO_BUILD= yes
USE_THUNDERBIRD= yes
-USE_XPI= *thunderbird
+USE_XPI= thunderbird
THUNDERBIRD_I18N_ALL= ar br ca cs da de en-GB en-US es-AR es-ES et eu fi fr \
fy-NL ga-IE gd gl he hu is it ja ko lt nb-NO nl nn-NO \
@@ -58,8 +59,10 @@ do-extract:
then \
exit 1; \
fi; \
- cd ${WRKSRC}/langpack-$$lang@thunderbird.mozilla.org/chrome; \
- ${LOCALBASE}/bin/zip -r $$lang.jar $$lang; \
+ cd ${WRKSRC}/langpack-$$lang@thunderbird.mozilla.org/chrome/$$lang; \
+ ${LOCALBASE}/bin/zip -r ../$$lang.jar locale; \
+ cd ..; ${RM} -rf $$lang; cd ..; \
+ ${REINPLACE_CMD} -i "" "s,chrome/$$lang,jar:chrome/$$lang.jar!," chrome.manifest; \
done
do-install:
diff --git a/mail/thunderbird-i18n/Makefile b/mail/thunderbird-i18n/Makefile
index 620fdfe7a311..c5984ee0d10f 100644
--- a/mail/thunderbird-i18n/Makefile
+++ b/mail/thunderbird-i18n/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird-i18n
PORTVERSION= 6.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}/linux-i686/xpi
PKGNAMEPREFIX=
@@ -24,7 +25,7 @@ RUN_DEPENDS+= xpi-quick-locale-switcher>=0:${PORTSDIR}/www/xpi-quick-locale-swit
NO_BUILD= yes
USE_THUNDERBIRD= yes
-USE_XPI= *thunderbird
+USE_XPI= thunderbird
THUNDERBIRD_I18N_ALL= ar br ca cs da de en-GB en-US es-AR es-ES et eu fi fr \
fy-NL ga-IE gd gl he hu is it ja ko lt nb-NO nl nn-NO \
@@ -58,8 +59,10 @@ do-extract:
then \
exit 1; \
fi; \
- cd ${WRKSRC}/langpack-$$lang@thunderbird.mozilla.org/chrome; \
- ${LOCALBASE}/bin/zip -r $$lang.jar $$lang; \
+ cd ${WRKSRC}/langpack-$$lang@thunderbird.mozilla.org/chrome/$$lang; \
+ ${LOCALBASE}/bin/zip -r ../$$lang.jar locale; \
+ cd ..; ${RM} -rf $$lang; cd ..; \
+ ${REINPLACE_CMD} -i "" "s,chrome/$$lang,jar:chrome/$$lang.jar!," chrome.manifest; \
done
do-install: