aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-02-15 06:48:40 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-02-15 06:48:40 +0000
commit1e8f2fb060fd95cb87b392d29919da2e7cf283ee (patch)
tree8701b028c80c0509ec407423e1ed2de9cbf7dda9 /mail
parent5abfedffc39c37b6755a01dea6585e6c3e46adac (diff)
downloadports-1e8f2fb060fd95cb87b392d29919da2e7cf283ee.tar.gz
ports-1e8f2fb060fd95cb87b392d29919da2e7cf283ee.zip
mail/exim: actually fix the bug in code (+)
The comment prior to smtp_printf() implementation says that the extra BOOL argument tells whether "further is data expected". Looking at other invocations of it, including those for error 451, it should be FALSE here.
Diffstat (limited to 'mail')
-rw-r--r--mail/exim/Makefile3
-rw-r--r--mail/exim/files/extra-patch-Local-sa-exim.c2
2 files changed, 1 insertions, 4 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 9b628a088d3d..2242ff7608fa 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -21,9 +21,6 @@ USES= compiler cpe tar:bzip2 perl5
USE_CSTD= c99
USE_PERL5= run
-# LLVM15 workaround
-CFLAGS= -Wno-int-conversion
-
# Exim build system is job unsafe atm
MAKE_JOBS_UNSAFE= yes
# One can tune the following "hidden" knobs:
diff --git a/mail/exim/files/extra-patch-Local-sa-exim.c b/mail/exim/files/extra-patch-Local-sa-exim.c
index 103027b1f44d..b3343e3c5e26 100644
--- a/mail/exim/files/extra-patch-Local-sa-exim.c
+++ b/mail/exim/files/extra-patch-Local-sa-exim.c
@@ -193,7 +193,7 @@
- str=string_sprintf(string_sprintf("451- %s\r\n",SAmsgteergrubewait), spamstatus);
- fprintf(smtp_out, str);
- ret=fflush(smtp_out);
-+ smtp_printf("451-%s\r\n", teergrubewaitstr);
++ smtp_printf("451-%s\r\n", FALSE, teergrubewaitstr);
+ ret=smtp_fflush();
if (ret != 0)
{