aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-10-08 00:38:20 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-10-08 00:38:20 +0000
commit4c678b9f3e3116b2e298fd7867f83433ff393dec (patch)
tree496310d7cf2f030f1ebfcd9255587fb72bf2c681 /mail
parentc2d4040e345850235cf66a834201231460134611 (diff)
downloadports-4c678b9f3e3116b2e298fd7867f83433ff393dec.tar.gz
ports-4c678b9f3e3116b2e298fd7867f83433ff393dec.zip
gecko: update OSS patches
Notes
Notes: svn path=/head/; revision=551677
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-cubeb-oss5
2 files changed, 2 insertions, 4 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 6dc090138d38..ec1c51fca61b 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 78.3.2
+PORTREVISION= 1
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-cubeb-oss b/mail/thunderbird/files/patch-cubeb-oss
index 75466510be7d..8e851f99273e 100644
--- a/mail/thunderbird/files/patch-cubeb-oss
+++ b/mail/thunderbird/files/patch-cubeb-oss
@@ -61,7 +61,7 @@ https://github.com/kinetiknz/cubeb/pull/600
#endif
--- /dev/null
+++ media/libcubeb/src/cubeb_oss.c
-@@ -0,0 +1,1245 @@
+@@ -0,0 +1,1242 @@
+/*
+ * Copyright © 2019-2020 Nia Alarie <nia@NetBSD.org>
+ * Copyright © 2020 Ka Ho Ng <khng300@gmail.com>
@@ -1009,9 +1009,6 @@ https://github.com/kinetiknz/cubeb/pull/600
+ pthread_mutex_unlock(&s->mtx);
+ break;
+ }
-+ pthread_mutex_unlock(&s->mtx);
-+
-+ pthread_mutex_lock(&s->mtx);
+ pthread_cond_wait(&s->doorbell_cv, &s->mtx);
+ pthread_mutex_unlock(&s->mtx);
+ } while (1);