aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2023-06-26 12:31:17 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2023-06-26 12:32:48 +0000
commit5b4d8f41167458ad70a9d798cefb4d5245abb8ed (patch)
tree5bb926e9a6b754c552c034ed416e116dbedbdb3a /mail
parent9650dcc8132f0d8931d216d95462be854bf19b7b (diff)
downloadports-5b4d8f41167458ad70a9d798cefb4d5245abb8ed.tar.gz
ports-5b4d8f41167458ad70a9d798cefb4d5245abb8ed.zip
mail/qpopper: unbreak build for llvm16
This unbreaks build, so PORTREVISION not changed.
Diffstat (limited to 'mail')
-rw-r--r--mail/qpopper/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 9ec3fc3c128f..8e70fa98aae4 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -125,8 +125,12 @@ CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
# openssl-1.1.1 no longer has SSLv2 support
.if ${OPSYS} == FreeBSD
CFLAGS+= -DOPENSSL_NO_SSL2
-CONFIGURE_ARGS+= CFLAGS="${CFLAGS}"
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CFLAGS+= -Wno-incompatible-function-pointer-types
.endif
+.endif
+
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
post-patch:
.if ${COMPILER_TYPE} == clang