aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-10-04 08:21:40 +0000
committerBernard Spil <brnrd@FreeBSD.org>2016-10-04 08:21:40 +0000
commit5cd355edb55196f229ed8917ea8171c0d188b236 (patch)
treeb8859d0de62c2a7ca0c53f737f733acfc2268f17 /mail
parent65cc397719dbfab8a62d1c6494ce6446023d11f0 (diff)
downloadports-5cd355edb55196f229ed8917ea8171c0d188b236.tar.gz
ports-5cd355edb55196f229ed8917ea8171c0d188b236.zip
mail/roundcube: Update to 1.2.1
- Update to 1.2.1 - Add missing .htaccess file in WWWDIR [1] - Switch WANT_PHP_WEB to USES= php:web - Add description for DB options group - Convert all ${PORT_OPTIONS:Mfoo} to OPTIONS framework - Convert target conditionals to target-OPT-on PR: 196016 [1] Submitted by: Lukasz Wasikowski <lukasz@wasikowski.net> [1] Approved by: Maintainer timeout
Notes
Notes: svn path=/head/; revision=423243
Diffstat (limited to 'mail')
-rw-r--r--mail/roundcube/Makefile67
-rw-r--r--mail/roundcube/distinfo6
2 files changed, 23 insertions, 50 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index f01af574f404..db2a7f7b166d 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= roundcube
-DISTVERSION= 1.2.0
-PORTREVISION= 1
+DISTVERSION= 1.2.1
PORTEPOCH= 1
CATEGORIES?= mail www
MASTER_SITES= https://github.com/roundcube/roundcubemail/releases/download/${DISTVERSION}/
@@ -16,14 +15,14 @@ LICENSE= GPLv3
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}mail-${DISTVERSION}
-RCUBECOMP= SQL config index.php installer logs plugins program robots.txt skins temp vendor
+RCUBECOMP= SQL config .htaccess index.php installer logs \
+ plugins program robots.txt skins temp vendor
PORTDOCS= CHANGELOG INSTALL README.md UPGRADING
-USES= cpe
+USES= cpe php:web
CPE_PRODUCT= webmail
CPE_VENDOR= roundcube
-WANT_PHP_WEB= yes
USE_PHP= pcre mbstring session iconv dom xml json intl zip filter openssl fileinfo exif
OPTIONS_DEFINE= LDAP GD PSPELL NSC DOCS
@@ -31,6 +30,7 @@ OPTIONS_SINGLE= DB
OPTIONS_SINGLE_DB= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT=MYSQL
+DB_DESC= Database backend
MYSQL_DESC= Use MySQL backend
PGSQL_DESC= Use PostgreSQL backend
SQLITE_DESC= Use SQLite backend
@@ -39,44 +39,17 @@ GD_DESC= Enable GD support (image conversion)
PSPELL_DESC= Enable PSpell support (internal spellcheck)
NSC_DESC= Install network spellchecker
-.include <bsd.port.options.mk>
+GD_VARS= use_php+=gd
+LDAP_VARS= use_php+=ldap
+MYSQL_VARS= use_php+=pdo_mysql
+NSC_IMPLIES= PSPELL
+NSC_VARS= use_php+=simplexml rcubecomp+=spellchecker.php
+PGSQL_VARS= use_php+=pdo_pgsql
+PSPELL_VARS= use_php+=pspell
+SQLITE_VARS= use_php+=pdo_pgsql
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= pdo_mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pdo_pgsql
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= pdo_sqlite
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_PHP+= ldap
-.endif
-
-.if ${PORT_OPTIONS:MGD}
-USE_PHP+= gd
-.endif
-
-.if ${PORT_OPTIONS:MPSPELL} || ${PORT_OPTIONS:MNSC}
-USE_PHP+= pspell
-.endif
-
-.if ${PORT_OPTIONS:MNSC}
-RCUBECOMP+= spellchecker.php
-USE_PHP+= simplexml
-PLIST_SUB+= SPELLCHECK=""
-.else
-PLIST_SUB+= SPELLCHECK="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNSC}
-post-extract:
+post-extract-NSC:
@${CP} ${FILESDIR}/spellchecker.php ${WRKSRC}
-.endif
post-patch:
@${FIND} ${WRKSRC} -name \*.orig -type f -delete
@@ -87,12 +60,6 @@ do-install:
.for i in ${RCUBECOMP}
@cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${STAGEDIR}${WWWDIR}
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}/
-.endfor
-.endif
@(cd ${WRKSRC}; ${FIND} bin ${RCUBECOMP} -not -type d) | ${SORT} | \
${SED} -ne 's,^,${WWWDIR_REL}/,p' >> ${TMPPLIST}
@${ECHO_CMD} '@exec chown ${WWWOWN}:${WWWGRP} %D/${WWWDIR_REL}/logs' \
@@ -100,4 +67,10 @@ do-install:
@${ECHO_CMD} '@exec chown ${WWWOWN}:${WWWGRP} %D/${WWWDIR_REL}/temp' \
>> ${TMPPLIST}
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
.include <bsd.port.mk>
diff --git a/mail/roundcube/distinfo b/mail/roundcube/distinfo
index 8db4c8df69fa..03d4e52bd8bf 100644
--- a/mail/roundcube/distinfo
+++ b/mail/roundcube/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1465476478
-SHA256 (roundcubemail-1.2.0-complete.tar.gz) = 574895da03b5ad78eaf0843a78e0c0ab734a9327b4ba47b72405b768cb2854cc
-SIZE (roundcubemail-1.2.0-complete.tar.gz) = 3748290
+TIMESTAMP = 1475568853
+SHA256 (roundcubemail-1.2.1-complete.tar.gz) = 271aabea275739b5a1f66510b02b79818aa218ffbac2abc9ff168e20a9031d45
+SIZE (roundcubemail-1.2.1-complete.tar.gz) = 3854668