aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /mail
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
downloadports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.tar.gz
ports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Notes
Notes: svn path=/head/; revision=326307
Diffstat (limited to 'mail')
-rw-r--r--mail/balsa/Makefile2
-rw-r--r--mail/bogofilter/Makefile2
-rw-r--r--mail/claws-mail/Makefile2
-rw-r--r--mail/crm114/Makefile2
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/libpst/Makefile2
-rw-r--r--mail/mmr/Makefile2
-rw-r--r--mail/normalizemime/Makefile2
-rw-r--r--mail/sylpheed/Makefile2
9 files changed, 9 insertions, 9 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index d608bf1b0c9b..2c427e1ff7b6 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --enable-threads \
--with-ssl \
--without-nm \
--with-canberra
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${ICONV_LIB} ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
MAN1= balsa.1
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 873c88591290..32c5841a7b4e 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -43,7 +43,7 @@ BF_CPPFLAGS?= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
.if ${PORT_OPTIONS:MUNICODE}
CONFIGURE_ARGS+= --enable-unicode
-BF_LIBS+= -liconv
+BF_LIBS+= ${ICONV_LIB}
.endif
.if ${PORT_OPTIONS:MGSL}
LIB_DEPENDS+= libgsl.so:${PORTSDIR}/math/gsl
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 714ef8edaa12..e0bb89b01ccf 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -67,7 +67,7 @@ USE_OPENLDAP= yes
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lresolv||g; s|-lpisock\"|-liconv &|g' \
+ @${REINPLACE_CMD} -e 's|-lresolv||g; s|-lpisock\"|${ICONV_LIB} &|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}&|g ; s|/usr/share|${LOCALBASE}/share|g' \
${WRKSRC}/src/procmime.c
diff --git a/mail/crm114/Makefile b/mail/crm114/Makefile
index 0ab6ce721528..a2fcb030b930 100644
--- a/mail/crm114/Makefile
+++ b/mail/crm114/Makefile
@@ -30,7 +30,7 @@ MAKE_ARGS= CC="${CC}" prefix="${PREFIX}" \
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-LIBS+= -L${LOCALBASE}/lib -liconv -lintl
+LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB} -lintl
CFLAGS+= -DVERSION='\"${PORTVERSION}-${CRM114RELEASENAME}\"'
CFLAGS+= -DNO_LOGL
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 8bf40c077f15..2155925adc03 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -235,7 +235,7 @@ SEDLIST+= -e 's,XX_TCP_WRAPPERS_LIBS_XX,,'
.if ${PORT_OPTIONS:MICONV}
USES= iconv
-SEDLIST+= -e 's,XX_ICONV_LIBS_XX,-L${LOCALBASE:S/,/\\,/g}/lib -liconv,' \
+SEDLIST+= -e 's,XX_ICONV_LIBS_XX,-L${LOCALBASE:S/,/\\,/g}/lib ${ICONV_LIB},' \
-e 's,^\# (HAVE_ICONV=),\1,'
.else
SEDLIST+= -e 's,XX_ICONV_LIBS_XX,,'
diff --git a/mail/libpst/Makefile b/mail/libpst/Makefile
index 96e3be9a7578..0f6987a4180b 100644
--- a/mail/libpst/Makefile
+++ b/mail/libpst/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= gsf-1:${PORTSDIR}/devel/libgsf
GNU_CONFIGURE= yes
USES= iconv pathfix gmake pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+= --disable-python --enable-libpst-shared
USE_LDCONFIG= yes
diff --git a/mail/mmr/Makefile b/mail/mmr/Makefile
index 5f5277786ee4..a4af9cf101f8 100644
--- a/mail/mmr/Makefile
+++ b/mail/mmr/Makefile
@@ -29,7 +29,7 @@ CXXFLAGS+= -DTHREADMAIL \
-DMAILPATH=\"/var/mail\" \
-DMAILER=\"/usr/sbin/sendmail\ -t\" \
-I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv -lcurses -lmd
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB} -lcurses -lmd
post-patch:
@${REINPLACE_CMD} -e 's|md5/libmd5.a||g' ${WRKSRC}/Makefile
diff --git a/mail/normalizemime/Makefile b/mail/normalizemime/Makefile
index 03b8665fcfc7..5e9e3246e997 100644
--- a/mail/normalizemime/Makefile
+++ b/mail/normalizemime/Makefile
@@ -22,7 +22,7 @@ USES= iconv
NO_WRKSUBDIR= yes
CXXFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
PLIST_FILES= bin/${DISTNAME:R}
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 35a4b31461f8..b8dcc833e9b6 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -101,7 +101,7 @@ MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g;' \
+ s|-lresolv||g; s|-lpisock\"|${ICONV_LIB} &|g;' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}&|g' \
${WRKSRC}/libsylph/procmime.c