aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2011-12-28 14:26:17 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2011-12-28 14:26:17 +0000
commit72da00e6253d70710c84e3def3f7fc0878956a6a (patch)
tree015d7e76f5a5b29ba7476f2d92f3f35923c4da6f /mail
parent3ada76b619d23b6e1ad3dcff7e70fbe8d60490fa (diff)
downloadports-72da00e6253d70710c84e3def3f7fc0878956a6a.tar.gz
ports-72da00e6253d70710c84e3def3f7fc0878956a6a.zip
- Force rc_script to wait on stop to prevent race condition on stop/start combo [1]
- Private email from Daniel O'Connor <doconnor at gsoft dot com dot au> PR: ports/163564 [1] Submitted by: m.tsatsenko@gmail.com Approved by: m.tsatsenko@gmail.com (maintainer), gabor (mentor, implicit)
Notes
Notes: svn path=/head/; revision=288170
Diffstat (limited to 'mail')
-rw-r--r--mail/mimedefang/Makefile15
-rw-r--r--mail/mimedefang/files/patch-examples__init-script.in21
2 files changed, 26 insertions, 10 deletions
diff --git a/mail/mimedefang/Makefile b/mail/mimedefang/Makefile
index 9c7478c96d17..7085ebbb0af6 100644
--- a/mail/mimedefang/Makefile
+++ b/mail/mimedefang/Makefile
@@ -7,21 +7,25 @@
PORTNAME= mimedefang
PORTVERSION= 2.72
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.mimedefang.org/static/
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= Milter based anti-spam and anti-virus filtering program
+LICENSE= GPLv2
+
BUILD_DEPENDS= \
${SITE_PERL}/IO/Stringy.pm:${PORTSDIR}/devel/p5-IO-stringy \
p5-MIME-Tools>=5.417:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ p5-Mail-SpamAssassin>=3.0:${PORTSDIR}/mail/p5-Mail-SpamAssassin
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+OPTIONS= CLAMAV "Enable Clamav" on
-LICENSE= GPLv2
USE_PERL5= yes
GNU_CONFIGURE= yes
@@ -38,10 +42,13 @@ CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc \
--with-ipheader \
--prefix=${PREFIX}
-.if defined (MIMEDEFANG_DISABLE_CLAMAV)
+.if defined (MIMEDEFANG_DISABLE_CLAMAV) || defined(WITHOUT_CLAMAV)
CONFIGURE_ARGS+= --disable-antivirus \
--disable-clamav \
--disable-clamd
+.else
+BUILD_DEPENDS+= clamscan:${PORTSDIR}/security/clamav
+RUN_DEPENDS+= clamscan:${PORTSDIR}/security/clamav
.endif
MAN1= mimedefang-util.1
diff --git a/mail/mimedefang/files/patch-examples__init-script.in b/mail/mimedefang/files/patch-examples__init-script.in
index b8b1b6550d25..54e34a2a1763 100644
--- a/mail/mimedefang/files/patch-examples__init-script.in
+++ b/mail/mimedefang/files/patch-examples__init-script.in
@@ -1,5 +1,5 @@
---- examples/init-script.in.orig 2009-05-04 17:34:32.000000000 +0200
-+++ examples/init-script.in 2010-08-13 10:34:05.000000000 +0200
+--- examples/init-script.in.orig 2010-06-30 01:50:32.000000000 +0400
++++ examples/init-script.in 2011-12-14 00:40:09.284988761 +0400
@@ -39,6 +39,12 @@
# The socket used by mimedefang to communicate with sendmail
# SOCKET=$SPOOLDIR/mimedefang.sock
@@ -27,7 +27,7 @@
# If you want to use the "notification" facility, set the appropriate port.
# See the mimedefang-notify man page for details.
-@@ -189,6 +195,7 @@
+@@ -193,6 +199,7 @@
procname=$PROGDIR/$prog-multiplexor
start_cmd="start_it"
stop_cmd="stop_it"
@@ -35,7 +35,7 @@
sig_reload="INT"
reread_cmd="reread_it"
# provide both "reload", the FreeBSD default, with a direct signal to
-@@ -199,6 +206,8 @@
+@@ -203,6 +210,8 @@
# Make sure required vars are set
SOCKET=${SOCKET:=$SPOOLDIR/$prog.sock}
MX_SOCKET=${MX_SOCKET:=$SPOOLDIR/$prog-multiplexor.sock}
@@ -44,7 +44,7 @@
start_it() {
if test -r $PID ; then
-@@ -281,6 +290,29 @@
+@@ -286,6 +295,29 @@
kill `cat $MXPID`
return 1
fi
@@ -74,7 +74,16 @@
return 0
}
-@@ -368,6 +400,12 @@
+@@ -321,7 +353,7 @@
+ rm -f $MX_SOCKET > /dev/null 2>&1
+ rm -f $SOCKET > /dev/null 2>&1
+
+- if [ "$1" = "wait" ] ; then
++ if [ 1 ] ; then
+ printf "Waiting for daemons to exit."
+ WAITPID=""
+ test -f $PID && WAITPID=`cat $PID`
+@@ -373,6 +405,12 @@
fi
}