aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2006-07-08 13:17:43 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2006-07-08 13:17:43 +0000
commit81c8a4235d83de96d60051571b5c231664cfe39b (patch)
tree84f2a2f710cb6724662a94d94418dd8d5e344043 /mail
parent52f26e4a0d5fdc1dc08494921e6d68a1967e0390 (diff)
downloadports-81c8a4235d83de96d60051571b5c231664cfe39b.tar.gz
ports-81c8a4235d83de96d60051571b5c231664cfe39b.zip
- add WITH_DILLO knob and optionally depend on www/dillo
- don't strip binaries when building with WITH_DEBUG PR: 99813 Submitted by: Pawel Pekala <c0rn@o2.pl>
Notes
Notes: svn path=/head/; revision=167194
Diffstat (limited to 'mail')
-rw-r--r--mail/claws-mail/Makefile11
-rw-r--r--mail/claws-mail/pkg-plist6
-rw-r--r--mail/sylpheed-claws/Makefile11
-rw-r--r--mail/sylpheed-claws/pkg-plist6
4 files changed, 26 insertions, 8 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 7a8a05e9d0d7..0870ae540bbf 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 2.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -52,6 +52,7 @@ OPTIONS= ALL "Enable all options." off \
CLAMAV "Enable virus-checking support." off \
COMPFACE "Enable X-Face support." on \
DEBUG "Enable debug support." off \
+ DILLO "Enable Dillo HTML viewer." off \
GNOMEPRINT "Enable extended print support (GNOME)." off \
GPGME "Enable PGP/GnuPG support using GPGME." off \
JPILOT "Enable JPilot support." off \
@@ -145,6 +146,14 @@ PLIST_SUB+= THEMES=""
.endif
.if defined(WITH_DEBUG) || defined(WITH_ALL)
CONFIGURE_ARGS+= --enable-maintainer-mode --enable-crash-dialog
+STRIP=
+.endif
+.if defined(WITH_DILLO) || defined(WITH_ALL)
+PLIST_SUB+= DILLO=""
+RUN_DEPENDS+= dillo:${PORTSDIR}/www/dillo
+.else
+PLIST_SUB+= DILLO="@comment "
+CONFIGURE_ARGS+= --disable-dillo-viewer-plugin
.endif
post-extract:
diff --git a/mail/claws-mail/pkg-plist b/mail/claws-mail/pkg-plist
index 79d8fc95e87f..5d285bcfaaf9 100644
--- a/mail/claws-mail/pkg-plist
+++ b/mail/claws-mail/pkg-plist
@@ -201,9 +201,9 @@ include/sylpheed-claws/wizard.h
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.a
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.la
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.so
-lib/sylpheed-claws/plugins/dillo_viewer.a
-lib/sylpheed-claws/plugins/dillo_viewer.la
-lib/sylpheed-claws/plugins/dillo_viewer.so
+%%DILLO%%lib/sylpheed-claws/plugins/dillo_viewer.a
+%%DILLO%%lib/sylpheed-claws/plugins/dillo_viewer.la
+%%DILLO%%lib/sylpheed-claws/plugins/dillo_viewer.so
%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.a
%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.la
%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.so
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 7a8a05e9d0d7..0870ae540bbf 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 2.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -52,6 +52,7 @@ OPTIONS= ALL "Enable all options." off \
CLAMAV "Enable virus-checking support." off \
COMPFACE "Enable X-Face support." on \
DEBUG "Enable debug support." off \
+ DILLO "Enable Dillo HTML viewer." off \
GNOMEPRINT "Enable extended print support (GNOME)." off \
GPGME "Enable PGP/GnuPG support using GPGME." off \
JPILOT "Enable JPilot support." off \
@@ -145,6 +146,14 @@ PLIST_SUB+= THEMES=""
.endif
.if defined(WITH_DEBUG) || defined(WITH_ALL)
CONFIGURE_ARGS+= --enable-maintainer-mode --enable-crash-dialog
+STRIP=
+.endif
+.if defined(WITH_DILLO) || defined(WITH_ALL)
+PLIST_SUB+= DILLO=""
+RUN_DEPENDS+= dillo:${PORTSDIR}/www/dillo
+.else
+PLIST_SUB+= DILLO="@comment "
+CONFIGURE_ARGS+= --disable-dillo-viewer-plugin
.endif
post-extract:
diff --git a/mail/sylpheed-claws/pkg-plist b/mail/sylpheed-claws/pkg-plist
index 79d8fc95e87f..5d285bcfaaf9 100644
--- a/mail/sylpheed-claws/pkg-plist
+++ b/mail/sylpheed-claws/pkg-plist
@@ -201,9 +201,9 @@ include/sylpheed-claws/wizard.h
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.a
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.la
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.so
-lib/sylpheed-claws/plugins/dillo_viewer.a
-lib/sylpheed-claws/plugins/dillo_viewer.la
-lib/sylpheed-claws/plugins/dillo_viewer.so
+%%DILLO%%lib/sylpheed-claws/plugins/dillo_viewer.a
+%%DILLO%%lib/sylpheed-claws/plugins/dillo_viewer.la
+%%DILLO%%lib/sylpheed-claws/plugins/dillo_viewer.so
%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.a
%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.la
%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.so