aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDerek Schrock <dereks@lifeofadishwasher.com>2022-12-27 15:00:38 +0000
committerKurt Jaeger <pi@FreeBSD.org>2022-12-27 15:01:59 +0000
commit8341f685dd02030d7c1e027be83ec57b3bf06272 (patch)
treed7c9e78cdf3b428042b37838758b2bb008dced85 /mail
parent8ad732afc367fd8743b229427700d3a1948d7890 (diff)
downloadports-8341f685dd02030d7c1e027be83ec57b3bf06272.tar.gz
ports-8341f685dd02030d7c1e027be83ec57b3bf06272.zip
mail/py-rfc6555: Happy Eyeballs Algorithm described in RFC 6555 (new port)
Synchronous Python implementation of the Happy Eyeballs Algorithm described in RFC 6555. Provided with a single file and dead-simple API to allow easy vendoring and integration into other projects. PR: 262231 Author: Derek Schrock <dereks@lifeofadishwasher.com> Differential Revision: https://reviews.freebsd.org/D34389
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-rfc6555/Makefile23
-rw-r--r--mail/py-rfc6555/distinfo3
-rw-r--r--mail/py-rfc6555/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 2ce4e39f4fdc..48cc9bcbfe1a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -521,6 +521,7 @@
SUBDIR += py-pyspf
SUBDIR += py-python-slimta
SUBDIR += py-pyzmail
+ SUBDIR += py-rfc6555
SUBDIR += py-spf-engine
SUBDIR += py-validate_email
SUBDIR += pymsgauth
diff --git a/mail/py-rfc6555/Makefile b/mail/py-rfc6555/Makefile
new file mode 100644
index 000000000000..b765f3b6301d
--- /dev/null
+++ b/mail/py-rfc6555/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= rfc6555
+PORTVERSION= 0.1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= mail python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dereks@lifeofadishwasher.com
+COMMENT= Happy Eyeballs Algorithm described in RFC 6555
+WWW= https://github.com/sethmlarson/rfc6555
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= pytest python
+# github port since tests are not included in sdist
+# https://github.com/sethmlarson/rfc6555/pull/8
+USE_GITHUB= yes
+GH_ACCOUNT= sethmlarson
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/py-rfc6555/distinfo b/mail/py-rfc6555/distinfo
new file mode 100644
index 000000000000..0d62060b64a5
--- /dev/null
+++ b/mail/py-rfc6555/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646273914
+SHA256 (sethmlarson-rfc6555-v0.1.0_GH0.tar.gz) = 8a15da0f619227c6938be27c64e844668701bca65205002eda789a4fd883b23f
+SIZE (sethmlarson-rfc6555-v0.1.0_GH0.tar.gz) = 11216
diff --git a/mail/py-rfc6555/pkg-descr b/mail/py-rfc6555/pkg-descr
new file mode 100644
index 000000000000..c4a7174d76de
--- /dev/null
+++ b/mail/py-rfc6555/pkg-descr
@@ -0,0 +1,3 @@
+Synchronous Python implementation of the Happy Eyeballs Algorithm
+described in RFC 6555. Provided with a single file and dead-simple
+API to allow easy vendoring and integration into other projects.