aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2024-04-06 23:32:10 +0000
committerFlorian Smeets <flo@FreeBSD.org>2024-04-07 09:36:13 +0000
commit92a030dffd4fd7c3f5abdd7a85b16086da294fe1 (patch)
treed83f5e611d5723c97792ba1aa7179471fd6c2e40 /mail
parent04a6b84a1a7982cc3e6966d9a6be0b8e6f8648ee (diff)
downloadports-92a030dffd4fd7c3f5abdd7a85b16086da294fe1.tar.gz
ports-92a030dffd4fd7c3f5abdd7a85b16086da294fe1.zip
databases/p5-DBD-mysql: Fix for MariaDB users
Add a new variable DBD_MYSQL, use that in *_DEPENDS and add mysql to USES where required. DBD_MYSQL will automatically set the correct DBD dependency. In cd16748194e2 databases/p5-DBD-mysql was updated to 5.x, in 5.x the support for MariaDB was removed and only MySQL >= 8.0 is supported. In the 4.x releases MariaDB is still supported, according to upstream 4.x will still be supported for a while [1], so use that for now when we detect that MYSQL_FLAVOUR is set to mariadb. databases/p5-DBD-mysql4 was added in d95f49cb3b54. DBD:MariaDB would be another alternative, but migrating to it might need more analysis than just staying with the 4.x releases of p5-DBD-mysql. This thread on the amavis-users mailing list has a very good summary [2] from the author of DBD:MariaDB. This includes ideas and suggestions from vvd and mat. Thanks! [1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=277889#c17 [2] https://lists.amavis.org/pipermail/amavis-users/2024-March/006823.html PR: 275100, 277889 Reviewed by: vvd, mat Fixes: cd16748194e2 Differential Revision: https://reviews.freebsd.org/D44662
Diffstat (limited to 'mail')
-rw-r--r--mail/assp/Makefile5
-rw-r--r--mail/exilog/Makefile4
-rw-r--r--mail/opendmarc/Makefile6
-rw-r--r--mail/policyd2/Makefile5
-rw-r--r--mail/ratelimit-policyd/Makefile5
-rw-r--r--mail/spamassassin-devel/Makefile3
-rw-r--r--mail/spamassassin/Makefile4
-rw-r--r--mail/sqlgrey/Makefile5
-rw-r--r--mail/sympa/Makefile5
9 files changed, 25 insertions, 17 deletions
diff --git a/mail/assp/Makefile b/mail/assp/Makefile
index 115ed0933457..39dde5a3e4f4 100644
--- a/mail/assp/Makefile
+++ b/mail/assp/Makefile
@@ -1,6 +1,6 @@
PORTNAME= assp
PORTVERSION= 1.9.9.14158
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://www.ringofsaturn.com/distfiles/
@@ -96,7 +96,8 @@ RUN_DEPENDS+= p5-Net-DNS>=0.68:dns/p5-Net-DNS
.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= p5-Tie-DBI>=1.05:databases/p5-Tie-DBI
-RUN_DEPENDS+= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+RUN_DEPENDS+= ${DBD_MYSQL}
+USES+= mysql
.endif
.if ${PORT_OPTIONS:MMATCHRE}
diff --git a/mail/exilog/Makefile b/mail/exilog/Makefile
index 2cdba1a826db..a6866f4d680e 100644
--- a/mail/exilog/Makefile
+++ b/mail/exilog/Makefile
@@ -1,6 +1,6 @@
PORTNAME= exilog
PORTVERSION= 0.5
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= mail
MASTER_SITES= http://duncanthrax.net/exilog/
@@ -30,7 +30,7 @@ OPTIONS_DEFAULT= AGENT DOCS MYSQL
OPTIONS_SUB= YES
AGENT_DESC= Include exilog agent
-MYSQL_RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+MYSQL_RUN_DEPENDS= ${DBD_MYSQL}
MYSQL_USES= mysql
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
diff --git a/mail/opendmarc/Makefile b/mail/opendmarc/Makefile
index 114c2b74a2fe..e7636444a181 100644
--- a/mail/opendmarc/Makefile
+++ b/mail/opendmarc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= opendmarc
PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail security
MASTER_SITES= GH
@@ -13,10 +13,10 @@ LICENSE_COMB= multi
RUN_DEPENDS= p5-Switch>=0:lang/p5-Switch \
p5-DBI>=0:databases/p5-DBI \
- p5-DBD-mysql>=0:databases/p5-DBD-mysql \
+ ${DBD_MYSQL} \
p5-HTTP-Message>=0:www/p5-HTTP-Message
-USES= cpe libtool perl5 shebangfix autoreconf
+USES= cpe libtool mysql perl5 shebangfix autoreconf
LICENSE_FILE_SENDMAIL= ${WRKSRC}/LICENSE.Sendmail
LICENSE_GROUPS_SENDMAIL= FSF OSI
LICENSE_NAME_SENDMAIL= Sendmail Open Source License
diff --git a/mail/policyd2/Makefile b/mail/policyd2/Makefile
index c31d36e2aa39..f4147f5a9083 100644
--- a/mail/policyd2/Makefile
+++ b/mail/policyd2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= policyd2
PORTVERSION= 2.0.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= https://download.policyd.org/v${PORTVERSION}/
DISTNAME= cluebringer-v${PORTVERSION}
@@ -39,7 +39,8 @@ PGSQL_DESC= Add a dependency on DBD::Pg
SQLITE_DESC= Add a dependency on DBD:SQLite
WEBUI_DESC= Add a dependency on the corresponding PHP pdo driver
-MYSQL_RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+MYSQL_RUN_DEPENDS= ${DBD_MYSQL}
+MYSQL_USES= mysql
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
SQLITE_RUN_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite
diff --git a/mail/ratelimit-policyd/Makefile b/mail/ratelimit-policyd/Makefile
index dfd58c973b4e..7e5efab5217d 100644
--- a/mail/ratelimit-policyd/Makefile
+++ b/mail/ratelimit-policyd/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ratelimit-policyd
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= mail
MAINTAINER= 000.fbsd@quip.cz
@@ -8,13 +9,13 @@ WWW= https://github.com/MirLach/ratelimit-policyd
LICENSE= NONE
-USES+= perl5 shebangfix
+USES+= mysql perl5 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= MirLach
#GH_TAGNAME= 65154a2
-RUN_DEPENDS+= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+RUN_DEPENDS+= ${DBD_MYSQL}
SHEBANG_FILES= ratelimit-policyd.pl
diff --git a/mail/spamassassin-devel/Makefile b/mail/spamassassin-devel/Makefile
index ce9e36451e06..b144aa58ff2d 100644
--- a/mail/spamassassin-devel/Makefile
+++ b/mail/spamassassin-devel/Makefile
@@ -123,7 +123,8 @@ DMARC_RUN_DEPENDS= p5-Mail-DMARC>=0:mail/p5-Mail-DMARC \
p5-URI>=0:net/p5-URI
GNUPG_RUN_DEPENDS= gnupg1>=1.4.7:security/gnupg1
GNUPG2_RUN_DEPENDS= gpg2:security/gnupg
-MYSQL_RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+MYSQL_RUN_DEPENDS= ${DBD_MYSQL}
+MYSQL_USES= mysql
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
PYZOR_RUN_DEPENDS= pyzor:mail/pyzor
RAZOR_RUN_DEPENDS= razor-agents>=2.84:mail/razor-agents \
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index 06993c0e624f..63058355b9a2 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -1,5 +1,6 @@
PORTNAME= spamassassin
PORTVERSION= 4.0.1
+PORTREVISION= 1
CATEGORIES?= mail perl5
MASTER_SITES= https://archive.apache.org/dist/${PORTNAME}/source/ CPAN/Mail
DISTNAME= Mail-SpamAssassin-${PORTVERSION}
@@ -119,7 +120,8 @@ DMARC_RUN_DEPENDS= p5-Mail-DMARC>=0:mail/p5-Mail-DMARC \
p5-URI>=0:net/p5-URI
GNUPG_RUN_DEPENDS= gnupg1>=1.4.7:security/gnupg1
GNUPG2_RUN_DEPENDS= gpg2:security/gnupg
-MYSQL_RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+MYSQL_RUN_DEPENDS= ${DBD_MYSQL}
+MYSQL_USES= mysql
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
PYZOR_RUN_DEPENDS= pyzor:mail/pyzor
RAZOR_RUN_DEPENDS= razor-agents>=2.84:mail/razor-agents \
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 0e08bd7d3f9c..29dd55de1b02 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sqlgrey
PORTVERSION= 1.8.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-1.8%20%28stable%29
@@ -38,7 +38,8 @@ OPTIONS_DEFAULT=PGSQL
STATS_DESC= Depend on Date::Calc for logstats.pl script
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
-MYSQL_RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+MYSQL_RUN_DEPENDS= ${DBD_MYSQL}
+MYSQL_USES= mysql
SQLITE_RUN_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite
STATS_RUN_DEPENDS= p5-Date-Calc>=0:devel/p5-Date-Calc
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index 55719a5614a3..02f2c7ff9196 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sympa
DISTVERSION= 6.2.72
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MAINTAINER= dgeo@centrale-med.fr
@@ -110,9 +110,10 @@ APACHE_RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:www/mod_fastcgi
APACHE_USES= apache:run
FASTCGI_RUN_DEPENDS= p5-CGI-Fast>=1.08:www/p5-CGI-Fast \
p5-FCGI>=0.67:www/p5-FCGI
-MYSQL_RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+MYSQL_RUN_DEPENDS= ${DBD_MYSQL}
MYSQL_SUB_LIST= REQ_MYSQL=mysql
MYSQL_SUB_LIST_OFF= REQ_MYSQL=""
+MYSQL_USES= mysql
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=2.00:databases/p5-DBD-Pg
PGSQL_SUB_LIST= REQ_PGSQL=postgresql
PGSQL_SUB_LIST_OFF= REQ_PGSQL=""