aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2018-05-11 11:23:42 +0000
committerMatthias Andree <mandree@FreeBSD.org>2018-05-11 11:23:42 +0000
commit9c9c191d6e0d53bd3c1d413cef07b50ccc0ff871 (patch)
treec1fae1e497e2620d4ccbe2b698f6611552dfe0d8 /mail
parente00f1f043fd43741ec4057e1ca81385267a38423 (diff)
downloadports-9c9c191d6e0d53bd3c1d413cef07b50ccc0ff871.tar.gz
ports-9c9c191d6e0d53bd3c1d413cef07b50ccc0ff871.zip
Fix build with openssl-devel, remove BROKEN_SSL.
Approved by: (blanket approval for unbreaking builds)
Notes
Notes: svn path=/head/; revision=469628
Diffstat (limited to 'mail')
-rw-r--r--mail/fetchmail/Makefile2
-rw-r--r--mail/fetchmail/files/patch-socket.c2
2 files changed, 1 insertions, 3 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 35f9ea7696f1..c95863e952c8 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -14,8 +14,6 @@ COMMENT= Batch mail retrieval utility for IMAP/POP3/ETRN/ODMR
LICENSE= GPLv2 LGPL21
LICENSE_COMB= dual
-BROKEN_SSL= openssl-devel
-
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USERS= ${PORTNAME}
diff --git a/mail/fetchmail/files/patch-socket.c b/mail/fetchmail/files/patch-socket.c
index 28a0b99caf23..6bb35ccf25d1 100644
--- a/mail/fetchmail/files/patch-socket.c
+++ b/mail/fetchmail/files/patch-socket.c
@@ -5,7 +5,7 @@
if(myproto) {
if(!strcasecmp("ssl2",myproto)) {
-#if HAVE_DECL_SSLV2_CLIENT_METHOD + 0 > 0
-+#ifndef OPENSSL_NO_SSL2
++#if (HAVE_DECL_SSLV2_CLIENT_METHOD + 0 > 0) && !defined(OPENSSL_NO_SSL2)
_ctx[sock] = SSL_CTX_new(SSLv2_client_method());
#else
- report(stderr, GT_("Your operating system does not support SSLv2.\n"));