aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-30 06:00:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-30 06:00:28 +0000
commit9ec324fbdb5c0f7a05025a47c0e1766aafc3be73 (patch)
treea6cdc278f108abe8000d50a5ec2f187d9b190115 /mail
parent781c12526184ca8b32d19b03e8c527a2cd51e6e6 (diff)
downloadports-9ec324fbdb5c0f7a05025a47c0e1766aafc3be73.tar.gz
ports-9ec324fbdb5c0f7a05025a47c0e1766aafc3be73.zip
Chase mail/cclient shared library version bump.
Several patches were needed due to the removal of include/c-client/linkage.c in favour of include/c-client/linkage.h. PR: ports/114833 Submitted by: "Pedro J. Lobo" <pjlobo@sec.upm.es>
Notes
Notes: svn path=/head/; revision=200423
Diffstat (limited to 'mail')
-rw-r--r--mail/mailsync/Makefile3
-rw-r--r--mail/mailsync/files/patch-configure10
-rw-r--r--mail/mailsync/files/patch-src_mailsync_main.cc11
-rw-r--r--mail/p5-Mail-CClient/Makefile5
-rw-r--r--mail/php4-imap/Makefile1
-rw-r--r--mail/php5-imap/Makefile1
-rw-r--r--mail/phplist/Makefile1
-rw-r--r--mail/postilion/Makefile2
-rw-r--r--mail/prayer/Makefile1
-rw-r--r--mail/prayer/files/patch-prayer__mm.c11
-rw-r--r--mail/tkrat2/Makefile4
11 files changed, 40 insertions, 10 deletions
diff --git a/mail/mailsync/Makefile b/mail/mailsync/Makefile
index 912a114335ca..1aa6634ef55e 100644
--- a/mail/mailsync/Makefile
+++ b/mail/mailsync/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mailsync
PORTVERSION= 5.2.1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +16,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Mailsync is a way of keeping a collection of mailboxes synchronized
-LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
+LIB_DEPENDS= c-client4.9:${PORTSDIR}/mail/cclient
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
diff --git a/mail/mailsync/files/patch-configure b/mail/mailsync/files/patch-configure
index 6c56797d5f69..8501377ed8d5 100644
--- a/mail/mailsync/files/patch-configure
+++ b/mail/mailsync/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Wed Jun 30 10:04:12 2004
-+++ configure Tue Aug 9 16:25:24 2005
+--- configure.orig Wed Jun 30 18:04:12 2004
++++ configure Sun Sep 30 15:39:42 2007
@@ -5012,7 +5012,7 @@
@@ -59,15 +59,17 @@
fi
-@@ -5477,7 +5475,7 @@
+@@ -5477,8 +5475,8 @@
echo "$as_me:$LINENO: checking for c-client.h" >&5
echo $ECHO_N "checking for c-client.h... $ECHO_C" >&6
- for p in `eval "echo {${CCLIENTLOCATIONS}}{,/c-client,/lib/c-client,/include/c-client,/include,/include/imap}"` ; do
+- if test -r "${p}/c-client.h" -a -r "${p}/linkage.h" -a -r "${p}/linkage.c" ; then
+ p=${CCLIENTLOCATIONS}/include/c-client
- if test -r "${p}/c-client.h" -a -r "${p}/linkage.h" -a -r "${p}/linkage.c" ; then
++ if test -r "${p}/c-client.h" -a -r "${p}/linkage.h" ; then
CCLIENT_INCLUDES="-I${p}"
CCLIENT_LINKAGE_H="${p}/linkage.h"
+ CCLIENT_LINKAGE_C="${p}/linkage.c"
@@ -5486,7 +5484,6 @@
echo "${ECHO_T}found in ${p}" >&6
break
diff --git a/mail/mailsync/files/patch-src_mailsync_main.cc b/mail/mailsync/files/patch-src_mailsync_main.cc
new file mode 100644
index 000000000000..f5e334e8e1c1
--- /dev/null
+++ b/mail/mailsync/files/patch-src_mailsync_main.cc
@@ -0,0 +1,11 @@
+--- src/mailsync_main.cc.orig Sun Sep 30 15:39:52 2007
++++ src/mailsync_main.cc Sun Sep 30 15:39:56 2007
+@@ -68,7 +68,7 @@
+ int success;
+ bool& debug = options.debug;
+
+-#include "linkage.c"
++#include "linkage.h"
+
+ //
+ // Parse arguments, read config file, choose operation mode
diff --git a/mail/p5-Mail-CClient/Makefile b/mail/p5-Mail-CClient/Makefile
index 180ef3c7733a..b4896ccf2a31 100644
--- a/mail/p5-Mail-CClient/Makefile
+++ b/mail/p5-Mail-CClient/Makefile
@@ -7,6 +7,7 @@
PORTNAME= CClient
PORTVERSION= 1.12
+PORTREVISION= 1
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Mail/HDIAS
@@ -14,9 +15,9 @@ PKGNAMEPREFIX= p5-
DISTNAME= Mail-Cclient-${PORTVERSION}
MAINTAINER= mat@FreeBSD.org
-COMMENT= Perl interface to the c-client mailbox API
+COMMENT= Perl interface to the c-client mailbox API
-LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
+LIB_DEPENDS= c-client4.9:${PORTSDIR}/mail/cclient
PERL_CONFIGURE= yes
CONFIGURE_ARGS= --cclient_dir=${LOCALBASE} \
diff --git a/mail/php4-imap/Makefile b/mail/php4-imap/Makefile
index 7bda6f50f705..db1bb1234fd6 100644
--- a/mail/php4-imap/Makefile
+++ b/mail/php4-imap/Makefile
@@ -6,6 +6,7 @@
#
CATEGORIES= mail
+PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php4
diff --git a/mail/php5-imap/Makefile b/mail/php5-imap/Makefile
index 859dccbc4a6e..666df03bb0ec 100644
--- a/mail/php5-imap/Makefile
+++ b/mail/php5-imap/Makefile
@@ -6,6 +6,7 @@
#
CATEGORIES= mail
+PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/mail/phplist/Makefile b/mail/phplist/Makefile
index 7bbad1712cc2..924aec0c502a 100644
--- a/mail/phplist/Makefile
+++ b/mail/phplist/Makefile
@@ -6,6 +6,7 @@
PORTNAME= phplist
PORTVERSION= 2.10.5
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
diff --git a/mail/postilion/Makefile b/mail/postilion/Makefile
index d5b8a3ed1f09..102375356e99 100644
--- a/mail/postilion/Makefile
+++ b/mail/postilion/Makefile
@@ -7,7 +7,7 @@
PORTNAME= postilion
PORTVERSION= 0.9.3c
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail tk83
MASTER_SITES= http://www.postilion.org/software/Postilion/
DISTNAME= ${PORTNAME}-current
diff --git a/mail/prayer/Makefile b/mail/prayer/Makefile
index 20c84beb7be8..d97f439670e2 100644
--- a/mail/prayer/Makefile
+++ b/mail/prayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= prayer
PORTVERSION= 1.0.16
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/prayer/
diff --git a/mail/prayer/files/patch-prayer__mm.c b/mail/prayer/files/patch-prayer__mm.c
new file mode 100644
index 000000000000..e682d54a896c
--- /dev/null
+++ b/mail/prayer/files/patch-prayer__mm.c
@@ -0,0 +1,11 @@
+--- prayer/mm.c.orig Sun Sep 30 15:50:26 2007
++++ prayer/mm.c Sun Sep 30 15:50:30 2007
+@@ -31,7 +31,7 @@
+ /* Must call mminit before any other fn */
+ void mm_init()
+ {
+-#include "linkage.c"
++#include "linkage.h"
+
+ ml_init();
+ }
diff --git a/mail/tkrat2/Makefile b/mail/tkrat2/Makefile
index fb63ceecc363..1c8b1672553e 100644
--- a/mail/tkrat2/Makefile
+++ b/mail/tkrat2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tkrat
PORTVERSION= 2.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail tk84
MASTER_SITES= http://tkrat.org/downloads/stable/ \
ftp://ftp.tkrat.org/pub/tkrat/
@@ -17,7 +17,7 @@ COMMENT= A mail user agent for X with a Tcl/Tk user interface
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
tk84:${PORTSDIR}/x11-toolkits/tk84 \
- c-client4.8:${PORTSDIR}/mail/cclient
+ c-client4.9:${PORTSDIR}/mail/cclient
USE_XLIB= yes