aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-01-27 00:05:16 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-01-27 00:08:31 +0000
commitc443b6628ed1c2b7e5cd65ee4f8cc12340fad8e3 (patch)
tree8e00bf5e80adbac79fe30953a809ab82b50c8ddc /mail
parentef939d360c9add9d6491e049459baeb0d6e0ec4b (diff)
downloadports-c443b6628ed1c2b7e5cd65ee4f8cc12340fad8e3.tar.gz
ports-c443b6628ed1c2b7e5cd65ee4f8cc12340fad8e3.zip
mail/bogofilter*: change default database
* The default version of mail/bogofilter now uses LMDB instead of Berkeley DB. It is not compatible and cannot read databases. * bogofilter was renamed to bogofilter-bdb * bogofilter-lmdb was renamed to bogofilter * MOVED/UPDATING entries included.
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile2
-rw-r--r--mail/bogofilter-bdb/Makefile98
-rw-r--r--mail/bogofilter-bdb/distinfo (renamed from mail/bogofilter/distinfo)0
-rw-r--r--mail/bogofilter-bdb/files/patch-configure (renamed from mail/bogofilter/files/patch-configure)0
-rw-r--r--mail/bogofilter-bdb/files/patch-contrib__trainbogo.sh (renamed from mail/bogofilter/files/patch-contrib__trainbogo.sh)0
-rw-r--r--mail/bogofilter-bdb/pkg-descr (renamed from mail/bogofilter/pkg-descr)0
-rw-r--r--mail/bogofilter-bdb/pkg-install (renamed from mail/bogofilter/pkg-install)0
-rw-r--r--mail/bogofilter-bdb/pkg-plist (renamed from mail/bogofilter/pkg-plist)0
-rw-r--r--mail/bogofilter-kc/Makefile2
-rw-r--r--mail/bogofilter-lmdb/Makefile19
-rw-r--r--mail/bogofilter-sqlite/Makefile2
-rw-r--r--mail/bogofilter/Makefile102
12 files changed, 113 insertions, 112 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 464efdd3f20e..60e1f8d8e0bd 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -30,8 +30,8 @@
SUBDIR += bincimap
SUBDIR += bmf
SUBDIR += bogofilter
+ SUBDIR += bogofilter-bdb
SUBDIR += bogofilter-kc
- SUBDIR += bogofilter-lmdb
SUBDIR += bogofilter-sqlite
SUBDIR += bsfilter
SUBDIR += bsmtp
diff --git a/mail/bogofilter-bdb/Makefile b/mail/bogofilter-bdb/Makefile
new file mode 100644
index 000000000000..178fe62253bb
--- /dev/null
+++ b/mail/bogofilter-bdb/Makefile
@@ -0,0 +1,98 @@
+# Created by: Matthias Andree <matthias.andree@gmx.de>
+
+PORTNAME= bogofilter
+DISTVERSION= 1.2.5
+PORTREVISION?= 3
+CATEGORIES?= mail
+MASTER_SITES= SF/bogofilter/bogofilter-stable/
+PKGNAMESUFFIX?= -bdb
+
+MAINTAINER?= mandree@FreeBSD.org
+COMMENT= Fast, teachable, learning spam detector
+
+LICENSE= GPLv2
+
+.if !defined(MASTERDIR) || ${MASTERDIR} == ${.CURDIR}
+# building master port
+USES+= bdb:5+
+.endif
+
+OPTIONS_DEFINE= GSL UNICODE DOCS
+OPTIONS_DEFAULT= GSL UNICODE
+GSL_DESC= Link with system-wide GSL dynamically (recommended)
+UNICODE_DESC= Normalize tokens to Unicode (UTF-8) (recommended)
+
+CONFLICTS_INSTALL?= bogofilter-sqlite bogofilter bogofilter-kc
+
+USES+= cpe perl5 shebangfix tar:xz
+SHEBANG_FILES= contrib/randomtrain.sh contrib/scramble.sh \
+ src/tests/unsort.pl contrib/*.pl
+USE_PERL5= run
+GNU_CONFIGURE= yes
+
+CPE_VENDOR= bogofilter_project
+
+UNICODE_USES= iconv
+UNICODE_CONFIGURE_ENABLE= unicode
+GSL_LIB_DEPENDS= libgsl.so:math/gsl
+GSL_CONFIGURE_OFF= --with-included-gsl
+
+PORTDOCS= *
+
+TEST_TARGET= check
+
+.include <bsd.port.pre.mk>
+
+BF_LIBS?= -l${BDB_LIB_NAME}
+BF_CPPFLAGS?= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
+CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
+.if ${PORT_OPTIONS:MUNICODE}
+BF_LIBS+= ${ICONV_LIB}
+.endif
+CPPFLAGS+= ${BF_CPPFLAGS}
+LIBS+= -L${LOCALBASE}/lib ${BF_LIBS}
+CONFIGURE_ENV+= PERL="${PERL}"
+INSTALL_TARGET= install-strip prefix=${PREFIX} mandir=${MANPREFIX}/man
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/INTEGRITY_TESTS = t.lock1 t.lock3 t.valgrind/INTEGRITY_TESTS = t.lock1/' \
+ -e 's/ENVIRON_TESTS = t.abort/ENVIRON_TESTS =/' \
+ ${WRKSRC}/src/tests/Makefile.in
+
+post-build:
+ cd ${WRKSRC}/src && ${SETENV} SHELL=${SH} ${MAKE_CMD} ${TEST_TARGET} ${_MAKE_JOBS} SHELL=${SH} \
+ || { r=$$? ; head -n30000 ${WRKSRC}/src/tests/test-suite.log ; exit $$r ; }
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/contrib
+.for i in html programmer xml
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/${i}
+.endfor
+.for i in AUTHORS COPYING INSTALL NEWS README README.git \
+ doc/README.validation TODO GETTING.STARTED \
+ RELEASE.NOTES doc/README.db doc/README.sqlite \
+ doc/integrating-with-postfix doc/integrating-with-qmail \
+ doc/bogofilter-tuning.HOWTO.html doc/bogofilter-SA-* \
+ doc/bogofilter-faq.html doc/bogofilter-faq-fr.html
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
+.endfor
+.for i in README.randomtrain README.contrib
+ ${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${STAGEDIR}${DOCSDIR}/contrib/${i}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/trio/AUTHORS ${STAGEDIR}${DOCSDIR}/AUTHORS.trio
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.xml ${STAGEDIR}${DOCSDIR}/xml
+ ${INSTALL_DATA} ${WRKSRC}/doc/programmer/README.freebsd ${STAGEDIR}${DOCSDIR}/programmer
+ ${INSTALL_PROGRAM} ${WRKSRC}/bogogrep ${STAGEDIR}${PREFIX}/bin/
+.for i in bfproxy.pl bogofilter-milter.pl bogo.R bogofilter-qfe.sh \
+ mime.get.rfc822.pl parmtest.sh printmaildir.pl \
+ bogominitrain.pl \
+ randomtrain.sh scramble.sh spamitarium.pl stripsearch.pl trainbogo.sh
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/${i} ${STAGEDIR}${DOCSDIR}/contrib/${i}
+.endfor
+.for i in dot-qmail-bogofilter-default \
+ mailfilter.example procmailrc.example vm-bogofilter.el
+ ${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${STAGEDIR}${DOCSDIR}/contrib/${i}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/mail/bogofilter/distinfo b/mail/bogofilter-bdb/distinfo
index 480c473b12bf..480c473b12bf 100644
--- a/mail/bogofilter/distinfo
+++ b/mail/bogofilter-bdb/distinfo
diff --git a/mail/bogofilter/files/patch-configure b/mail/bogofilter-bdb/files/patch-configure
index 544c40f04d41..544c40f04d41 100644
--- a/mail/bogofilter/files/patch-configure
+++ b/mail/bogofilter-bdb/files/patch-configure
diff --git a/mail/bogofilter/files/patch-contrib__trainbogo.sh b/mail/bogofilter-bdb/files/patch-contrib__trainbogo.sh
index 0d7cd5742567..0d7cd5742567 100644
--- a/mail/bogofilter/files/patch-contrib__trainbogo.sh
+++ b/mail/bogofilter-bdb/files/patch-contrib__trainbogo.sh
diff --git a/mail/bogofilter/pkg-descr b/mail/bogofilter-bdb/pkg-descr
index 8ad5e92560c6..8ad5e92560c6 100644
--- a/mail/bogofilter/pkg-descr
+++ b/mail/bogofilter-bdb/pkg-descr
diff --git a/mail/bogofilter/pkg-install b/mail/bogofilter-bdb/pkg-install
index 8da3d8915d7e..8da3d8915d7e 100644
--- a/mail/bogofilter/pkg-install
+++ b/mail/bogofilter-bdb/pkg-install
diff --git a/mail/bogofilter/pkg-plist b/mail/bogofilter-bdb/pkg-plist
index 85061fe7228b..85061fe7228b 100644
--- a/mail/bogofilter/pkg-plist
+++ b/mail/bogofilter-bdb/pkg-plist
diff --git a/mail/bogofilter-kc/Makefile b/mail/bogofilter-kc/Makefile
index 8194ff38d2e5..d0cd0eb7ddc6 100644
--- a/mail/bogofilter-kc/Makefile
+++ b/mail/bogofilter-kc/Makefile
@@ -14,6 +14,6 @@ BF_CPPFLAGS= -I${LOCALBASE}/include
BF_LIBS=
DESCR= ${PKGDIR}/pkg-descr
-MASTERDIR= ${.CURDIR}/../bogofilter
+MASTERDIR= ${.CURDIR}/../bogofilter-bdb
.include "${MASTERDIR}/Makefile"
diff --git a/mail/bogofilter-lmdb/Makefile b/mail/bogofilter-lmdb/Makefile
deleted file mode 100644
index f3ecc9dd170d..000000000000
--- a/mail/bogofilter-lmdb/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-PORTNAME= bogofilter
-PORTREVISION= 3
-CATEGORIES= mail
-PKGNAMESUFFIX= -lmdb
-
-MAINTAINER= mandree@FreeBSD.org
-
-LIB_DEPENDS= liblmdb.so:databases/lmdb
-
-CONFLICTS_INSTALL= bogofilter bogofilter-kc bogofilter-sqlite
-
-CONFIGURE_ARGS= --with-database=lmdb
-BF_CPPFLAGS= -I${LOCALBASE}/include
-BF_LIBS=
-DESCR= ${PKGDIR}/pkg-descr
-
-MASTERDIR= ${.CURDIR}/../bogofilter
-
-.include "${MASTERDIR}/Makefile"
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
index 86aed2f298ee..4b923a7d4140 100644
--- a/mail/bogofilter-sqlite/Makefile
+++ b/mail/bogofilter-sqlite/Makefile
@@ -15,6 +15,6 @@ BF_CPPFLAGS= -I${LOCALBASE}/include
BF_LIBS=
DESCR= ${PKGDIR}/pkg-descr
-MASTERDIR= ${.CURDIR}/../bogofilter
+MASTERDIR= ${.CURDIR}/../bogofilter-bdb
.include "${MASTERDIR}/Makefile"
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 74029145934d..4b29b9cb59df 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -1,97 +1,19 @@
-# Created by: Matthias Andree <matthias.andree@gmx.de>
-
PORTNAME= bogofilter
-DISTVERSION= 1.2.5
-PORTREVISION?= 3
-CATEGORIES?= mail
-MASTER_SITES= SF/bogofilter/bogofilter-stable/
-
-MAINTAINER?= mandree@FreeBSD.org
-COMMENT= Fast, teachable, learning spam detector
-
-LICENSE= GPLv2
-
-.if !defined(MASTERDIR) || ${MASTERDIR} == ${.CURDIR}
-# building master port
-USES+= bdb:5+
-.endif
-
-OPTIONS_DEFINE= GSL UNICODE DOCS
-OPTIONS_DEFAULT= GSL UNICODE
-GSL_DESC= Link with system-wide GSL dynamically (recommended)
-UNICODE_DESC= Normalize tokens to Unicode (UTF-8) (recommended)
-
-CONFLICTS_INSTALL?= bogofilter-sqlite bogofilter-lmdb bogofilter-kc
-
-USES+= cpe perl5 shebangfix tar:xz
-SHEBANG_FILES= contrib/randomtrain.sh contrib/scramble.sh \
- src/tests/unsort.pl contrib/*.pl
-USE_PERL5= run
-GNU_CONFIGURE= yes
-
-CPE_VENDOR= bogofilter_project
-
-UNICODE_USES= iconv
-UNICODE_CONFIGURE_ENABLE= unicode
-GSL_LIB_DEPENDS= libgsl.so:math/gsl
-GSL_CONFIGURE_OFF= --with-included-gsl
-
-PORTDOCS= *
-
-TEST_TARGET= check
+PORTREVISION= 3
+CATEGORIES= mail
+PKGNAMESUFFIX= # blank, to override bogofilter-bdb's
-.include <bsd.port.pre.mk>
+MAINTAINER= mandree@FreeBSD.org
-BF_LIBS?= -l${BDB_LIB_NAME}
-BF_CPPFLAGS?= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-.if ${PORT_OPTIONS:MUNICODE}
-BF_LIBS+= ${ICONV_LIB}
-.endif
-CPPFLAGS+= ${BF_CPPFLAGS}
-LIBS+= -L${LOCALBASE}/lib ${BF_LIBS}
-CONFIGURE_ENV+= PERL="${PERL}"
-INSTALL_TARGET= install-strip prefix=${PREFIX} mandir=${MANPREFIX}/man
+LIB_DEPENDS= liblmdb.so:databases/lmdb
-post-patch:
- ${REINPLACE_CMD} -e 's/INTEGRITY_TESTS = t.lock1 t.lock3 t.valgrind/INTEGRITY_TESTS = t.lock1/' \
- -e 's/ENVIRON_TESTS = t.abort/ENVIRON_TESTS =/' \
- ${WRKSRC}/src/tests/Makefile.in
+CONFLICTS_INSTALL= bogofilter-bdb bogofilter-kc bogofilter-sqlite
-post-build:
- cd ${WRKSRC}/src && ${SETENV} SHELL=${SH} ${MAKE_CMD} ${TEST_TARGET} ${_MAKE_JOBS} SHELL=${SH} \
- || { r=$$? ; head -n30000 ${WRKSRC}/src/tests/test-suite.log ; exit $$r ; }
+CONFIGURE_ARGS= --with-database=lmdb
+BF_CPPFLAGS= -I${LOCALBASE}/include
+BF_LIBS=
+DESCR= ${PKGDIR}/pkg-descr
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/contrib
-.for i in html programmer xml
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/${i}
-.endfor
-.for i in AUTHORS COPYING INSTALL NEWS README README.git \
- doc/README.validation TODO GETTING.STARTED \
- RELEASE.NOTES doc/README.db doc/README.sqlite \
- doc/integrating-with-postfix doc/integrating-with-qmail \
- doc/bogofilter-tuning.HOWTO.html doc/bogofilter-SA-* \
- doc/bogofilter-faq.html doc/bogofilter-faq-fr.html
- ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
-.endfor
-.for i in README.randomtrain README.contrib
- ${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${STAGEDIR}${DOCSDIR}/contrib/${i}
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/trio/AUTHORS ${STAGEDIR}${DOCSDIR}/AUTHORS.trio
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/*.xml ${STAGEDIR}${DOCSDIR}/xml
- ${INSTALL_DATA} ${WRKSRC}/doc/programmer/README.freebsd ${STAGEDIR}${DOCSDIR}/programmer
- ${INSTALL_PROGRAM} ${WRKSRC}/bogogrep ${STAGEDIR}${PREFIX}/bin/
-.for i in bfproxy.pl bogofilter-milter.pl bogo.R bogofilter-qfe.sh \
- mime.get.rfc822.pl parmtest.sh printmaildir.pl \
- bogominitrain.pl \
- randomtrain.sh scramble.sh spamitarium.pl stripsearch.pl trainbogo.sh
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/${i} ${STAGEDIR}${DOCSDIR}/contrib/${i}
-.endfor
-.for i in dot-qmail-bogofilter-default \
- mailfilter.example procmailrc.example vm-bogofilter.el
- ${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${STAGEDIR}${DOCSDIR}/contrib/${i}
-.endfor
+MASTERDIR= ${.CURDIR}/../bogofilter-bdb
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"