aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-07-28 10:41:29 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-07-28 10:41:29 +0000
commitc794e7bfeff12758d31e0124f27b961681c6c06e (patch)
treef4470873eb44b8b1a207d7cfe1e7c224db761742 /mail
parent5bf3e01ae135f5f1110fd6a5e3bb05dd21df0b08 (diff)
downloadports-c794e7bfeff12758d31e0124f27b961681c6c06e.tar.gz
ports-c794e7bfeff12758d31e0124f27b961681c6c06e.zip
- Fix ezmlm-idx dependency with IDX option [1]
- Allow overriding max users/aliases per page [2] - Bump PORTREVISION due to fixed dependency PR: ports/170112 [1] Submitted by: Alexander Zubkov <info@zubkov.info> [2] Submitted by: Bryan Drewery <bryan@shatow.net> (maintainer) [1]
Notes
Notes: svn path=/head/; revision=301645
Diffstat (limited to 'mail')
-rw-r--r--mail/qmailadmin/Makefile58
1 files changed, 31 insertions, 27 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index d4ce850dc242..2ac1c8640ef5 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qmailadmin
PORTVERSION= 1.2.15
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= mail www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION}
@@ -24,17 +25,26 @@ RUN_DEPENDS= \
autorespond:${PORTSDIR}/mail/autorespond \
${VPOPMAIL_DIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
-.include <bsd.port.options.mk>
+CONFLICTS= qmailadmin-devel-1.*
-.if empty(PORT_OPTIONS:MIDX)
-BUILD_DEPENDS+= ezmlm-send:${PORTSDIR}/mail/ezmlm
-RUN_DEPENDS+= ezmlm-send:${PORTSDIR}/mail/ezmlm
-.else
-BUILD_DEPENDS+= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
-RUN_DEPENDS+= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
-.endif
+OPTIONS_DEFINE= IPAUTH USER_INDEX MODIFY_QUOTA DOMAIN_AUTOFILL \
+ IDX IDX_SQL HELP SPAM_DETECTION SPAM_NEEDS_EMAIL \
+ CATCHALL TRIVIAL_PASSWORD NOCACHE
+OPTIONS_DEFAULT=IPAUTH IDX_SQL USER_INDEX CATCHALL TRIVIAL_PASSWORD
+IPAUTH_DESC= Check IP address after login
+USER_INDEX_DESC= Enable user index display
+MODIFY_QUOTA_DESC= Allow domain admin to modify quotas
+DOMAIN_AUTOFILL_DESC= Autofill domain on login using hostname
+IDX_DESC= Use ezmlm-idx instead of ezmlm
+IDX_SQL_DESC= Enable MySQL support for ezmlm
+HELP_DESC= Show help links on login page
+SPAM_DETECTION_DESC= Allow users to toggle spam checking
+SPAM_NEEDS_EMAIL_DESC= Append user's email to spam command
+CATCHALL_DESC= Enable catch-all accounts
+TRIVIAL_PASSWORD_DESC= Disallow password containing username
+NOCACHE_DESC= Prohibit caching via http headers
-CONFLICTS= qmailadmin-devel-1.*
+.include <bsd.port.options.mk>
# vpopmail installation directory
#
@@ -54,24 +64,6 @@ WANT_QMAIL= yes
# default is "|preline LOCALBASE/bin/maildrop /etc/mailfilter"
# do not forget the "|" at the start
# USER_INDEX - might confuse earlier versions of Internet Explorer
-
-OPTIONS_DEFINE= IPAUTH USER_INDEX MODIFY_QUOTA DOMAIN_AUTOFILL \
- IDX IDX_SQL HELP SPAM_DETECTION SPAM_NEEDS_EMAIL \
- CATCHALL TRIVIAL_PASSWORD NOCACHE
-OPTIONS_DEFAULT=IPAUTH IDX_SQL USER_INDEX CATCHALL TRIVIAL_PASSWORD
-IPAUTH_DESC= Check IP address after login
-USER_INDEX_DESC= Enable user index display
-MODIFY_QUOTA_DESC= Allow domain admin to modify quotas
-DOMAIN_AUTOFILL_DESC= Autofill domain on login using hostname
-IDX_DESC= Use ezmlm-idx instead of ezmlm
-IDX_SQL_DESC= Enable MySQL support for ezmlm
-HELP_DESC= Show help links on login page
-SPAM_DETECTION_DESC= Allow users to toggle spam checking
-SPAM_NEEDS_EMAIL_DESC= Append user's email to spam command
-CATCHALL_DESC= Enable catch-all accounts
-TRIVIAL_PASSWORD_DESC= Disallow password containing username
-NOCACHE_DESC= Prohibit caching via http headers
-
# CGIBINDIR - location of your cgi directory
# CGIBINSUBDIR - subdirectory to place cgi scripts in
# CGIBINURL - location of your cgi directory in a URL
@@ -84,12 +76,22 @@ CGIBINURL?= /cgi-bin
WEBDATADIR?= www/data.default
WEBDATASUBDIR?= qmailadmin
WEBDATAURL?=
+MAXUSERSPERPAGE?= 15
+MAXALIASESPERPAGE?= 25
PLIST_SUB+= CGIBINDIR="${CGIBINDIR}" CGIBINSUBDIR="${CGIBINSUBDIR}" \
WEBDATADIR="${WEBDATADIR}" WEBDATASUBDIR="${WEBDATASUBDIR}"
# End of user-configurable variables
+.if empty(PORT_OPTIONS:MIDX)
+BUILD_DEPENDS+= ezmlm-send:${PORTSDIR}/mail/ezmlm
+RUN_DEPENDS+= ezmlm-send:${PORTSDIR}/mail/ezmlm
+.else
+BUILD_DEPENDS+= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
+RUN_DEPENDS+= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
+.endif
+
CONFIGURE_ARGS+= \
--enable-qmaildir=${QMAIL_PREFIX} \
--enable-htmldir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR} \
@@ -100,6 +102,8 @@ CONFIGURE_ARGS+= \
--enable-cgipath=${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
--enable-vpopmaildir=${VPOPMAIL_DIR} \
--enable-autoresponder-path=${LOCALBASE}/bin \
+ --enable-maxusersperpage=${MAXUSERSPERPAGE} \
+ --enable-maxaliasesperpage=${MAXALIASESPERPAGE} \
--enable-ezmlmdir=${LOCALBASE}/bin
.if empty(PORT_OPTIONS:MIPAUTH)