aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2023-12-07 12:21:08 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2023-12-07 12:21:08 +0000
commitc984d8b061c3d692b2190c7432c89a74cb01e991 (patch)
treed5b0f319d4e478e516bad075ac3ec216cc030f5d /mail
parent32715e208d12b45f7e3220684713aac0abdbefc6 (diff)
downloadports-c984d8b061c3d692b2190c7432c89a74cb01e991.tar.gz
ports-c984d8b061c3d692b2190c7432c89a74cb01e991.zip
mail/roundcube-tls_icon: New port
A roundcube plugin to display if a mail was received via TLS.
Diffstat (limited to 'mail')
-rw-r--r--mail/roundcube-tls_icon/Makefile42
-rw-r--r--mail/roundcube-tls_icon/distinfo3
-rw-r--r--mail/roundcube-tls_icon/pkg-plist16
3 files changed, 61 insertions, 0 deletions
diff --git a/mail/roundcube-tls_icon/Makefile b/mail/roundcube-tls_icon/Makefile
new file mode 100644
index 000000000000..41d15be509fd
--- /dev/null
+++ b/mail/roundcube-tls_icon/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= tls_icon
+DISTVERSION= 1.3.1
+CATEGORIES= mail
+PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= netchild@FreeBSD.org
+COMMENT= Roundcube tls_icon plugin
+WWW= https://github.com/GermanCoding/Roundcube_TLS_Icon
+
+LICENSE= MIT
+
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+
+USES= php:flavors
+
+WWWDIR= ${LOCALBASE}/www/roundcube
+NO_ARCH= yes
+NO_BUILD= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= GermanCoding
+GH_PROJECT= Roundcube_TLS_Icon
+
+PLUGDIR= ${WWWDIR}/plugins/tls_icon
+PLIST_SUB+= PLUGDIR="www/roundcube/plugins/tls_icon"
+
+do-install:
+ @${ECHO} "Installing in ${PLUGDIR}"
+ ${MKDIR} ${STAGEDIR}/${PLUGDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}/${PLUGDIR}
+
+gen-plist:
+ ${FIND} ${WRKSRC} -type f -print | ${SORT} | \
+ ${GREP} -v '.gitignore' | \
+ ${SED} -e "s:${WRKSRC}:%%PLUGDIR%%:g" \
+ -e 's:%%PLUGDIR%%/config.inc.php.dist:@sample %%PLUGDIR%%/config.inc.php.dist %%PLUGDIR%%/config.inc.php:' \
+ > pkg-plist.new
+ ${FIND} ${WRKSRC} -type d -print | ${SORT} -r | \
+ ${SED} -e "s:${WRKSRC}:@dir %%PLUGDIR%%:g" >> pkg-plist.new
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-tls_icon/distinfo b/mail/roundcube-tls_icon/distinfo
new file mode 100644
index 000000000000..e0db0a39054a
--- /dev/null
+++ b/mail/roundcube-tls_icon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1701950990
+SHA256 (GermanCoding-Roundcube_TLS_Icon-1.3.1_GH0.tar.gz) = b2152ebeeeaa885f7962b8b39f57b98db57e4921e245e117e6144973c03ce38a
+SIZE (GermanCoding-Roundcube_TLS_Icon-1.3.1_GH0.tar.gz) = 6110
diff --git a/mail/roundcube-tls_icon/pkg-plist b/mail/roundcube-tls_icon/pkg-plist
new file mode 100644
index 000000000000..dae2ac5b4e63
--- /dev/null
+++ b/mail/roundcube-tls_icon/pkg-plist
@@ -0,0 +1,16 @@
+%%PLUGDIR%%/LICENSE
+%%PLUGDIR%%/README.md
+%%PLUGDIR%%/blue_lock.svg
+%%PLUGDIR%%/composer.json
+@sample %%PLUGDIR%%/config.inc.php.dist %%PLUGDIR%%/config.inc.php
+%%PLUGDIR%%/localization/de_DE.inc
+%%PLUGDIR%%/localization/en_US.inc
+%%PLUGDIR%%/localization/fr_FR.inc
+%%PLUGDIR%%/localization/nl_NL.inc
+%%PLUGDIR%%/localization/ru_RU.inc
+%%PLUGDIR%%/lock.svg
+%%PLUGDIR%%/tls_icon.css
+%%PLUGDIR%%/tls_icon.php
+%%PLUGDIR%%/unlock.svg
+@dir %%PLUGDIR%%/localization
+@dir %%PLUGDIR%%