aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-03 17:07:05 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-03 17:07:05 +0000
commitd4076495066a3539ade9dc869200d0b77480ef8d (patch)
treee296c2d9eacd4fb3c5b274cb5179a8891ed4dbf6 /mail
parent098da320bec07b14faaf6702a4ee4a2827e12c55 (diff)
downloadports-d4076495066a3539ade9dc869200d0b77480ef8d.tar.gz
ports-d4076495066a3539ade9dc869200d0b77480ef8d.zip
- Fix race during build of DJB ports that could lead to files leaking out of
STAGEDIR. The auto_home.c/auto_qmail.c (depending on which conf- file is used) must be deleted to or else this might not be executed depending on how quickly build and pre-install run: ./auto-str auto_home `sed 1q conf-home` > auto_home.c - Move STAGEDIR fixing to post-build with a message explaining the rebuild. - Bump PORTREVISION as pkg_install packages may have been built without some files.
Notes
Notes: svn path=/head/; revision=350029
Diffstat (limited to 'mail')
-rw-r--r--mail/qmail-conf/Makefile7
-rw-r--r--mail/qmail-contrib/Makefile11
-rw-r--r--mail/qmailanalog/Makefile9
-rw-r--r--mail/qtools/Makefile7
4 files changed, 19 insertions, 15 deletions
diff --git a/mail/qmail-conf/Makefile b/mail/qmail-conf/Makefile
index 650346fc42fe..b8b228314ca8 100644
--- a/mail/qmail-conf/Makefile
+++ b/mail/qmail-conf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmail-conf
PORTVERSION= 0.60
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= http://www.din.or.jp/~ushijima/qmail-conf/ \
http://cr.yp.to/djbdns/
@@ -44,10 +44,11 @@ pre-build:
# Do a dance to stage and keep out of resulting binaries (see r346769
# and r349241)
-pre-install:
+post-build:
+ @${ECHO_MSG} "===> Rebuilding DJB installer to respect STAGEDIR"
@${MV} -f ${WRKSRC}/conf-qmail ${WRKSRC}/conf-qmail.sav
@${ECHO_CMD} "${STAGEDIR}${QMAIL_PREFIX}" > ${WRKSRC}/conf-qmail
- @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o
+ @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_qmail.o auto_qmail.c
@cd ${WRKSRC} ; ${MAKE_CMD} install instcheck
@${TOUCH} ${WRKSRC}/*-conf
@${MV} -f ${WRKSRC}/conf-qmail.sav ${WRKSRC}/conf-qmail
diff --git a/mail/qmail-contrib/Makefile b/mail/qmail-contrib/Makefile
index 977a88e886d9..e632da8f6951 100644
--- a/mail/qmail-contrib/Makefile
+++ b/mail/qmail-contrib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmail-contrib
PORTVERSION= 0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://cr.yp.to/software/ \
${MASTER_SITE_GENTOO}
@@ -63,23 +63,24 @@ do-build:
# Do a dance to stage and keep out of resulting binaries (see r346769
# and r349241)
-pre-install:
- ${MKDIR} ${STAGEDIR}${QMAIL_PREFIX}/${DOCSDIR}
+post-build:
+ @${ECHO_MSG} "===> Rebuilding DJB installer to respect STAGEDIR"
@${MV} -f ${WRKFF}/conf-qmail ${WRKFF}/conf-qmail.sav
@${ECHO_CMD} "${STAGEDIR}${QMAIL_PREFIX}" > ${WRKFF}/conf-qmail
- @cd ${WRKFF} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o
+ @cd ${WRKFF} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_qmail.o auto_qmail.c
@cd ${WRKFF} ; ${MAKE_CMD} install instcheck
@${TOUCH} ${WRKFF}/newaliases ${WRKFF}/fastforward ${WRKFF}/newinclude
@${MV} -f ${WRKFF}/conf-qmail.sav ${WRKFF}/conf-qmail
@${MV} -f ${WRKDF}/conf-qmail ${WRKDF}/conf-qmail.sav
@${ECHO_CMD} "${STAGEDIR}${QMAIL_PREFIX}" > ${WRKDF}/conf-qmail
- @cd ${WRKDF} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o
+ @cd ${WRKDF} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_qmail.o auto_qmail.c
@cd ${WRKDF} ; ${MAKE_CMD} install instcheck
@${TOUCH} ${WRKDF}/dot-forward
@${MV} -f ${WRKDF}/conf-qmail.sav ${WRKDF}/conf-qmail
do-install:
+ @${MKDIR} ${STAGEDIR}${QMAIL_PREFIX}/${DOCSDIR}
@${MAKE} -C ${WRKDIR}/dot-forward-${DF_VER} ${INSTALL_TARGET}
@${MAKE} -C ${WRKDIR}/fastforward-${FF_VER} ${INSTALL_TARGET}
diff --git a/mail/qmailanalog/Makefile b/mail/qmailanalog/Makefile
index d32d9a25f680..b2e2417df8b3 100644
--- a/mail/qmailanalog/Makefile
+++ b/mail/qmailanalog/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmailanalog
PORTVERSION= 0.70
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= http://cr.yp.to/software/ \
http://www.emaillab.org/djb/qmailanalog/
@@ -47,15 +47,16 @@ post-patch:
# Do a dance to stage and keep out of resulting binaries (see r346769
# and r349241)
-pre-install:
- @${MKDIR} ${STAGEDIR}${QMPREFIX}
+post-build:
+ @${ECHO_MSG} "===> Rebuilding DJB installer to respect STAGEDIR"
@${MV} -f ${WRKSRC}/conf-home ${WRKSRC}/conf-home.sav
@${ECHO_CMD} "${STAGEDIR}${QMPREFIX}" > ${WRKSRC}/conf-home
- @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o
+ @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o auto_home.c
@cd ${WRKSRC} ; ${MAKE_CMD} install instcheck
@${MV} -f ${WRKSRC}/conf-home.sav ${WRKSRC}/conf-home
post-install:
+ @${MKDIR} ${STAGEDIR}${QMPREFIX}
${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${MANPREFIX}/man/man1/
.include <bsd.port.post.mk>
diff --git a/mail/qtools/Makefile b/mail/qtools/Makefile
index 03d490618524..5b46725e0e87 100644
--- a/mail/qtools/Makefile
+++ b/mail/qtools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qtools
PORTVERSION= 0.56
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://www.superscript.com/qtools/
@@ -33,10 +33,11 @@ do-configure:
# Do a dance to stage and keep out of resulting binaries (see r346769
# and r349241)
-pre-install:
+post-build:
+ @${ECHO_MSG} "===> Rebuilding DJB installer to respect STAGEDIR"
@${MV} -f ${WRKSRC}/conf-home ${WRKSRC}/conf-home.sav
@${ECHO_CMD} "${STAGEDIR}${PREFIX}" > ${WRKSRC}/conf-home
- @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o
+ @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o auto_home.c
@cd ${WRKSRC} ; ${MAKE_CMD} install instcheck
@${TOUCH} ${WRKSRC}/replier-config
@${MV} -f ${WRKSRC}/conf-home.sav ${WRKSRC}/conf-home