aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-09-22 01:59:06 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-09-22 01:59:06 +0000
commite088a4f458f3d17260f32449bd6d1f816c2d8df1 (patch)
tree6e18eff901e2521afb1db2785a9e9f659f1f6e7c /mail
parenta96ff3698210fd43ea1a81e6142d74d260669540 (diff)
downloadports-e088a4f458f3d17260f32449bd6d1f816c2d8df1.tar.gz
ports-e088a4f458f3d17260f32449bd6d1f816c2d8df1.zip
Update all ports using OpenSSL and RSA to work without rsaref since
it is no longer required. Apologies to the various maintainers whom I did not yet hear back from, but the ports freeze is coming up in a few hours and I will be verifying all of these ports on a 4.1 machine myself to catch any problems.
Notes
Notes: svn path=/head/; revision=32957
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt/Makefile2
-rw-r--r--mail/mutt14/Makefile2
-rw-r--r--mail/pine4-ssl/Makefile9
-rw-r--r--mail/zmailer/Makefile2
5 files changed, 5 insertions, 12 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index ad7391e1f30b..acefcf5db0fc 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
CFLAGS+= -I${PREFIX}/include/ncurses
.endif
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.endif
.if defined(WITH_DOCS)
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index ad7391e1f30b..acefcf5db0fc 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
CFLAGS+= -I${PREFIX}/include/ncurses
.endif
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.endif
.if defined(WITH_DOCS)
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index ad7391e1f30b..acefcf5db0fc 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
CFLAGS+= -I${PREFIX}/include/ncurses
.endif
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.endif
.if defined(WITH_DOCS)
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
diff --git a/mail/pine4-ssl/Makefile b/mail/pine4-ssl/Makefile
index c9692141bcef..ce65eb1debca 100644
--- a/mail/pine4-ssl/Makefile
+++ b/mail/pine4-ssl/Makefile
@@ -33,19 +33,12 @@ FILESDIR= ${.CURDIR}/files
EXTRA_PATCHES= ${FILESDIR}/extrapatch-*
-USE_OPENSSL= RSA
-
-.include <bsd.port.pre.mk>
+USE_OPENSSL= YES
post-extract:
( cd ${WRKSRC} ; tar xfz ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} )
do-build:
-.if defined(OPENSSL_RSAREF)
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./build bsf EXTRAAUTHENTICATORS=ssl RSAREF=yes)
-.else
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./build bsf EXTRAAUTHENTICATORS=ssl)
-.endif
-PRE_MK_INCLUDED= yes
.include "${MASTERDIR}/Makefile"
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index 31aeca3651ab..ce6c73aad666 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= veers@disturbed.net
GNU_CONFIGURE= yes
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
CONFIGURE_ARGS= --with-openssl
.else
CONFIGURE_ARGS= --without-openssl