aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-11-06 15:38:55 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-11-06 15:38:55 +0000
commitfe5a63ec07e915c60cabbf25c6c19f813e6f0522 (patch)
treed52574ff605461a2db137c647b4f1883167114bf /mail
parente4c96a5eb28b6edf37b06483d5ac102ecfd5a1f4 (diff)
downloadports-fe5a63ec07e915c60cabbf25c6c19f813e6f0522.tar.gz
ports-fe5a63ec07e915c60cabbf25c6c19f813e6f0522.zip
For quite a while now, the only update server for SpamAssassin hasn't
had a valid DNS entry. People have asked about it on the mailing list as far back as August, but literally nobody has replied to any of those posts, and no commits or wiki updates have been made regarding this, making it reasonably appear that nobody on the SpamAssassin team has noticed or cares that SpamAssassin no longer updates. For now, just add a patch that turns sa-update(1) into a no-op. While here, add a couple simple Makefile tweaks and bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=425497
Diffstat (limited to 'mail')
-rw-r--r--mail/spamassassin/Makefile16
-rw-r--r--mail/spamassassin/files/patch-sa-update.raw12
-rw-r--r--mail/spamassassin/pkg-plist2
3 files changed, 18 insertions, 12 deletions
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index 2d14c3aeeb01..88e6da23e000 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spamassassin
PORTVERSION= 3.4.1
-PORTREVISION?= 7 # also bump japanese/spamassassin
+PORTREVISION?= 8 # also bump japanese/spamassassin
CATEGORIES?= mail perl5
MASTER_SITES= APACHE/spamassassin/source CPAN/Mail
DISTNAME= Mail-SpamAssassin-${PORTVERSION}
@@ -29,7 +29,7 @@ CONFLICTS?= ja-spamassassin-[0-9]*
CPE_VENDOR= apache
-USES= perl5 cpe
+USES= cpe perl5
USE_PERL5= configure
USE_LDCONFIG= yes
@@ -78,6 +78,8 @@ SUB_LIST+= SPAMD_OWN="${USERS}:${GROUPS}"
PLIST_SUB+= USER=${USERS} GROUP=${GROUPS}
OPTIONS_SUB= yes
+AS_ROOT_SUB_LIST= RUN_AS_USER="-u ${USERS} -H /var/spool/spamd"
+AS_ROOT_SUB_LIST_OFF= RUN_AS_USER=
DCC_RUN_DEPENDS= dcc-dccd>=1.3.111:mail/dcc-dccd
DKIM_RUN_DEPENDS= p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL \
p5-Mail-DKIM>=0.37:mail/p5-Mail-DKIM \
@@ -91,7 +93,7 @@ RAZOR_RUN_DEPENDS= razor-agents>=2.84:mail/razor-agents
RELAY_COUNTRY_RUN_DEPENDS= p5-Geo-IP>=0:net/p5-Geo-IP
SPF_QUERY_RUN_DEPENDS= p5-Mail-SPF>=0:mail/p5-Mail-SPF
-SSL_USE= OPENSSL=yes
+SSL_USES= ssl
SSL_RUN_DEPENDS= p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL
SSL_CONFIGURE_ON= ENABLE_SSL=yes
SSL_CONFIGURE_OFF= ENABLE_SSL=no
@@ -128,12 +130,6 @@ SUB_LIST+= SQL_FLAG="-Q"
SUB_LIST+= SQL_FLAG=""
.endif
-.if empty(PORT_OPTIONS:MAS_ROOT)
-SUB_LIST+= RUN_AS_USER="-u ${USERS} -H /var/spool/spamd"
-.else
-SUB_LIST+= RUN_AS_USER=""
-.endif
-
.if ${PORT_OPTIONS:MUPDATE_AND_COMPILE} && empty(PACKAGE_BUILDING) && empty(BATCH)
PLIST_SUB+= UPDATE_ON_INSTALL="yes"
.else
@@ -162,8 +158,6 @@ post-patch::
. endif
.endfor
- ${FIND} ${WRKSRC} -name '*.orig' -or -name '*.bak' -delete
-
pre-su-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_LIB} ${WRKSRC}/spamc/libspamc.so ${STAGEDIR}${PREFIX}/lib/libspamc.so.0
diff --git a/mail/spamassassin/files/patch-sa-update.raw b/mail/spamassassin/files/patch-sa-update.raw
new file mode 100644
index 000000000000..ce39c2cfdaf6
--- /dev/null
+++ b/mail/spamassassin/files/patch-sa-update.raw
@@ -0,0 +1,12 @@
+--- sa-update.raw.orig 2016-11-06 15:26:19 UTC
++++ sa-update.raw
+@@ -162,7 +162,8 @@ my %valid_GPG = (
+
+ # Default list of channels to update against
+ #
+-my @channels = ( 'updates.spamassassin.org' );
++#my @channels = ( 'updates.spamassassin.org' );
++my @channels = ();
+
+ my $IGNORE_MIRBY_OLDER_THAN = (24 * 60 * 60 * 7); # 1 week
+
diff --git a/mail/spamassassin/pkg-plist b/mail/spamassassin/pkg-plist
index 13b8309fff86..663c5b15f793 100644
--- a/mail/spamassassin/pkg-plist
+++ b/mail/spamassassin/pkg-plist
@@ -1,4 +1,4 @@
-@unexec if service sa-spamd status | grep -q "spamd is running"; then service sa-spamd stop; fi
+@preunexec if service sa-spamd status | grep -q "spamd is running"; then service sa-spamd stop; fi
bin/sa-awl
bin/sa-check_spamd
bin/sa-compile