aboutsummaryrefslogtreecommitdiff
path: root/math/GiNaC
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-07 07:09:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-07 07:09:03 +0000
commit215b73200a675d39df83b0b7b1918c6f0057a7c0 (patch)
tree23fbcb9692ebf74b5a15855c7944fc45b32a8734 /math/GiNaC
parentbbb040872ed21388056ee9d9de546e2b9fea6818 (diff)
downloadports-215b73200a675d39df83b0b7b1918c6f0057a7c0.tar.gz
ports-215b73200a675d39df83b0b7b1918c6f0057a7c0.zip
add GiNaC, a C++ library for symbolic mathematical calculations
Notes
Notes: svn path=/head/; revision=39165
Diffstat (limited to 'math/GiNaC')
-rw-r--r--math/GiNaC/Makefile31
-rw-r--r--math/GiNaC/distinfo1
-rw-r--r--math/GiNaC/files/patch-ginsh::ginsh_lexer.ll11
-rw-r--r--math/GiNaC/files/patch-ginsh::ginsh_parser.yy19
-rw-r--r--math/GiNaC/pkg-comment1
-rw-r--r--math/GiNaC/pkg-descr8
-rw-r--r--math/GiNaC/pkg-plist52
7 files changed, 123 insertions, 0 deletions
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
new file mode 100644
index 000000000000..48afe1b6071c
--- /dev/null
+++ b/math/GiNaC/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: GiNaC
+# Date created: Mar 7, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GiNaC
+PORTVERSION= 0.7.3
+CATEGORIES= math
+MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/ \
+ http://www.ginac.de/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_BZIP2= yes
+LIB_DEPENDS= cln.1:${PORTSDIR}/math/cln
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-cln-prefix=${PREFIX}
+
+USE_GMAKE= yes
+USE_NEWGCC= yes
+
+INSTALLS_SHLIB= yes
+
+MAN1= ginsh.1 viewgar.1 ginac-config.1
+
+.include <bsd.port.mk>
diff --git a/math/GiNaC/distinfo b/math/GiNaC/distinfo
new file mode 100644
index 000000000000..f20b6e598984
--- /dev/null
+++ b/math/GiNaC/distinfo
@@ -0,0 +1 @@
+MD5 (GiNaC-0.7.3.tar.bz2) = 6a1eed07848290100193ddbae63deed2
diff --git a/math/GiNaC/files/patch-ginsh::ginsh_lexer.ll b/math/GiNaC/files/patch-ginsh::ginsh_lexer.ll
new file mode 100644
index 000000000000..4a21abd620e2
--- /dev/null
+++ b/math/GiNaC/files/patch-ginsh::ginsh_lexer.ll
@@ -0,0 +1,11 @@
+--- ginsh/ginsh_lexer.ll.orig Tue Mar 6 18:18:07 2001
++++ ginsh/ginsh_lexer.ll Tue Mar 6 18:22:06 2001
+@@ -32,6 +32,8 @@
+ #include "ginsh.h"
+ #include "ginsh_parser.h"
+
++extern YYSTYPE yylval;
++
+ #define YY_INPUT(buf, result, max_size) (result = ginsh_input(buf, max_size))
+
+ // Table of all used symbols
diff --git a/math/GiNaC/files/patch-ginsh::ginsh_parser.yy b/math/GiNaC/files/patch-ginsh::ginsh_parser.yy
new file mode 100644
index 000000000000..dc0a74f9ea45
--- /dev/null
+++ b/math/GiNaC/files/patch-ginsh::ginsh_parser.yy
@@ -0,0 +1,19 @@
+--- ginsh/ginsh_parser.yy.orig Wed Feb 28 20:55:04 2001
++++ ginsh/ginsh_parser.yy Tue Mar 6 16:45:06 2001
+@@ -29,6 +29,7 @@
+ %{
+ #include "config.h"
+
++#include <sys/time.h>
+ #include <sys/resource.h>
+
+ #if HAVE_UNISTD_H
+@@ -720,6 +721,8 @@
+ /*
+ * Main program
+ */
++
++int yyparse();
+
+ int main(int argc, char **argv)
+ {
diff --git a/math/GiNaC/pkg-comment b/math/GiNaC/pkg-comment
new file mode 100644
index 000000000000..383821251fd6
--- /dev/null
+++ b/math/GiNaC/pkg-comment
@@ -0,0 +1 @@
+A C++ library for symbolic mathematical calculations
diff --git a/math/GiNaC/pkg-descr b/math/GiNaC/pkg-descr
new file mode 100644
index 000000000000..81f38e6aea2c
--- /dev/null
+++ b/math/GiNaC/pkg-descr
@@ -0,0 +1,8 @@
+GiNaC is an iterated and recursive acronym for GiNaC is Not a CAS,
+where CAS stands for Computer Algebra System. It is designed to allow
+the creation of integrated systems that embed symbolic manipulations
+together with more established areas of computer science (like
+computation-intense numeric applications, graphical interfaces, etc.)
+under one roof.
+
+WWW: http://www.ginac.de/
diff --git a/math/GiNaC/pkg-plist b/math/GiNaC/pkg-plist
new file mode 100644
index 000000000000..a2afa9fb02e8
--- /dev/null
+++ b/math/GiNaC/pkg-plist
@@ -0,0 +1,52 @@
+bin/ginac-config
+bin/ginsh
+bin/viewgar
+include/ginac/add.h
+include/ginac/archive.h
+include/ginac/assertion.h
+include/ginac/basic.h
+include/ginac/clifford.h
+include/ginac/color.h
+include/ginac/coloridx.h
+include/ginac/constant.h
+include/ginac/ex.h
+include/ginac/expair.h
+include/ginac/expairseq.h
+include/ginac/exprseq.h
+include/ginac/fail.h
+include/ginac/flags.h
+include/ginac/function.h
+include/ginac/ginac.h
+include/ginac/idx.h
+include/ginac/indexed.h
+include/ginac/inifcns.h
+include/ginac/isospin.h
+include/ginac/lorentzidx.h
+include/ginac/lortensor.h
+include/ginac/lst.h
+include/ginac/matrix.h
+include/ginac/mul.h
+include/ginac/ncmul.h
+include/ginac/normal.h
+include/ginac/numeric.h
+include/ginac/operators.h
+include/ginac/power.h
+include/ginac/pseries.h
+include/ginac/registrar.h
+include/ginac/relational.h
+include/ginac/simp_lor.h
+include/ginac/structure.h
+include/ginac/symbol.h
+include/ginac/tinfos.h
+include/ginac/version.h
+@dirrm include/ginac
+@unexec install-info --delete %D/info/ginac.info %D/info/dir
+info/ginac.info
+@exec install-info %D/info/ginac.info %D/info/dir
+lib/libginac.a
+lib/libginac.so
+lib/libginac-0.7.so.3
+share/aclocal/ginac.m4
+@dirrm share/doc/GiNaC/reference
+@dirrm share/doc/GiNaC/tutorial
+@dirrm share/doc/GiNaC