aboutsummaryrefslogtreecommitdiff
path: root/math/Imath/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-10 10:11:00 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:18 +0000
commit05044ea01992c28028cc87f374560aad1b6c595d (patch)
treed238fa9faf70458ab3b928a3ca716de78e7d7863 /math/Imath/Makefile
parent0ee9911e8c932f92e7aac08aa64c52b5dbd71f14 (diff)
downloadports-05044ea01992c28028cc87f374560aad1b6c595d.tar.gz
ports-05044ea01992c28028cc87f374560aad1b6c595d.zip
math/Imath: new port (replaces graphics/ilmbase)
Patch series to update OpenEXR and ports that depend on ilmbase/OpenEXR coming up. --------------- Imath is a basic, light-weight, and efficient C++ representation of 2D and 3D vectors and matrices and other simple but useful mathematical objects, functions, and data types common in computer graphics applications, including the "half" 16-bit floating-point type. Imath also includes optional python bindings for all types and functions, including optimized implementations of vector and matrix arrays. Imath was originally developed at Industrial Light & Magic in the early 2000's and was originally distributed as open source as a part of the OpenEXR project. Imath continues to be maintained as a sub-project of OpenEXR, which is now a project of the Academy Software Foundation. See the OpenEXR project's GOVERNANCE.md for more information about how the project operates. WWW: https://github.com/AcademySoftwareFoundation/Imath/
Diffstat (limited to 'math/Imath/Makefile')
-rw-r--r--math/Imath/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/math/Imath/Makefile b/math/Imath/Makefile
new file mode 100644
index 000000000000..78b3b78adb52
--- /dev/null
+++ b/math/Imath/Makefile
@@ -0,0 +1,53 @@
+# Based on the graphics/ilmbase port that was done by: nork@FreeBSD.org
+
+PORTNAME= Imath
+PORTVERSION= 3.0.1
+CATEGORIES= math devel graphics
+
+MAINTAINER= mandree@FreeBSD.org
+COMMENT= C++/Python lib of 2D/3D vector, matrix, math ops for computer graphics
+
+LICENSE= BSD3CLAUSE
+
+USES= cmake compiler:c++14-lang pkgconfig
+
+USE_GITHUB= yes
+GH_TUPLE= AcademySoftwareFoundation:Imath:v${PORTVERSION}
+USE_LDCONFIG= yes
+
+CMAKE_ARGS+= -DCMAKE_DEBUG_POSTFIX= \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
+PLIST_SUB= MAJORVER=${_MAJORVER} \
+ MINVER=${_MINVER} \
+ PLVER=${_PLVER} \
+ VER=${_VER}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS LARGE_STACK PYTHON
+OPTIONS_SUB= yes
+
+LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
+LARGE_STACK_CMAKE_BOOL= IMATH_ENABLE_LARGE_STACK
+
+PYTHON_LIB_DEPENDS= ${PY_BOOST}
+PYTHON_USES= python
+PYTHON_CMAKE_BOOL= PYTHON
+
+_MAJORVER= 3_0
+_VER= 27
+_MINVER= 0
+_PLVER= 0
+
+post-install:
+.for l in libImath
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${l}-${_MAJORVER}.so
+.endfor
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+do-test:
+ cd ${BUILD_WRKSRC} && ctest
+
+.include <bsd.port.mk>