aboutsummaryrefslogtreecommitdiff
path: root/math/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-05 07:58:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-05 07:58:52 +0000
commit18c29c6a7240694673e23dbcaae1c4c29b4d8f15 (patch)
tree0efa9a6f7a2350a9f9a26330101c2a156dda1e8c /math/Makefile
parentf2a3966da67441fbaacec8038719dd65da9af878 (diff)
downloadports-18c29c6a7240694673e23dbcaae1c4c29b4d8f15.tar.gz
ports-18c29c6a7240694673e23dbcaae1c4c29b4d8f15.zip
Msieve is a library and utility for factoring large integers using the most
powerful modern algorithms. It features a stable and very fast implementation of a self-initializing multiple polynomial quadratic sieve (MPQS), plus a highly experimental and unfinished number field sieve (NFS) implementation. Primary design goals are speed, portability and ease of use. Msieve claims to be the fastest implementation for factoring general inputs between 40 and 100 decimal digits. Author: Jason Papadopoulos <jasonp@boo.net> WWW: http://www.boo.net/~jasonp/qs.html PR: ports/107477 Submitted by: Daniel Roethlisberger <daniel at roe.ch>
Notes
Notes: svn path=/head/; revision=181482
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bfe8c7a87774..48d6c9bb9697 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -145,6 +145,7 @@
SUBDIR += mpexpr
SUBDIR += mpfr
SUBDIR += mprime
+ SUBDIR += msieve
SUBDIR += mtl
SUBDIR += mtrxmath
SUBDIR += mumps