aboutsummaryrefslogtreecommitdiff
path: root/math/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-07-09 18:08:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-07-09 18:08:06 +0000
commit4d0e669f8dc658817239bee59b9596acd2eceaf8 (patch)
tree19627229200c86f348277b54bd8cddcbaea2f4ca /math/Makefile
parent25b4607212d5feafbdbc78821d3c257e9703a568 (diff)
downloadports-4d0e669f8dc658817239bee59b9596acd2eceaf8.tar.gz
ports-4d0e669f8dc658817239bee59b9596acd2eceaf8.zip
Add py-jax 0.1.72
JAX is Autograd and XLA, brought together for high-performance machine learning research. With its updated version of Autograd, JAX can automatically differentiate native Python and NumPy functions. It can differentiate through loops, branches, recursion, and closures, and it can take derivatives of derivatives of derivatives. It supports reverse-mode differentiation (a.k.a. backpropagation) via grad as well as forward-mode differentiation, and the two can be composed arbitrarily to any order. What's new is that JAX uses XLA to compile and run your NumPy programs on GPUs and TPUs. Compilation happens under the hood by default, with library calls getting just-in-time compiled and executed. But JAX also lets you just-in-time compile your own Python functions into XLA-optimized kernels using a one-function API, jit. Compilation and automatic differentiation can be composed arbitrarily, so you can express sophisticated algorithms and get maximal performance without leaving Python. You can even program multiple GPUs or TPU cores at once using pmap, and differentiate through the whole thing. Dig a little deeper, and you'll see that JAX is really an extensible system for composable function transformations. Both grad and jit are instances of such transformations. Others are vmap for automatic vectorization and pmap for single-program multiple-data (SPMD) parallel programming of multiple accelerators, with more to come. WWW: https://github.com/google/jax
Notes
Notes: svn path=/head/; revision=541767
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 5f25ba4b96a8..93110c6824c1 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -762,6 +762,7 @@
SUBDIR += py-hdbscan
SUBDIR += py-hdmedians
SUBDIR += py-intspan
+ SUBDIR += py-jax
SUBDIR += py-keras
SUBDIR += py-keras-applications
SUBDIR += py-keras-preprocessing