aboutsummaryrefslogtreecommitdiff
path: root/math/R-cran-RcppRoll/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2017-09-10 12:42:37 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2017-09-10 12:42:37 +0000
commit249ced6bebbb6642612d63b8090e9f1885d41e23 (patch)
treecf66d928791a55a9216a7c224e0415801aa49796 /math/R-cran-RcppRoll/Makefile
parent8c0e2e4c6db50577cd9f9f68b537af1d7b57d851 (diff)
downloadports-249ced6bebbb6642612d63b8090e9f1885d41e23.tar.gz
ports-249ced6bebbb6642612d63b8090e9f1885d41e23.zip
- Add new port: math/R-cran-RcppRoll
Provides fast and efficient routines for common rolling / windowed operations. Routines for the efficient computation of windowed mean, median, sum, product, minimum, maximum, standard deviation and variance are provided. WWW: https://cran.r-project.org/web/packages/RcppRoll/
Notes
Notes: svn path=/head/; revision=449541
Diffstat (limited to 'math/R-cran-RcppRoll/Makefile')
-rw-r--r--math/R-cran-RcppRoll/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/math/R-cran-RcppRoll/Makefile b/math/R-cran-RcppRoll/Makefile
new file mode 100644
index 000000000000..45333d55d37e
--- /dev/null
+++ b/math/R-cran-RcppRoll/Makefile
@@ -0,0 +1,20 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= RcppRoll
+DISTVERSION= 0.2.2
+CATEGORIES= math
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Efficient Rolling / Windowed Operations
+
+LICENSE= GPLv2+
+
+CRAN_DEPENDS= R-cran-Rcpp>0:devel/R-cran-Rcpp
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist,compiles
+
+.include <bsd.port.mk>