aboutsummaryrefslogtreecommitdiff
path: root/math/R-cran-nloptr/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2015-11-15 03:57:20 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2015-11-15 03:57:20 +0000
commit61b298a43d1e0d9b69830fac25335a3468e7d1ea (patch)
treef34d9c95af600efe1b4cfe5a20936de3ab06bddb /math/R-cran-nloptr/Makefile
parentada67a0ded11ab32ab9859413aba534fa7c8a00f (diff)
downloadports-61b298a43d1e0d9b69830fac25335a3468e7d1ea.tar.gz
ports-61b298a43d1e0d9b69830fac25335a3468e7d1ea.zip
- Add new port: math/R-cran-nloptr
nloptr is an R interface to NLopt. NLopt is a free/open-source library for nonlinear optimization, providing a common interface for a number of different free optimization routines available online as well as original implementations of various other algorithms. WWW: https://cran.r-project.org/web/packages/nloptr/
Notes
Notes: svn path=/head/; revision=401681
Diffstat (limited to 'math/R-cran-nloptr/Makefile')
-rw-r--r--math/R-cran-nloptr/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/math/R-cran-nloptr/Makefile b/math/R-cran-nloptr/Makefile
new file mode 100644
index 000000000000..597f1fd8eb13
--- /dev/null
+++ b/math/R-cran-nloptr/Makefile
@@ -0,0 +1,21 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= nloptr
+PORTVERSION= 1.0.4
+CATEGORIES= math
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= R interface to NLopt
+
+LICENSE= LGPL3
+
+LIB_DEPENDS= libnlopt.so:${PORTSDIR}/math/nlopt
+
+USES= cran:auto-plist pkgconfig
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/<<</</' ${WRKSRC}/configure
+
+.include <bsd.port.mk>