aboutsummaryrefslogtreecommitdiff
path: root/math/SoPlex
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-07 22:29:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-07 22:29:46 +0000
commit67a9073255c853a66ec40e20ec79b92c2b44bc85 (patch)
tree9d553fcb5181a65656f17c284dc5954946973eb4 /math/SoPlex
parent9f6655b0e0dc5c41080004b9e7d0f84295ae8364 (diff)
downloadports-67a9073255c853a66ec40e20ec79b92c2b44bc85.tar.gz
ports-67a9073255c853a66ec40e20ec79b92c2b44bc85.zip
Drop FreeBSD 10.3 support
Reviewed by: yuri (SoPlex), sunpoet (nghttp2), cpm (chromium), brooks (llvm*) Approved by: portmgr (rene) Differential Revision: https://reviews.freebsd.org/D15238
Notes
Notes: svn path=/head/; revision=469338
Diffstat (limited to 'math/SoPlex')
-rw-r--r--math/SoPlex/Makefile11
-rw-r--r--math/SoPlex/files/patch-CMakeLists.txt11
2 files changed, 2 insertions, 20 deletions
diff --git a/math/SoPlex/Makefile b/math/SoPlex/Makefile
index b392b963c09c..b752ce2c5494 100644
--- a/math/SoPlex/Makefile
+++ b/math/SoPlex/Makefile
@@ -17,15 +17,8 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
LIB_DEPENDS= libgmp.so:math/gmp
-USES= cmake:outsource,noninja tar:tgz
+USES= cmake:outsource tar:tgz
USE_LDCONFIG= yes
PLIST_SUB= SHL4=${DISTVERSION}.0 SHL2=${DISTVERSION:R}
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
-CMAKE_ARGS= -DFREEBSD_NO_CXX_THREAD_LOCAL_BUG224581:BOOL=ON # https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=224581
-# This also necessitates noninja above for some reason
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/SoPlex/files/patch-CMakeLists.txt b/math/SoPlex/files/patch-CMakeLists.txt
deleted file mode 100644
index 1d739c91b584..000000000000
--- a/math/SoPlex/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2017-12-26 18:14:03 UTC
-+++ CMakeLists.txt
-@@ -85,7 +85,7 @@ if(LEGACY)
- add_definitions(-DTHREADLOCAL=)
- endif()
-
--if(NOT "${CMAKE_CXX_COMPILE_FEATURES}" MATCHES "cxx_thread_local")
-+if(NOT "${CMAKE_CXX_COMPILE_FEATURES}" MATCHES "cxx_thread_local" OR FREEBSD_NO_CXX_THREAD_LOCAL_BUG224581)
- add_definitions(-DTHREADLOCAL=)
- endif()
-