aboutsummaryrefslogtreecommitdiff
path: root/math/aamath/Makefile
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-12 10:58:41 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-12 10:58:41 +0000
commitd285f0f10135d59e30ee6ed71be23b37ed486ec5 (patch)
tree42381865cf7af661f0add1f3fdc9d6f64e435969 /math/aamath/Makefile
parentdeb072054ded0bfe322f470c476a9be85b061bdf (diff)
downloadports-d285f0f10135d59e30ee6ed71be23b37ed486ec5.tar.gz
ports-d285f0f10135d59e30ee6ed71be23b37ed486ec5.zip
Enable readline support.
PR: 85793 Submitted by: Nicola Vitale <nivit@email.it>
Notes
Notes: svn path=/head/; revision=142520
Diffstat (limited to 'math/aamath/Makefile')
-rw-r--r--math/aamath/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
index bea6045d0f38..57d192198056 100644
--- a/math/aamath/Makefile
+++ b/math/aamath/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aamath
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= math textproc
MASTER_SITES= http://fuse.superglue.se/aamath/
@@ -18,8 +19,18 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES+= bin/${PORTNAME}
MAN1= aamath.1
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+LDFLAGS= -lreadline
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS= ${LOCALBASE}/lib/libreadline.so
+.endif
+
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/aamath ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>