aboutsummaryrefslogtreecommitdiff
path: root/math/alglib
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-08-21 02:27:27 +0000
committerWen Heping <wen@FreeBSD.org>2017-08-21 02:27:27 +0000
commit9e13212c8f681f926f95b78b12037dead4e7203a (patch)
treedda3a79122862e062964df91826341dc9b02d252 /math/alglib
parenta835af9c246e43a725d41d3d4b8e61c9c227464b (diff)
downloadports-9e13212c8f681f926f95b78b12037dead4e7203a.tar.gz
ports-9e13212c8f681f926f95b78b12037dead4e7203a.zip
A cross-platform numerical analysis and data processing library. It supports
several programming languages (C++, C#, Pascal, VBA) and several operating systems. ALGLIB features include: * Data analysis (classification/regression, including neural networks) * Optimization and nonlinear solvers * Interpolation and linear/nonlinear least-squares fitting * Linear algebra (direct algorithms, EVD/SVD), direct and iterative linear solvers, Fast Fourier Transform and many other algorithms (numerical integration, ODEs, statistics, special functions) This is a free edition of alglib. WWW: http://www.alglib.net PR: 221681 Submitted by: yuri@rawbw.com
Notes
Notes: svn path=/head/; revision=448448
Diffstat (limited to 'math/alglib')
-rw-r--r--math/alglib/Makefile29
-rw-r--r--math/alglib/distinfo3
-rw-r--r--math/alglib/pkg-descr13
-rw-r--r--math/alglib/pkg-plist16
4 files changed, 61 insertions, 0 deletions
diff --git a/math/alglib/Makefile b/math/alglib/Makefile
new file mode 100644
index 000000000000..c05053e00dda
--- /dev/null
+++ b/math/alglib/Makefile
@@ -0,0 +1,29 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= alglib
+PORTVERSION= 3.11.0
+CATEGORIES= math science
+MASTER_SITES= http://www.alglib.net/translator/re/
+EXTRACT_SUFX= .cpp.gpl.zip
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Numerical analysis and data processing library
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/gpl3.txt
+
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/cpp
+
+do-build:
+ cd ${WRKSRC}/src && \
+ ${CXX} ${CXXFLAGS} -fPIC -Wl,-soname,lib${PORTNAME}.so.3 -shared -o lib${PORTNAME}.so.3 *.cpp
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/lib${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/*.h ${STAGEDIR}${PREFIX}/include/lib${PORTNAME}
+ ${INSTALL_LIB} ${WRKSRC}/src/lib${PORTNAME}.so.3 ${STAGEDIR}${PREFIX}/lib
+ @${LN} -s lib${PORTNAME}.so.3 ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/math/alglib/distinfo b/math/alglib/distinfo
new file mode 100644
index 000000000000..943654679de3
--- /dev/null
+++ b/math/alglib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1503275552
+SHA256 (alglib-3.11.0.cpp.gpl.zip) = 01357d1d3494207bbf38a578f548877a1f7885b8222be6f3fc0fbab5cb192a13
+SIZE (alglib-3.11.0.cpp.gpl.zip) = 2303026
diff --git a/math/alglib/pkg-descr b/math/alglib/pkg-descr
new file mode 100644
index 000000000000..602da74e25e5
--- /dev/null
+++ b/math/alglib/pkg-descr
@@ -0,0 +1,13 @@
+A cross-platform numerical analysis and data processing library. It supports
+several programming languages (C++, C#, Pascal, VBA) and several operating
+systems. ALGLIB features include:
+* Data analysis (classification/regression, including neural networks)
+* Optimization and nonlinear solvers
+* Interpolation and linear/nonlinear least-squares fitting
+* Linear algebra (direct algorithms, EVD/SVD), direct and iterative linear
+ solvers, Fast Fourier Transform and many other algorithms (numerical
+ integration, ODEs, statistics, special functions)
+
+This is a free edition of alglib.
+
+WWW: http://www.alglib.net
diff --git a/math/alglib/pkg-plist b/math/alglib/pkg-plist
new file mode 100644
index 000000000000..04b5a75cedf4
--- /dev/null
+++ b/math/alglib/pkg-plist
@@ -0,0 +1,16 @@
+include/libalglib/alglibinternal.h
+include/libalglib/alglibmisc.h
+include/libalglib/ap.h
+include/libalglib/dataanalysis.h
+include/libalglib/diffequations.h
+include/libalglib/fasttransforms.h
+include/libalglib/integration.h
+include/libalglib/interpolation.h
+include/libalglib/linalg.h
+include/libalglib/optimization.h
+include/libalglib/solvers.h
+include/libalglib/specialfunctions.h
+include/libalglib/statistics.h
+include/libalglib/stdafx.h
+lib/libalglib.so
+lib/libalglib.so.3