aboutsummaryrefslogtreecommitdiff
path: root/math/arpack
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
commit564a799c7173c288d4d3a9be78ac3d2db983d512 (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /math/arpack
parentaf1790bfbbcd5831281907db9c04f3776b8d601c (diff)
downloadports-564a799c7173c288d4d3a9be78ac3d2db983d512.tar.gz
ports-564a799c7173c288d4d3a9be78ac3d2db983d512.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=344614
Diffstat (limited to 'math/arpack')
-rw-r--r--math/arpack/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/math/arpack/Makefile b/math/arpack/Makefile
index 537d48e9c408..c35167d8175b 100644
--- a/math/arpack/Makefile
+++ b/math/arpack/Makefile
@@ -16,11 +16,14 @@ EXTRACT_ONLY= ${PORTNAME}${PORTVERSION}.tar.gz
MAINTAINER= bf@FreeBSD.org
COMMENT= Argand Library: large eigenvalue subroutines (serial version)
+BUILD_DEPENDS= tradcpp:${PORTSDIR}/devel/tradcpp
+
CONFLICTS= arpack-ng-[0-9]*
+CPP= tradcpp
FFLAGS+= -ffixed-line-length-none
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-USE_FORTRAN= yes
+USES= fortran
USE_LDCONFIG= yes
WRKSRC = ${WRKDIR}/ARPACK
@@ -128,7 +131,7 @@ pre-build:
@${ECHO_CMD} "Renaming LAPACK functions ..."
@for f in `${FIND} ${WRKDIR} -type f -mindepth 2 -name '*.f'` ; do \
${MV} $${f} $${f}.unproc ; \
- ${CPP} -C -I${WRKDIR} -imacros arpack_compat_f.h -traditional-cpp \
+ ${CPP} -C -I${WRKDIR} -imacros arpack_compat_f.h \
$${f}.unproc $${f} ; done
do-build: