aboutsummaryrefslogtreecommitdiff
path: root/math/bargraph
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-18 07:43:49 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-18 07:43:49 +0000
commite09b0593bfccf59b0a7a4035051d1c0a58e2e745 (patch)
tree56a93cad02de4a4fd8341d07d47ab53f0d224e24 /math/bargraph
parentfe74f02b021539c91c774cc39050a04e9b18468d (diff)
downloadports-e09b0593bfccf59b0a7a4035051d1c0a58e2e745.tar.gz
ports-e09b0593bfccf59b0a7a4035051d1c0a58e2e745.zip
1: Stagify.
2: add USES=perl5 Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=358228
Diffstat (limited to 'math/bargraph')
-rw-r--r--math/bargraph/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/math/bargraph/Makefile b/math/bargraph/Makefile
index 685d098030b4..412f742bc2ef 100644
--- a/math/bargraph/Makefile
+++ b/math/bargraph/Makefile
@@ -17,23 +17,22 @@ LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/bin/fig2dev:${PORTSDIR}/print/transfig \
${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
+USES= perl5 shebangfix
NO_WRKSUBDIR= yes
NO_BUILD= yes
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+SHEBANG_FILES= bargraph.pl
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bargraph.pl ${PREFIX}/bin/bargraph
+ ${INSTALL_SCRIPT} ${WRKSRC}/bargraph.pl ${STAGEDIR}${PREFIX}/bin/bargraph
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
.if !defined (NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} ${WRKSRC}/samples/*.perf ${WRKSRC}/samples/*.png ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/samples/*.perf ${WRKSRC}/samples/*.png ${STAGEDIR}${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>