aboutsummaryrefslogtreecommitdiff
path: root/math/biggles
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-12 13:38:36 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-12 13:38:36 +0000
commita82ed944cc82e51f886f7a0099bb9c3ab423002c (patch)
treebb5c0307fc287a8186610238342dd2b70db7de54 /math/biggles
parentd732440950c938043bcc7b4bdfb1708c7a9e47f3 (diff)
downloadports-a82ed944cc82e51f886f7a0099bb9c3ab423002c.tar.gz
ports-a82ed944cc82e51f886f7a0099bb9c3ab423002c.zip
. fix build with clang; [1]
. trim Makefile headers; . use new LIB_DEPENDS syntax; . convert USE_GMAKE to modern USES statement. Reported by: Roman Cat <roman-cat@yandex.ru> (at freebsd-ports@) [1]
Notes
Notes: svn path=/head/; revision=327063
Diffstat (limited to 'math/biggles')
-rw-r--r--math/biggles/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/math/biggles/Makefile b/math/biggles/Makefile
index 9ae11ad5fc63..342beb282f1d 100644
--- a/math/biggles/Makefile
+++ b/math/biggles/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: biggles
-# Date created: Nov 25, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= biggles
PORTVERSION= 1.6.6
@@ -19,15 +14,18 @@ COMMENT= Create publication-quality 2D scientific plots
LICENSE= GPLv2
BUILD_DEPENDS= ${PYNUMPY}
-LIB_DEPENDS= plot:${PORTSDIR}/graphics/plotutils
+LIB_DEPENDS= libplot.so:${PORTSDIR}/graphics/plotutils
+USES= gmake
USE_PYTHON= yes
-USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" \
CFLAGS="${CFLAGS} -fPIC" \
LIBPLOT_CPPFLAGS="-I${LOCALBASE}/include" \
LIBPLOT_LDFLAGS="-L${LOCALBASE}/lib -lplot"
+post-patch:
+ @${REINPLACE_CMD} -e '/CC/s,gcc,$$\{CC\},' ${WRKSRC}/make.inc
+
pre-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}