aboutsummaryrefslogtreecommitdiff
path: root/math/blas/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2012-01-23 01:16:10 +0000
committerMaho Nakata <maho@FreeBSD.org>2012-01-23 01:16:10 +0000
commita20eb23df8df51f80dd45c14e905c4967521e81c (patch)
tree83ece9a40dab6aad473f6441f8e6e3f5fc91ddec /math/blas/Makefile
parent98556abd4401ee223eb58168facdedcb6bd71262 (diff)
downloadports-a20eb23df8df51f80dd45c14e905c4967521e81c.tar.gz
ports-a20eb23df8df51f80dd45c14e905c4967521e81c.zip
* Make the BLAS port the secondary port of LAPACK.
* Version number of BLAS port is now accord with LAPACK port. Submitted by: bf
Notes
Notes: svn path=/head/; revision=289643
Diffstat (limited to 'math/blas/Makefile')
-rw-r--r--math/blas/Makefile52
1 files changed, 6 insertions, 46 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index 20ac9ee40438..fefbb787f8b6 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -6,54 +6,14 @@
#
PORTNAME= blas
-PORTVERSION= 1.0
-PORTREVISION= 6
-CATEGORIES= math
-MASTER_SITES= http://www.netlib.org/blas/ \
- http://www.mirrorservice.org/sites/netlib.bell-labs.com/netlib/blas/ \
- ftp://ftp.mirrorservice.org/sites/netlib.bell-labs.com/netlib/blas/ \
- http://netlib.sandia.gov/blas/ \
- http://www.netlib.no/netlib/blas/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tgz
+PORTREVISION= 0
MAINTAINER= maho@FreeBSD.org
-COMMENT= Basic Linear Algebra, level 1, 2, and 3
+COMMENT= Basic Linear Algebra Subroutines
-USE_LDCONFIG= yes
-USE_FORTRAN= yes
-WRKSRC= ${WRKDIR}/BLAS
-SHLIB_MAJOR= 2
+DESCR= ${.CURDIR}/pkg-descr
+BLAS_SLAVEPORT = yes
-PLIST_FILES= lib/libblas.a lib/libblas.so lib/libblas.so.${SHLIB_MAJOR}
+MASTERDIR= ${.CURDIR}/../lapack
-LDFLAGS+= ${FFLAGS}
-LDADD ?= -lgfortran -lm
-SRCCONF= ${NONEXISTENT}
-MAKE_ENV+= LDADD="${LDADD}" \
- SHLIB_MAJOR="${SHLIB_MAJOR}" SRCCONF="${SRCCONF}"
-.for _u in AR NM RANLIB
-MAKE_ENV+= ${_u}="${LOCALBASE}/bin/${_u:L}"
-.endfor
-
-OPTIONS= PROFILE "Build and install a profiling library" Off
-
-.include <bsd.port.options.mk>
-
-.if defined(WITH_PROFILE)
-.if defined(NOPROFILE) || defined(NO_PROFILE) || defined(WITHOUT_PROFILE)
-IGNORE = you have defined WITH_PROFILE, but have also defined\
-WITHOUT_PROFILE, NOPROFILE, or NO_PROFILE
-.elif !exists(/usr/lib/libc_p.a)
-IGNORE = you have chosen WITH_PROFILE, but have not installed the\
-base system profiling libraries
-.endif
-PLIST_FILES+= lib/libblas_p.a
-.else
-MAKE_ENV+= NO_PROFILE=
-.endif
-
-post-patch:
- @${CP} ${FILESDIR}/makefile.lib ${WRKSRC}/Makefile
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"