aboutsummaryrefslogtreecommitdiff
path: root/math/bliss
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-22 22:06:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-22 22:08:40 +0000
commitb27b6f969c16284ccab9424fa09f9b2ccaf3ca14 (patch)
tree5390fba02f02f8161895f56bff6c92e24eaebfe3 /math/bliss
parent20eac646d70c756258ebe2a23415f96255f09cd8 (diff)
downloadports-b27b6f969c16284ccab9424fa09f9b2ccaf3ca14.tar.gz
ports-b27b6f969c16284ccab9424fa09f9b2ccaf3ca14.zip
math/bliss: New port: Tool for computing automorphism groups and canonical forms of graphs
Diffstat (limited to 'math/bliss')
-rw-r--r--math/bliss/Makefile23
-rw-r--r--math/bliss/distinfo3
-rw-r--r--math/bliss/files/patch-Makefile15
-rw-r--r--math/bliss/files/patch-bliss.cc11
-rw-r--r--math/bliss/pkg-descr5
-rw-r--r--math/bliss/pkg-plist14
6 files changed, 71 insertions, 0 deletions
diff --git a/math/bliss/Makefile b/math/bliss/Makefile
new file mode 100644
index 000000000000..0632f16e622b
--- /dev/null
+++ b/math/bliss/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= bliss
+DISTVERSION= 0.73
+CATEGORIES= math
+MASTER_SITES= http://www.tcs.hut.fi/Software/bliss/
+PKGNAMESUFFIX= -graph-tool
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Tool for computing automorphism groups and canonical forms of graphs
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake zip
+
+BINARY_ALIAS= g++=${CXX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libbliss.a ${STAGEDIR}${PREFIX}/lib
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
+ ${CP} ${WRKSRC}/*.hh ${WRKSRC}/*.h ${STAGEDIR}${PREFIX}/include/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/math/bliss/distinfo b/math/bliss/distinfo
new file mode 100644
index 000000000000..3740d1a3adf6
--- /dev/null
+++ b/math/bliss/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621719470
+SHA256 (bliss-0.73.zip) = f57bf32804140cad58b1240b804e0dbd68f7e6bf67eba8e0c0fa3a62fd7f0f84
+SIZE (bliss-0.73.zip) = 94108
diff --git a/math/bliss/files/patch-Makefile b/math/bliss/files/patch-Makefile
new file mode 100644
index 000000000000..c7f1b6191347
--- /dev/null
+++ b/math/bliss/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2015-09-01 07:23:10 UTC
++++ Makefile
+@@ -1,9 +1,9 @@
+-CFLAGS = -I.
+-CFLAGS += -g
++CFLAGS += -I.
++#CFLAGS += -g
+ #CFLAGS += -pg
+ CFLAGS += -Wall
+ CFLAGS += --pedantic
+-CFLAGS += -O9
++#CFLAGS += -O9
+ #CFLAGS += -DBLISS_DEBUG
+ CFLAGS += -fPIC
+
diff --git a/math/bliss/files/patch-bliss.cc b/math/bliss/files/patch-bliss.cc
new file mode 100644
index 000000000000..2f60e86f90c3
--- /dev/null
+++ b/math/bliss/files/patch-bliss.cc
@@ -0,0 +1,11 @@
+--- bliss.cc.orig 2021-05-22 21:39:07 UTC
++++ bliss.cc
+@@ -59,7 +59,7 @@ usage(FILE* const fp, const char* argv0)
+ else program_name = argv0;
+ if(!program_name or *program_name == 0) program_name = "bliss";
+
+- fprintf(fp, "bliss version %s (compiled "__DATE__")\n", bliss::version);
++ fprintf(fp, "bliss version %s (compiled " __DATE__ ")\n", bliss::version);
+ fprintf(fp, "Copyright 2003-2015 Tommi Junttila\n");
+ fprintf(fp,
+ "\n"
diff --git a/math/bliss/pkg-descr b/math/bliss/pkg-descr
new file mode 100644
index 000000000000..082f444b9372
--- /dev/null
+++ b/math/bliss/pkg-descr
@@ -0,0 +1,5 @@
+bliss is an open source tool for computing automorphism groups and canonical
+forms of graphs. It has both a command line user interface as well as C++ and C
+programming language APIs.
+
+WWW: http://www.tcs.hut.fi/Software/bliss/index.html
diff --git a/math/bliss/pkg-plist b/math/bliss/pkg-plist
new file mode 100644
index 000000000000..11d8c8c9a877
--- /dev/null
+++ b/math/bliss/pkg-plist
@@ -0,0 +1,14 @@
+bin/bliss
+include/bliss/bignum.hh
+include/bliss/bliss_C.h
+include/bliss/defs.hh
+include/bliss/graph.hh
+include/bliss/heap.hh
+include/bliss/kqueue.hh
+include/bliss/kstack.hh
+include/bliss/orbit.hh
+include/bliss/partition.hh
+include/bliss/timer.hh
+include/bliss/uintseqhash.hh
+include/bliss/utils.hh
+lib/libbliss.a