aboutsummaryrefslogtreecommitdiff
path: root/math/calctool
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-07 14:07:15 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-07 14:07:15 +0000
commit2fdffa611537d80d72bee7239101fd885c6aca86 (patch)
treee34ae0c200d22ef6c043bd31873e7a25bcd27a0f /math/calctool
parent6e5f23ff54fbdf061b88395c31de79422396e446 (diff)
downloadports-2fdffa611537d80d72bee7239101fd885c6aca86.tar.gz
ports-2fdffa611537d80d72bee7239101fd885c6aca86.zip
math/calctool: USES+= ncurses, link with ncurses, not curses
Also use OPTIONS_SUB=yes. More options framework could be used as well.
Notes
Notes: svn path=/head/; revision=408410
Diffstat (limited to 'math/calctool')
-rw-r--r--math/calctool/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/math/calctool/Makefile b/math/calctool/Makefile
index 9d03ff6b66cb..fa0f5ed66a48 100644
--- a/math/calctool/Makefile
+++ b/math/calctool/Makefile
@@ -15,33 +15,26 @@ USE_LDCONFIG= yes
OPTIONS_DEFINE= X11 TTY XVIEW
OPTIONS_DEFAULT= X11 TTY
+OPTIONS_SUB= yes
X11_DESC= Build X11 version of calctool
TTY_DESC= Build tty version of calctool
XVIEW_DESC= Build tty version of calctool
+TTY_USES= ncurses
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
USE_XORG= x11
BINARIES+= xcalctool
-PLIST_SUB+= X11=""
-.else
-PLIST_SUB+= X11="@comment "
.endif
.if ${PORT_OPTIONS:MTTY}
BINARIES+= tty_calctool
-PLIST_SUB+= TTY=""
-.else
-PLIST_SUB+= TTY="@comment "
.endif
.if ${PORT_OPTIONS:MXVIEW}
BINARIES+= xv_calctool
LIB_DEPENDS+= libxview.so:${PORTSDIR}/x11-toolkits/xview
-PLIST_SUB+= XVIEW=""
-.else
-PLIST_SUB+= XVIEW="@comment "
.endif
.if ${ARCH} == "sparc64"
@@ -55,6 +48,7 @@ post-patch:
-e "s#%%LOCALBASE%%#${LOCALBASE}#g" \
-e "s#%%BINARIES%%#${BINARIES}#g" \
-e "s#%%DATADIR%%#${DATADIR}#g" \
+ -e 's|-ltermcap|$${LDFLAGS} -lncurses|g' \
${WRKSRC}/Makefile
do-install: