aboutsummaryrefslogtreecommitdiff
path: root/math/chuffed
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-11-06 01:23:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-11-06 02:07:07 +0000
commit249081720a998361c3ec20087ae0c4a572e45016 (patch)
tree8355b07f9ee36ff3f521ec92314c576470ab10b3 /math/chuffed
parent73158a3400734e118fcaae808a00f3bc5c05d2f1 (diff)
downloadports-249081720a998361c3ec20087ae0c4a572e45016.tar.gz
ports-249081720a998361c3ec20087ae0c4a572e45016.zip
math/chuffed: Remove GH_TAGNAME
It was left over in the previous update by mistake.
Diffstat (limited to 'math/chuffed')
-rw-r--r--math/chuffed/Makefile6
-rw-r--r--math/chuffed/distinfo6
-rw-r--r--math/chuffed/pkg-plist84
3 files changed, 92 insertions, 4 deletions
diff --git a/math/chuffed/Makefile b/math/chuffed/Makefile
index 49f922e35c2b..e97013426b3f 100644
--- a/math/chuffed/Makefile
+++ b/math/chuffed/Makefile
@@ -1,5 +1,6 @@
PORTNAME= chuffed
DISTVERSION= 0.13.0
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -11,10 +12,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= bison cmake compiler:c++11-lang
USE_GITHUB= yes
-GH_TAGNAME= e04bedd # devel branch: only devel branch is compatible with the current MiniZinc
GH_TUPLE= cp-profiler:cpp-integration:f16b313:cpi/submodules/cp-profiler-integration
+CMAKE_ON= BUILD_SHARED_LIBS
+
+CXXFLAGS+= -fPIC
+
DATADIR= ${PREFIX}/share/minizinc/chuffed
post-install:
diff --git a/math/chuffed/distinfo b/math/chuffed/distinfo
index 2ccf4184cda9..194331463887 100644
--- a/math/chuffed/distinfo
+++ b/math/chuffed/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1699204303
-SHA256 (chuffed-chuffed-0.13.0-e04bedd_GH0.tar.gz) = 42dc36cf0d7a408ccbced3c7c0b1a492898588401ddab435ff2f30580f0293aa
-SIZE (chuffed-chuffed-0.13.0-e04bedd_GH0.tar.gz) = 321590
+TIMESTAMP = 1699226085
+SHA256 (chuffed-chuffed-0.13.0_GH0.tar.gz) = c6a1bff9d12098a6cd996fadb1797b0a23cc1750dcb7d65e8bf767827c363414
+SIZE (chuffed-chuffed-0.13.0_GH0.tar.gz) = 405377
SHA256 (cp-profiler-cpp-integration-f16b313_GH0.tar.gz) = 871b081fbc4ee76077eccd388ff1c6063e0376f365eba2cb9d8ce0ab9a617275
SIZE (cp-profiler-cpp-integration-f16b313_GH0.tar.gz) = 5214
diff --git a/math/chuffed/pkg-plist b/math/chuffed/pkg-plist
index 5a2a2085ba9c..454edc3c9b62 100644
--- a/math/chuffed/pkg-plist
+++ b/math/chuffed/pkg-plist
@@ -1,9 +1,83 @@
bin/fzn-chuffed
+include/chuffed/branching/branching.h
+include/chuffed/branching/impact.h
+include/chuffed/branching/warm-start.h
+include/chuffed/core/assume.h
+include/chuffed/core/engine.h
+include/chuffed/core/options.h
+include/chuffed/core/propagator.h
+include/chuffed/core/sat-types.h
+include/chuffed/core/sat.h
+include/chuffed/flatzinc/ast.h
+include/chuffed/flatzinc/flatzinc.h
+include/chuffed/flatzinc/generated_parser/parser.tab.h
+include/chuffed/globals/EdExplFinder.h
+include/chuffed/globals/bounded_path.h
+include/chuffed/globals/dag.h
+include/chuffed/globals/dconnected.h
+include/chuffed/globals/dtree.h
+include/chuffed/globals/globals.h
+include/chuffed/globals/graph.h
+include/chuffed/globals/mddglobals.h
+include/chuffed/globals/tree.h
+include/chuffed/ldsb/ldsb.h
+include/chuffed/mdd/CFG.h
+include/chuffed/mdd/CYK.h
+include/chuffed/mdd/MDD.h
+include/chuffed/mdd/circ_fns.h
+include/chuffed/mdd/circutil.h
+include/chuffed/mdd/mdd_prop.h
+include/chuffed/mdd/mdd_to_lgraph.h
+include/chuffed/mdd/opcache.h
+include/chuffed/mdd/opts.h
+include/chuffed/mdd/sorters.h
+include/chuffed/mdd/weighted_dfa.h
+include/chuffed/mdd/wmdd_prop.h
+include/chuffed/mip/mip.h
+include/chuffed/mip/simplex.h
+include/chuffed/primitives/primitives.h
+include/chuffed/support/BVec.h
+include/chuffed/support/ParseUtils.h
+include/chuffed/support/dijkstra.h
+include/chuffed/support/dynamic_kmeans.h
+include/chuffed/support/floyd_warshall.h
+include/chuffed/support/heap.h
+include/chuffed/support/kosaraju_scc.h
+include/chuffed/support/lengauer_tarjan.h
+include/chuffed/support/misc.h
+include/chuffed/support/set_finder.h
+include/chuffed/support/sparse_set.h
+include/chuffed/support/trailed_cst_list.h
+include/chuffed/support/union_find.h
+include/chuffed/support/vec.h
+include/chuffed/vars/bool-view.h
+include/chuffed/vars/int-var-el.h
+include/chuffed/vars/int-var-ll.h
+include/chuffed/vars/int-var-sl.h
+include/chuffed/vars/int-var.h
+include/chuffed/vars/int-view.h
+include/chuffed/vars/modelling.h
+include/chuffed/vars/vars.h
+lib/cmake/chuffed/chuffed-config-version.cmake
+lib/cmake/chuffed/chuffed-config.cmake
+lib/cmake/chuffed/chuffed-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/chuffed/chuffed-targets.cmake
+lib/libchuffed.so
+lib/libchuffed_fzn.so
%%DATADIR%%/chuffed.mzn
%%DATADIR%%/edit_distance.mzn
+%%DATADIR%%/experimental/on_restart/fzn_on_restart_complete.mzn
+%%DATADIR%%/experimental/on_restart/fzn_on_restart_last_val_bool.mzn
+%%DATADIR%%/experimental/on_restart/fzn_on_restart_last_val_int.mzn
+%%DATADIR%%/experimental/on_restart/fzn_on_restart_sol_bool.mzn
+%%DATADIR%%/experimental/on_restart/fzn_on_restart_sol_int.mzn
+%%DATADIR%%/experimental/on_restart/fzn_on_restart_status.mzn
+%%DATADIR%%/experimental/on_restart/fzn_on_restart_uniform_int.mzn
%%DATADIR%%/fzn_all_different_int.mzn
%%DATADIR%%/fzn_arg_max_bool.mzn
+%%DATADIR%%/fzn_bounded_dpath_int.mzn
%%DATADIR%%/fzn_circuit.mzn
+%%DATADIR%%/fzn_connected.mzn
%%DATADIR%%/fzn_cost_regular.mzn
%%DATADIR%%/fzn_count_eq.mzn
%%DATADIR%%/fzn_count_eq_par.mzn
@@ -16,18 +90,28 @@ bin/fzn-chuffed
%%DATADIR%%/fzn_count_lt.mzn
%%DATADIR%%/fzn_count_lt_par.mzn
%%DATADIR%%/fzn_cumulative.mzn
+%%DATADIR%%/fzn_dag.mzn
%%DATADIR%%/fzn_disjunctive.mzn
%%DATADIR%%/fzn_disjunctive_strict.mzn
%%DATADIR%%/fzn_distribute.mzn
+%%DATADIR%%/fzn_dpath_int.mzn
+%%DATADIR%%/fzn_dtree_int.mzn
%%DATADIR%%/fzn_global_cardinality_low_up.mzn
%%DATADIR%%/fzn_inverse.mzn
%%DATADIR%%/fzn_nvalue.mzn
%%DATADIR%%/fzn_regular.mzn
+%%DATADIR%%/fzn_seq_precede_chain_int.mzn
+%%DATADIR%%/fzn_steiner.mzn
%%DATADIR%%/fzn_subcircuit.mzn
%%DATADIR%%/fzn_table_int.mzn
+%%DATADIR%%/fzn_tree_int.mzn
+%%DATADIR%%/fzn_value_precede_int.mzn
%%DATADIR%%/redefinitions.mzn
%%DATADIR%%/values_interchange.mzn
%%DATADIR%%/values_sequences.mzn
%%DATADIR%%/variables_interchange.mzn
%%DATADIR%%/variables_sequences.mzn
share/minizinc/solvers/chuffed.msc
+@dir include/chuffed/examples
+@dir include/chuffed/flatzinc/mznlib/experimental/on_restart
+@dir include/chuffed/mzn-models