aboutsummaryrefslogtreecommitdiff
path: root/math/cln/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-17 13:15:18 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-17 13:15:18 +0000
commit60257e8c617e7a8a299f853180a2d49661dcfff2 (patch)
tree5392e3955ad7f6b0115aff543ac5584a6148eb46 /math/cln/Makefile
parent165150882c48ba7a2d9102721263709bee8c190e (diff)
downloadports-60257e8c617e7a8a299f853180a2d49661dcfff2.tar.gz
ports-60257e8c617e7a8a299f853180a2d49661dcfff2.zip
- Convert to USES=libtool
- Add INSTALL_TARGET=install-strip - Remove -fPIC - Use BROKEN_sparc64 - Remove old post-patch and pre-build targets
Notes
Notes: svn path=/head/; revision=365185
Diffstat (limited to 'math/cln/Makefile')
-rw-r--r--math/cln/Makefile29
1 files changed, 6 insertions, 23 deletions
diff --git a/math/cln/Makefile b/math/cln/Makefile
index 3511729de89b..bea1af8d69c3 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cln
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= http://www.ginac.de/CLN/ \
http://www.mirrors.wiretapped.net/security/cryptography/libraries/math/cln/ \
@@ -13,32 +14,14 @@ COMMENT= Class Library for Numbers
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
-USE_AUTOTOOLS= libtool
-USES= gmake pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gmp
+CONFIGURE_ARGS= --with-gmp=${LOCALBASE}
+INSTALL_TARGET= install-strip
+USES= gmake libtool pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
INFO= cln
-STRIP= # none
+BROKEN_sparc64= Does not compile on sparc64
-CFLAGS+= -fPIC
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
-post-patch:
- @${REINPLACE_CMD} 's|/usr/local|${PREFIX}|' ${WRKSRC}/Makefile.in
-
-pre-build:
-.if exists(${LOCALBASE}/lib/libcln.so.3)
-BROKEN= Does not compile when older version is installed. Please pkg_delete old cln first
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>