aboutsummaryrefslogtreecommitdiff
path: root/math/convertall
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-10-24 18:51:36 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-01-27 06:12:26 +0000
commit4f0a5e1540c391610950d6ae9ce64ba0dd218d72 (patch)
treee0e3a0327237691d3fe5df542835ced376d3bfae /math/convertall
parentcc7a787d5f043014dcea80bd0058dd7117a5e308 (diff)
downloadports-4f0a5e1540c391610950d6ae9ce64ba0dd218d72.tar.gz
ports-4f0a5e1540c391610950d6ae9ce64ba0dd218d72.zip
PyQt: Update sip to 6.5.0, reintroduce sip4 and simplify PyQt framework.
SIP: As mentioned in the update from sip to sip5, this is a transitional version to remove what is deprecated in sip4. Sip6 completely removes the deprecated parts. Unfortunately, some ports — mostly cura things — can not use sip6, so we reintroduce sip4. PyQt: At the same time, we took the opportunity to simplify PyQT and propose only one package as for devel/pyside2. */py-qt5-* have been merged — excepted chart, networkauth and webengine — into devel/py-qt5-pyqt. This allows us to be in adequacy with the packages that the author of these libraries proposes, namely: PyQt - devel/py-qt5-pyqt PyQt-Charts - x11-toolkits/py-qt5-chart PyQt-NetworkAuth – net/py-qt5-networkauth PyQt-WebEngine – www/py-qt5-webengine SIP – devel/py-sip py-sip - devel/py-qt5-sip PyQt-builder - devel/py-qtbuilder Qscintilla - devel/py-qt5-qscintilla2 Reviewed by: diizzy, kde Tested by: kai, rhurlin, arrowd, madpilot Approved by: makc, tcberner, kde Differential Revision: https://reviews.freebsd.org/D33237 Exp-run by: antoine
Diffstat (limited to 'math/convertall')
-rw-r--r--math/convertall/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/convertall/Makefile b/math/convertall/Makefile
index 26e7bb443ee2..ebe1d0141f7f 100644
--- a/math/convertall/Makefile
+++ b/math/convertall/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/doc/LICENSE
USES= pyqt:5 python:3.5+ shebangfix
-USE_PYQT= core gui widgets sip
+USE_PYQT= pyqt5 sip
SHEBANG_FILES= source/convertall.py