aboutsummaryrefslogtreecommitdiff
path: root/math/deal.ii
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-15 18:43:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-15 19:33:58 +0000
commitb94fd4ef36a4ab7a609775c8898b0d2866304a16 (patch)
treed7a77734e0d828c481788681a2c18a1e1442ccc2 /math/deal.ii
parent1a86bea35222459cae676d18682b85e919f50512 (diff)
downloadports-b94fd4ef36a4ab7a609775c8898b0d2866304a16.tar.gz
ports-b94fd4ef36a4ab7a609775c8898b0d2866304a16.zip
math/deal.ii: Bundle TBB to not hold up TBB->oneTBB transition in the ports tree
Diffstat (limited to 'math/deal.ii')
-rw-r--r--math/deal.ii/Makefile5
-rw-r--r--math/deal.ii/pkg-plist104
2 files changed, 107 insertions, 2 deletions
diff --git a/math/deal.ii/Makefile b/math/deal.ii/Makefile
index e17458f251e6..cfbde961b4b8 100644
--- a/math/deal.ii/Makefile
+++ b/math/deal.ii/Makefile
@@ -1,6 +1,7 @@
PORTNAME= deal.II
DISTVERSIONPREFIX= v
DISTVERSION= 9.3.1
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -12,8 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= ${LOCALBASE}/include/boost/config.hpp:devel/boost-libs
LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
libhdf5.so:science/hdf5 \
- libmetis.so:math/metis \
- libtbb.so:devel/tbb
+ libmetis.so:math/metis
USES= blaslapack cmake compiler:c++17-lang localbase:ldflags
USE_LDCONFIG= yes
@@ -26,6 +26,7 @@ CMAKE_OFF= DEAL_II_ALLOW_BUNDLED DEAL_II_COMPONENT_EXAMPLES \
DEAL_II_WITH_P4EST DEAL_II_WITH_TRILINOS DEAL_II_WITH_UMFPACK \
DEAL_II_WITH_NANOFLANN DEAL_II_WITH_MUPARSER DEAL_II_WITH_ASSIMP \
DEAL_II_WITH_HDF5
+CMAKE_ON= DEAL_II_FORCE_BUNDLED_TBB # instead of LIB_DEPENDS+=libtbb.so:devel/onetbb, pending https://github.com/dealii/dealii/issues/11561
OPTIONS_DEFINE= ADOLC ARPACK GSL LAPACK MPI NETCDF OPENCASCADE PETSC SCALAPACK SUNDIALS
OPTIONS_DEFAULT= GSL LAPACK # SUNDIALS
diff --git a/math/deal.ii/pkg-plist b/math/deal.ii/pkg-plist
index 22569ea8c1dd..fd1ce5f00434 100644
--- a/math/deal.ii/pkg-plist
+++ b/math/deal.ii/pkg-plist
@@ -147,6 +147,110 @@ include/deal.II/base/work_stream.h
include/deal.II/boost_adaptors/bounding_box.h
include/deal.II/boost_adaptors/point.h
include/deal.II/boost_adaptors/segment.h
+include/deal.II/bundled/tbb/aggregator.h
+include/deal.II/bundled/tbb/aligned_space.h
+include/deal.II/bundled/tbb/atomic.h
+include/deal.II/bundled/tbb/blocked_range.h
+include/deal.II/bundled/tbb/blocked_range2d.h
+include/deal.II/bundled/tbb/blocked_range3d.h
+include/deal.II/bundled/tbb/cache_aligned_allocator.h
+include/deal.II/bundled/tbb/combinable.h
+include/deal.II/bundled/tbb/compat/ppl.h
+include/deal.II/bundled/tbb/concurrent_hash_map.h
+include/deal.II/bundled/tbb/concurrent_lru_cache.h
+include/deal.II/bundled/tbb/concurrent_priority_queue.h
+include/deal.II/bundled/tbb/concurrent_queue.h
+include/deal.II/bundled/tbb/concurrent_unordered_map.h
+include/deal.II/bundled/tbb/concurrent_unordered_set.h
+include/deal.II/bundled/tbb/concurrent_vector.h
+include/deal.II/bundled/tbb/critical_section.h
+include/deal.II/bundled/tbb/enumerable_thread_specific.h
+include/deal.II/bundled/tbb/flow_graph.h
+include/deal.II/bundled/tbb/flow_graph_abstractions.h
+include/deal.II/bundled/tbb/flow_graph_opencl_node.h
+include/deal.II/bundled/tbb/gfx_factory.h
+include/deal.II/bundled/tbb/global_control.h
+include/deal.II/bundled/tbb/internal/_aggregator_impl.h
+include/deal.II/bundled/tbb/internal/_concurrent_queue_impl.h
+include/deal.II/bundled/tbb/internal/_concurrent_unordered_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_async_msg_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_body_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_cache_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_indexer_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_item_buffer_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_join_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_node_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_streaming_node.h
+include/deal.II/bundled/tbb/internal/_flow_graph_tagged_buffer_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_trace_impl.h
+include/deal.II/bundled/tbb/internal/_flow_graph_types_impl.h
+include/deal.II/bundled/tbb/internal/_mutex_padding.h
+include/deal.II/bundled/tbb/internal/_range_iterator.h
+include/deal.II/bundled/tbb/internal/_tbb_hash_compare_impl.h
+include/deal.II/bundled/tbb/internal/_tbb_strings.h
+include/deal.II/bundled/tbb/internal/_tbb_trace_impl.h
+include/deal.II/bundled/tbb/internal/_tbb_windef.h
+include/deal.II/bundled/tbb/internal/_template_helpers.h
+include/deal.II/bundled/tbb/internal/_x86_eliding_mutex_impl.h
+include/deal.II/bundled/tbb/internal/_x86_rtm_rw_mutex_impl.h
+include/deal.II/bundled/tbb/machine/gcc_armv7.h
+include/deal.II/bundled/tbb/machine/gcc_generic.h
+include/deal.II/bundled/tbb/machine/gcc_ia32_common.h
+include/deal.II/bundled/tbb/machine/gcc_itsx.h
+include/deal.II/bundled/tbb/machine/ibm_aix51.h
+include/deal.II/bundled/tbb/machine/icc_generic.h
+include/deal.II/bundled/tbb/machine/linux_common.h
+include/deal.II/bundled/tbb/machine/linux_ia32.h
+include/deal.II/bundled/tbb/machine/linux_ia64.h
+include/deal.II/bundled/tbb/machine/linux_intel64.h
+include/deal.II/bundled/tbb/machine/mac_ppc.h
+include/deal.II/bundled/tbb/machine/macos_common.h
+include/deal.II/bundled/tbb/machine/mic_common.h
+include/deal.II/bundled/tbb/machine/msvc_armv7.h
+include/deal.II/bundled/tbb/machine/msvc_ia32_common.h
+include/deal.II/bundled/tbb/machine/sunos_sparc.h
+include/deal.II/bundled/tbb/machine/windows_api.h
+include/deal.II/bundled/tbb/machine/windows_ia32.h
+include/deal.II/bundled/tbb/machine/windows_intel64.h
+include/deal.II/bundled/tbb/memory_pool.h
+include/deal.II/bundled/tbb/mutex.h
+include/deal.II/bundled/tbb/null_mutex.h
+include/deal.II/bundled/tbb/null_rw_mutex.h
+include/deal.II/bundled/tbb/parallel_do.h
+include/deal.II/bundled/tbb/parallel_for.h
+include/deal.II/bundled/tbb/parallel_for_each.h
+include/deal.II/bundled/tbb/parallel_invoke.h
+include/deal.II/bundled/tbb/parallel_reduce.h
+include/deal.II/bundled/tbb/parallel_scan.h
+include/deal.II/bundled/tbb/parallel_sort.h
+include/deal.II/bundled/tbb/parallel_while.h
+include/deal.II/bundled/tbb/partitioner.h
+include/deal.II/bundled/tbb/pipeline.h
+include/deal.II/bundled/tbb/queuing_mutex.h
+include/deal.II/bundled/tbb/queuing_rw_mutex.h
+include/deal.II/bundled/tbb/reader_writer_lock.h
+include/deal.II/bundled/tbb/recursive_mutex.h
+include/deal.II/bundled/tbb/runtime_loader.h
+include/deal.II/bundled/tbb/scalable_allocator.h
+include/deal.II/bundled/tbb/spin_mutex.h
+include/deal.II/bundled/tbb/spin_rw_mutex.h
+include/deal.II/bundled/tbb/task.h
+include/deal.II/bundled/tbb/task_arena.h
+include/deal.II/bundled/tbb/task_group.h
+include/deal.II/bundled/tbb/task_scheduler_init.h
+include/deal.II/bundled/tbb/task_scheduler_observer.h
+include/deal.II/bundled/tbb/tbb.h
+include/deal.II/bundled/tbb/tbb_allocator.h
+include/deal.II/bundled/tbb/tbb_config.h
+include/deal.II/bundled/tbb/tbb_disable_exceptions.h
+include/deal.II/bundled/tbb/tbb_exception.h
+include/deal.II/bundled/tbb/tbb_machine.h
+include/deal.II/bundled/tbb/tbb_profiling.h
+include/deal.II/bundled/tbb/tbb_stddef.h
+include/deal.II/bundled/tbb/tbb_thread.h
+include/deal.II/bundled/tbb/tbbmalloc_proxy.h
+include/deal.II/bundled/tbb/tick_count.h
include/deal.II/differentiation/ad.h
include/deal.II/differentiation/ad/ad_drivers.h
include/deal.II/differentiation/ad/ad_helpers.h