aboutsummaryrefslogtreecommitdiff
path: root/math/djbfft
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-26 07:40:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-26 07:40:07 +0000
commitcbd0dad33474ae503cd0f30e2033ba9b23ab3c06 (patch)
tree2ffa7444384731a73e75a00279d14efbc0444a10 /math/djbfft
parentba52cc3f2922e21fe288b1114af532c901616bd4 (diff)
downloadports-cbd0dad33474ae503cd0f30e2033ba9b23ab3c06.tar.gz
ports-cbd0dad33474ae503cd0f30e2033ba9b23ab3c06.zip
- Stage support
Notes
Notes: svn path=/head/; revision=346135
Diffstat (limited to 'math/djbfft')
-rw-r--r--math/djbfft/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/math/djbfft/Makefile b/math/djbfft/Makefile
index f9cad28d137c..3247bb44985a 100644
--- a/math/djbfft/Makefile
+++ b/math/djbfft/Makefile
@@ -20,7 +20,6 @@ HEADER_FILES= complex4.h complex8.h fftc4.h fftc8.h fftfreq.h \
fftr4.h fftr8.h real4.h real8.h
LIB_FILES= libdjbfft.a
-NO_STAGE= yes
post-patch:
@${FIND} ${WRKSRC} -type f -exec \
${REINPLACE_CMD} -E -e 's!(djbfft.a)!lib\1!' {} \;
@@ -41,14 +40,14 @@ do-configure:
.endif
pre-su-install:
- @${MKDIR} ${PREFIX}/include/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
do-install:
.for file in ${HEADER_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
.endfor
.for file in ${LIB_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/lib
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/lib
.endfor
.include <bsd.port.pre.mk>